recovery on timer expiry for R2

Unanswered Question
Oct 24th, 2007
User Badges:

Hi


Can anyone tell me how to increase the value of the timer for R2 connection that my calls wouldn't get dropped after 6 seconds of inactivity.


Thanks in Advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Wed, 10/24/2007 - 05:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Does the call connects then drops after 6 secs ?

Or which kind of inactivity are your referring to?

It is happening for incoming or outgoing calls ?


It is possible that something is not correct with the E1 R2 "handshake" as applicable to your country/telco, hence the call drop.


surenx_cisco Wed, 10/24/2007 - 05:36
User Badges:

The log in gatekeeper shows a duration of 6 seconds but a call doesn't get established. This doesn't happen to all calls only to some of them and each of those unsucessful calls show 6 sec duration and 102 disconnect cause code.


This is happening for incoming calls

Here's the config in my Cisco 3640

controller E1 0/0

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled

cas-custom 0

alert-wait-time 20


the last line alert-wait-time was added not long ago but it doesn't help either.


I think I need some solution like this http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080094487.shtml which advices to increase the value of timer T310 but in my case when I connect via R2 it seems that there's no option to increase the timer value.


Thanks in Advance

Paolo Bevilacqua Wed, 10/24/2007 - 05:41
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


you would need a trace of "debug vtsp signal" to understand why the call fails on the R2 side.

Notably your config does not specify a custom contry/telco, so it's possible that in its genericness does not meet in some case what the switch expects.


Actions

This Discussion