Struggling with ADSL on 857w

Unanswered Question
Oct 24th, 2007

Hi,

I'm having difficulty getting my BT ADSL to work on my 857w.

The PPP led is on and the inbound and outbound packet counters are incrementing on the atm interface. I can aslo ping the atm interface.

I have tried debugging the PPP negotiation but it does not return any data.

The configuration is as follows;

Building configuration...

Current configuration : 1542 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname myhost

!

boot-start-marker

boot-end-marker

!

enable secret xxx

enable password xxxxxxxxxxx

!

no aaa new-model

!

resource policy

!

no ip routing

!

!

no ip cef

no ip domain lookup

!

!

!

!

!

!

!

!

interface ATM0

no ip address

ip nat outside

ip virtual-reassembly

no ip route-cache

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

shutdown

!

interface FastEthernet2

shutdown

!

interface FastEthernet3

shutdown

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache

!

interface Dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ppp chap hostname xxxxxxxxxxxxx

ppp chap password 0 xxxxxxxxxxx

!

!

no ip http server

no ip http secure-server

ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

password xxxxxxxxxx

login

!

scheduler max-task-time 5000

end

Any help greatly appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Paolo Bevilacqua Wed, 10/24/2007 - 06:35

hi,

please add:

"ip nat inside"

"ppp ipcp dns request"

"ppp ipcp router default"

under dialer0 interface.

Then if you want your wireless functional, configure:

int vlan0

no ip address

bridge-group 1

no ip nat inside

ip route-cache

int dot11radio0

bridge-group 1

ip route-cache

no shutdown

int bvi1

ip address

ip nat inside

bridge irb

bridge 1 route ip

After that do "show ip route" and try to ping to address shoiwn to route for 0.0.0.0/0

If nothing works can be an issue with ADSL FW, in which case you should access the newer FW at:

ftp://fpt.cisco.com/access/800

The one you want 3.0.31 (or like). There is a document for installation in the same ftp directory.

Hope this helps, please rate post if it does!

paulstone80 Thu, 10/25/2007 - 01:04

Hi,

Thanks for your help.

I tried adding those parameters to the dialer 0 interface but the ADSL still does not work.

I have downloaded the firmware as suggested. Do I need to use the ROM monitor to copy this across to the router?

Thanks

Frank Hoeben Thu, 10/25/2007 - 04:34

Replace the above mentioned 'ip nat inside' on the dialer with 'ip nat outside'.

That should do it.

Sorry, this may not be much help but I had the same issues. After many long phone calls to Cisco it appears that BT don't use the same hardware at each exchange and some of these exchanges play merry hell with this router. I dropped in an 837 and never had another problem( except that I had a seperate wireless lynsys ap)

HTH

Paolo Bevilacqua Tue, 11/20/2007 - 12:08

Hi,

which firmware was not working for you ? I've seen 3.0.14 fix all and any case so far.

paulstone80 Tue, 11/20/2007 - 23:31

Hi,

p.bevilacqua: I did upgrade the firmware but this didn't make any difference, but i don't think the issue was related to the firmware.

I did get the ADSL to work in the end by adding

dsl operating-mode ansi-dmt

to the ATM0 interface.

It seemed that when left in 'operating-mode auto' the router would not negotiate with the exchange.

Actions

This Discussion