EIGRP Default route - best practice.

Answered Question
Oct 24th, 2007
User Badges:

We have a single router that is the last hop router before our firewall and the inside interface, E0, of that router is our default route.

Say E0 is 192.168.1.1, all of our internal routers have 'ip route 0.0.0.0 0.0.0.0 192.168.1.1' configed.


E0 of this router is connected to a switch and two distribution routers are also connected to that switch, and it is through these two distribution routers that all traffic flows from our internal network to the last hop router.


I'd like to get rid of the last hop router which would mean the two distribution routers would actually be the last hop before the firewall.


What is the best way to have a new default route with those two distribution routers? Could I use the L0 interface ip address in each router and distribute that into EIGRP as the default route in essence giving two default routes with the same metric? Would I need to give one a lower metric?


Any suggestion are appreciated.

Correct Answer by royalblues about 9 years 6 months ago

For loadbalancing keep the metric same but it would still depend upon how other devices are connected to the distribution switches. The shortestr metric would be chosen


yes for redistributing only the default route you need to use the route-map

eg


ip route 0.0.0.0 0.0.0.0


router eigrp 100

redistibute static route-map default metric 10000 10 255 1 1500


route-map default permit 10

match ip address 1


access-list 1 permit 0.0.0.0


HTH

Narayan


please rate all useful posts


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
royalblues Wed, 10/24/2007 - 11:04
User Badges:
  • Green, 3000 points or more

Assuming that the next hop from the distribution switches would be the firewall, you can add a default route from the switches pointing to the firewall and then advertise these on the EIGRP.


ip route 0.0.0.0 0.0.0.0


router eigrp 100

redistribute static metric 10000 10 255 1 1500


The metric manipulation would depend whether you want your traffic to be load balance or configure it active/standby between your distribution switches


HTH

Narayan

jkeeffe Wed, 10/24/2007 - 11:45
User Badges:

I would want to load balance so I would keep the metrics the same on both distribution switches right?


Also - I'll have other static routes on those dist. switches that I wouldn't want to be distributed, so would I build a route map containing the default route and use that in a distribute-list? If that is the case do you have a simple example of what that would look like?

Correct Answer
royalblues Wed, 10/24/2007 - 11:59
User Badges:
  • Green, 3000 points or more

For loadbalancing keep the metric same but it would still depend upon how other devices are connected to the distribution switches. The shortestr metric would be chosen


yes for redistributing only the default route you need to use the route-map

eg


ip route 0.0.0.0 0.0.0.0


router eigrp 100

redistibute static route-map default metric 10000 10 255 1 1500


route-map default permit 10

match ip address 1


access-list 1 permit 0.0.0.0


HTH

Narayan


please rate all useful posts


jkeeffe Thu, 10/25/2007 - 07:40
User Badges:

One last question please. Are the metrics you have in the example 'redistibute static route-map default metric 10000 10 255 1 1500' default for EIGRP? If I leave those out of the statement like 'redistibute static route-map default' would the same metrics be applied?

royalblues Thu, 10/25/2007 - 08:02
User Badges:
  • Green, 3000 points or more

Nope it is not the default. You can skip the metrics when you are redistributing a static route.


When you do not issue the metric, the interface metrics are taken


HTH

Narayan

Actions

This Discussion