Getting very slow DSL speed on my 1721 router

Unanswered Question
Oct 24th, 2007

I have a 1721 with an ethernet WIC cloned to a dialer interface. The WIC goes out to a DSL modem. My issue is that ever since I deployed this router, the speed has been diminished enough to make people complain. Its a 3mb circuit, but this is what I show when I pull up the dialer interface:

Dialer0 is up, line protocol is up (spoofing)

Hardware is Unknown

Internet address is <MASKED>

MTU 1500 bytes, BW 3000 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 11/255

Encapsulation PPP, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Interface is bound to Vi1

Last input never, output never, output hang never

Last clearing of "show interface" counters 1d01h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 2250 kilobits/sec

5 minute input rate 133000 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

603534 packets input, 698765983 bytes

394642 packets output, 47367523 bytes

Bound to:

Virtual-Access1 is up, line protocol is up

Hardware is Virtual Access interface

MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,

reliability 255/255, txload 22/255, rxload 51/255

Encapsulation PPP, LCP Open

Open: IPCP

PPPoE vaccess, cloned from Dialer0

Vaccess status 0x44, loopback not set

Keepalive set (10 sec)

Interface is bound to Di0 (Encapsulation PPP)

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters 20:11:48

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 174000 bits/sec, 7 packets/sec

5 minute output rate 5000 bits/sec, 5 packets/sec

427406 packets input, 470254490 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

295171 packets output, 36634198 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

As you can see, the virtual-Access1 interface is showing bandwidth of 56Kbit, whisch looks like ths slowness issue. What do I need to change on my config to get this speed to where it is supposed to be? Here is my currect interfaces config:

interface Loopback0

no ip address

shutdown

!

interface Ethernet0

no ip address

ip virtual-reassembly

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Ethernet0.1

shutdown

no cdp enable

!

interface FastEthernet0

description local LAN

ip address <MASKED>

ip nbar protocol-discovery

ip nat inside

ip virtual-reassembly

speed 100

full-duplex

no cdp enable

!

interface Virtual-Template1

no ip address

!

interface Dialer0

bandwidth 3000

bandwidth inherit 3000

ip address <MASKED>

ip access-group 102 in

ip mtu 1492

ip inspect FIREWALL out

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname <MASKED>t

ppp chap password 7 <MASKED>

ppp pap sent-username <MASKED> password 7 <MASKED>

crypto map *********

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

Thanks for any help!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Wed, 10/24/2007 - 13:37

Hi, bandwith is an informational parameter only, to be used by routing protocol (that you don't have) when calculating metric, and for the %usage stats.

It and does not affect actual performances. Most likely, performance issues are with your ISP infrastructure.

erik.doss Wed, 10/24/2007 - 13:39

Thats what I was kind of thinking. When this location was using a Linksys as a gateway, all seemed fine. When I put the 1721 in, it slowed quit a bit.

Keep in mind I am running a VPN tunnel over the DSL as well.

Paolo Bevilacqua Wed, 10/24/2007 - 17:38

Hi,

can you set FA0 hald duplex and enable "ip route-cache cef" under all interfaces ?

Also, would you be able to add a WIC-1ADSL eliminating the adsl modem/bridge ?

There was an encryption acceleration module available for the 1720 that you may not have, but lack of it is not a probable cause anyway.

erik.doss Thu, 10/25/2007 - 07:35

I had already thought about using an ADSL WIC, but I need to be sure I can use it with the ISP (Don't see why I can't). I already prepared another router with the ADSl WIC to send out.

I may also try an IOS change today, but I don't like doing those remotely.

Paolo Bevilacqua Thu, 10/25/2007 - 07:39

Models that does that w/ integrate interface are the 877 and the 1801. These also supports adsl2+.

erik.doss Thu, 10/25/2007 - 07:54

Is there any chance the IOS type could be causing issues? I am using c1700-advsecurityk9-mz.124-1c.bin

erik.doss Thu, 10/25/2007 - 10:32

Should I keep using the Advanced Security IOS or the IP/ADSL/FW/IDS PLUS IPSEC 3DES IOS?

Paolo Bevilacqua Thu, 10/25/2007 - 11:18

Hi,

Adv. Security is fine as long you don't need the other features, that takes 96 mb ram / 32 flash, while the Adv sec. only requires 64 / 16.

Actions

This Discussion