IP Phone:Receiver won't work for some of the phones

Unanswered Question
Oct 25th, 2007

Hi,

We are running CCM 4.1(3).

We are facing problem on some of the IP Phones(7940), like receiver of these phones are not working.You can only able to hear the voice from Speaker mode.

While ringing if receiver goes off-hook, still the rings are continued untill we press speaker phone to pick up the call.

I feel there is no off-hook signal for the receiver...

Any suggestions to resolve this problem...

Regards,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
AJAZ NAWAZ Thu, 10/25/2007 - 04:31

krishnamurthy

Under the device > phone configuration settings page, scroll down to Product Specific Configuration. What do you have set here?

Ajaz

rob.huffman Thu, 10/25/2007 - 04:43

Hi Krishnamurthy ,

I'm 99% sure its RMA time for these 7940's.This is most likely a problem with the Hookswitch. After deploying Cisco IP Phones for the last few years we (and many others) have found this to be the most common hardware problem. There is a "Best Practice" for cleaning the Hookswitch contacts (link below) that does work on occasion. Usually the phone has to be replaced/RMA'd.

Best?? Practices for Cleaning and Troubleshooting Cisco IP Phone Hookswitch

From this interesting Tech note;

http://www.cisco.com/en/US/products/hw/phones/ps379/products_tech_note09186a00801c0810.shtml

There was also a problem with the 7.2 phone firmware that caused similar looking symptoms but I am pretty sure that it was for the 3rd generation phones 7970/7961/7941. This could be rectified in the short term by booting the phone.

Hope this helps!

Rob

Actions

This Discussion