cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
394
Views
0
Helpful
6
Replies

QoS Config Help

aravindhs
Level 1
Level 1

Hi Experts,

I have an 1841's FE interface (CE router) connecting to a 7600's Gigabit interface. (PE router). The bearer will be locked to 10 Meg as per the customer's requrement. The link will carry Voice and Video traffic to other sites in the Customer's MPLS VPN.

The QoS requirement is to allocate 5 Meg of Voice and 3 Meg of Video on this 10 Mbps link.

Will the following work ? Or, do you suggest I use 'bandwidth' commands under class instead of policing.

I am assuming that the traffic with appropriate DSCPs will get into the higher queues (2 and 3, Q 4 is priority queue) as per the default DSCP-CoS mappings.

class-map match-any Voice

match dscp cs5

match dscp ef

class-map match-any Video

match dscp cs4

match dscp af41

match dscp af42

match dscp af43

class-map match-all System

match dscp cs6

policy-map QuestField

class Voice

police 5000000 125000 125000 conform-action transmit exceed-action drop

class Video

police 3000000 75000 75000 conform-action transmit exceed-action drop

class System

bandwidth percent 20

random-detect dscp-based

Both on the PE and CE, in the outbound direction ; --

interface GigabitEthernet 1/47

ip address 1.1.1.1 255.255.255.252

speed 10

duplex full

bandwidth 10240

ip vrf forwarding Quest_12345

max-reserved-bandwidth 100

Service-Policy QuestField out

interface Fast 0/0

ip addresss 1.1.1.2 255.255.255.252

speed 10

duplex full

bandwidth 10240

max-reserved-bandwidth 100

Service-policy Questfield Out

Thanks

Cheers

Arav

6 Replies 6

lgijssel
Level 9
Level 9

Indeed my suggestion is not to use policing for this. As long as the link can accomodate the maximum bandwidth it is better to use the bandwidth or priority commands in the class map.

Policing will directly lead to dropped packets, using the class map config will merely result in best effort forwarding which I consider preferrable for real time traffic instead of dropping it.

If you are a service provider this might be different because you will also need to forward the resulting traffic on your network and you do not want the customer to exceed his SLA.

regards,

Leo

Leo,

Thank you for your reply. How does this look ? Does the 'priority percent 50' reserve 50 percent of 10 Meg and put the packets in the priority queue ? The requirement is to set 3 Meg dedicated for the Video too.

policy-map QuestField

class Voice

priority percent 50

class Video

bandwidth percent 30

random-detect dscp-based

class System

bandwidth percent 20

random-detect dscp-based

Also, the 7600 PE router is a Gig interface. I understand that setting the "speed 10" on the interface will limit the traffic to 10 Mbps and won't require any rate-limiting on the 7600 to 10 Mbps. How does it all sound ?

Cheers

Thanks,

Arav

Sounds more or less OK.

Do not forget to configure the max-reserved bandwidth on the interface:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a0080087a94.html

Leo

I would use a nested policy map. You can first shape all traffic to 10 mbps and then apply your priority statement to voice traffic. More info regarding this solution is located in the link below.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hqos_c/part40/qctmcli2.htm#wp1060235

Regards

Many Thanks guys ! I will try it out and let you know how it turns out.

Cheers

Arav

LLQ really only has one queue, so splitting traffic into two classes, voice and video, only accomplishes placing a rate limiter on each. This is fine if you think there is a need to drop voice or video traffic that exceeds their caps but usually you want to avoid drops for such real-time traffic. The latter would be better accomplished by just having both in one combined class that defines 80%.

However, for real-time LLQ traffic that can be bursty, such as many videos are, you might want to insure you have some addition bandwidth headroom. A total of 80% for LLQ is a high percentage of the link. Recall reading Cisco recommending not to exceed 50%.

With regard to other traffic, you really don't need to define it, as it will fall into an implicit default class.

I like the idea of setting the interface to 10 Mbps rather than using a shaper.

PS:

Don't use WRED on your video traffic; generally avoid WRED for any non-TCP traffic.

Review Cisco Networking products for a $25 gift card