etherchannel and stp

Unanswered Question
Oct 25th, 2007
User Badges:

I'm setting up etherchannel on aggregation/access layers. Design is as follows


aggregation 6509/6509 running ios

access layer 2960tcl


The access switch currently has a single gbe uplink to each 6509. In my lab, normal stp blocking occurs at the access switch connecting to the secondary 6509 with single uplinks to each 6509.


Now when I implement etherchannel on the uplinks, all 4 ports on the access switch go into stp FWD and the BLK occurs on the secondary 6509 ports. Anyone have an idea as to why that's happening? While I'm not seeing any strange behavior other than that, I've never seen it block there, rather on the access switch.


Here's my configs:


6509 primary:


interface GigabitEthernet4/1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,101

switchport mode trunk

channel-group 1 mode desirable

description #access_gi0/1

no shut

!

interface GigabitEthernet4/2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,101

switchport mode trunk

channel-group 1 mode desirable

description #access_gi0/2

no shut



6509 secondary:


interface GigabitEthernet4/1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,101

switchport mode trunk

channel-group 2 mode desirable

description #access_gi0/11

no shut

!

interface GigabitEthernet4/2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,101

switchport mode trunk

channel-group 2 mode desirable

description #access_gi0/12

no shut



2960 access switch:


interface GigabitEthernet0/1

switchport trunk allowed vlan 100,101

switchport mode trunk

channel-group 1 mode desirable

no shut

!

interface GigabitEthernet0/2

switchport trunk allowed vlan 100,101

switchport mode trunk

channel-group 1 mode desirable

no shut


interface GigabitEthernet0/11

switchport trunk allowed vlan 100,101

switchport mode trunk

channel-group 2 mode desirable

no shut

!

interface GigabitEthernet0/12

switchport trunk allowed vlan 100,101

switchport mode trunk

channel-group 2 mode desirable

no shut


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Thu, 10/25/2007 - 15:56
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Sounds like the 2960 became the root of those Vlans.


Check your stp root placement.

rkazala Thu, 10/25/2007 - 16:27
User Badges:

On my 6500s I have the following:


6509 primary:


spanning-tree vlan 100-101 priority 1


6509 secondary:


spanning-tree vlan 100-101 priority 2


As far as I know this should be good for that.. where else would I be setting priorities?


Francois Tallet Thu, 10/25/2007 - 16:05
User Badges:
  • Gold, 750 points or more

It's very likely that the cost between the two 6509 is now lower through the access switch rather than through the direct link between the 6509.

Lower the cost of the root port of the non-root 6509, or increase the cost of the uplinks on your access switches.

Regards,

Francois

rkazala Thu, 10/25/2007 - 16:29
User Badges:

Here's what I have for the 6500s:


6509 primary:


spanning-tree vlan 100-101 priority 1


6509 secondary:


spanning-tree vlan 100-101 priority 2


What cost settings would you suggest setting and where?


Thanks

Francois Tallet Thu, 10/25/2007 - 16:43
User Badges:
  • Gold, 750 points or more

Use the command "spanning-tree vlan 1-2 cost XXX" on the ports I mentioned earlier.

Or quick hack, as you are running PVST, just configure uplinkfast on your access switch, that should take care of increasing the cost of the uplinks;-)

Regards,

Francois

rkazala Thu, 10/25/2007 - 17:57
User Badges:

I enabled spanning-tree uplinkfast and that seemed to fixed my problem for now. :) thanks!

Francois Tallet Thu, 10/25/2007 - 20:17
User Badges:
  • Gold, 750 points or more

It's just a side effect of uplinkfast. With uplinkfast, we increase the cost of the ports of the access switch so that they preferably become blocking. You could have achieved the same by simply increasing the cost on the uplinks of the access switch.

Regards,

Francois

Actions

This Discussion