send multicast by two GRE tunnels

Unanswered Question
Oct 25th, 2007
User Badges:

Hello everyone:

I have a problem to mount two tunnels with multicast support, I have a server in the IP multicast video 192.168.1.123, group 224.1.1.1 and I must convey this to two multicast tunnels where there are several receivers. But do not get it, someone can help me with this?

Thank you for any help they can give me

pd: A diagram attached


version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cisco2811

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

!

ip cef

!

!

ip multicast-routing

!

!

voice-card 0

no dspfarm

!

!

!

username admin privilege 15 secret 5 $1$sFpN$SXXXXXXYo.KsE40

!

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Tunnel0

ip address 10.10.1.1 255.255.255.0

ip pim sparse-dense-mode

tunnel source Loopback0

tunnel destination 217.127.XXX.188

!

interface Tunnel1

ip address 10.10.2.1 255.255.255.0

ip pim sparse-dense-mode

tunnel source Loopback0

tunnel destination 80.32.XXX.125

!

interface FastEthernet0/0

description INTERNAL_LAN$ETH-LAN$

ip address 192.168.1.254 255.255.255.0

ip pim sparse-dense-mode

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

description WAN$ETH-WAN$

ip address 195.77.XXX.70 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

no ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 195.77.XXX.65

ip route 192.168.3.0 255.255.255.0 Tunnel0

ip route 192.168.4.0 255.255.255.0 Tunnel1

!

!

ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip pim bidir-enable

ip nat inside source route-map salida-fibra interface FastEthernet0/1 overload

!

access-list 23 permit 192.168.1.0 0.0.0.255

access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255

access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.255

access-list 120 permit ip 192.168.1.0 0.0.0.255 any

!

route-map salida-fibra permit 10

match ip address 120

!




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cjnwodo Fri, 10/26/2007 - 00:26
User Badges:

Hi,


In the absence of the configs for the other 2800 I have a few questions/tips, which might help you:

I assume you have pim enabled tunnels on the other Cisco 2811 routers with loopback0 as the source and multicast globally configured [ip multicast-routing]


1) You are setup for PIM sparse-dence mode but I don't see any RP or mapping agent config. If you don't configure this on any of your routers, the network will treat the multicast group 224.1.1.1 as a dence mode group. It should still work albeit the traffic will be flooded everywhere initially, then pruned by those routers that have no members

2) You should have ip pim sparse-dense-mode configured on your loopback0 interfaces

3) Are you using Bi-dir? If not disable it on all routers with no ip pim bidir-enable

4) I hope you know that the static routes on the config you gave-

ip route 192.168.3.0 255.255.255.0 Tunnel0

ip route 192.168.4.0 255.255.255.0 Tunnel1

do nothing for your multicast traffic on that router. What you need to do on the other 2811 routers [192.168.4.254 & 192.168.3.254] is to configure ip route 192.168.1.0 255.255.255.0 tunnel . This will allow those router to perform their rpf to the tunnel interface.

5) Make sure you have ip pim sparse-dense-mode configured on the interfaces [192.168.4.254 & 192.168.3.254]of the other Cisco 2811s.


Check: show ip pim nei On each router should show that the router 192.168.1.254 has 2 neighbours whilst the other routers only have one neighbour [192.168.1.254]


Check: sh ip rpf 192.168.1.123 On the other Cisco 2811s [192.168.4.254 & 192.168.3.254] should show that their tunnel interfaces are the rpf for the source.


HTH

lidium.net Fri, 10/26/2007 - 02:21
User Badges:

HTH hello, thank you very much for your answer, and your suggestions, here attached configuration of two router, which is connected to the Sender multicast and one of the multicast receivers, two receivers are exactly the same.

You might be able to help shape the "RP" or "mapping agent config" because frankly not where to begin this task

Thank you for any help


Router 1: 2811- Connect to Multicast Sender

version 12.4

no service password-encryption

!

hostname cisco2811

!

no aaa new-model

!

!

ip cef

ip multicast-routing

!

username admin privilege 15 secret 5 $1$sFXXXXXX.EReYo.KsE40

!

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

ip pim sparse-dense-mode

!

interface Tunnel0

ip address 10.10.1.1 255.255.255.0

ip pim sparse-dense-mode

tunnel source Loopback0

tunnel destination 217.127.XXX.188

!

interface Tunnel1

ip address 10.10.2.1 255.255.255.0

ip pim sparse-dense-mode

tunnel source Loopback0

tunnel destination 80.32.XXX.125

!

interface FastEthernet0/0

description LOCAL_LAN$ETH-LAN$

ip address 192.168.1.254 255.255.255.0

ip pim sparse-dense-mode

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

description WAN$ETH-WAN$

ip address 195.77.XXX.70 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

ip forward-protocol nd

no ip pim bidir-enable

ip route 0.0.0.0 0.0.0.0 195.77.XXX.65

ip route 192.168.3.0 255.255.255.0 Tunnel0

ip route 192.168.4.0 255.255.255.0 Tunnel1

!

ip nat inside source route-map salida-fibra interface FastEthernet0/1 overload

!

access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255

access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.255

access-list 120 permit ip 192.168.1.0 0.0.0.255 any

!

route-map salida-fibra permit 10

match ip address 120

!


Router 2 2811 - Multicast Receiver

version 12.4

service password-encryption

!

ip cef

no ip domain lookup

ip multicast-routing

!

multilink bundle-name authenticated

username admin privilege 15 password 7 104CXXXXx13

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

ip pim sparse-dense-mode

!

interface Tunnel0

ip address 10.10.1.2 255.255.255.0

ip pim sparse-dense-mode

tunnel source Loopback0

tunnel destination 195.77.XXX.70

!

interface Ethernet0

ip address 192.168.3.251 255.255.255.0

ip pim sparse-dense-mode

ip nat inside

ip virtual-reassembly

hold-queue 100 out

!

interface ATM0

no ip address

no ip route-cache cef

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

ip address 217.127.XXX.188 255.255.255.192

ip nat outside

ip virtual-reassembly

no ip route-cache

no snmp trap link-status

pvc 8/32

encapsulation aal5snap

!

!

ip route 0.0.0.0 0.0.0.0 ATM0.1

ip route 192.168.1.0 255.255.255.0 Tunnel0

ip nat inside source route-map nonat interface ATM0.1 overload

!

access-list 100 permit ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255

access-list 120 deny ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255

access-list 120 permit ip 192.168.3.0 0.0.0.255 any

!

route-map nonat permit 10

match ip address 120

!


Commands en cisco 2811 source multicast

cisco2811#show ip pim neighbor

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

S - State Refresh Capable

Neighbor Interface Uptime/Expires Ver DR

Address Prio/Mode


cisco2811#show ip rpf 192.168.1.123

RPF information for ? (192.168.1.123)

RPF interface: FastEthernet0/0

RPF neighbor: ? (192.168.1.123) - directly connected

RPF route/mask: 192.168.1.0/24

RPF type: unicast (connected)

RPF recursion count: 0

Doing distance-preferred lookups across tables

cjnwodo Fri, 10/26/2007 - 02:42
User Badges:

Hi,


Firstly it looks ti me like your PIM is not working properly, because you have no pim neighbours.


Firstly, let's see if your tunnels work.


On Cisco2811[loop 2.2.2.2]: ping 10.10.1.2 & ping 10.10.2.2



lidium.net Fri, 10/26/2007 - 07:55
User Badges:

Hello cjnwodo:

Yes, both 10.10.1.2 as 10.10.2.2 not work, I have no experience in such tunnels through Loopback, because if the replacement "tunnel source Loopback0" with "tunnel source 195.77. XXX.70 "at all points, the tunnels work perfectly.

Any ideas?

Thanks

cjnwodo Mon, 10/29/2007 - 10:55
User Badges:

Hi,


It's ok to use the tunnel source as loopback0. The only caveat is that each router must be able to route to the loopback 0 of the other router.


Quick test: from cisco2811 [192.168.1.254] do the following: ping ip 80.32.xxx.125 source loopback0


IF this doesn't work then you need to make sure that both routers can route to the loopback address of the other.


HTH

Actions

This Discussion