MoH played by Router always on and off

Unanswered Question
Oct 27th, 2007

Hi there,

Music on Hold - everytime a problem for me ... :-)

I have a 3825 Router as Voicegateway in a branch office. It plays the standard MoH file via Multicast. It works, but the music is kind of choppy.

It starts playing for a second then pauses for a seceond playes again, pause and so on.

I have tryed different moh files and two IOS (12.4.9t2 at at the moment). Also i verified via sniffer that the music comes from the router. Nothing helps.

Any Ideas?

Thanks and many thanks


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
smahbub Thu, 11/01/2007 - 15:23

Try to modify the music threshold on the voice port to see if this has any affect ? The default is -38dBm, and the range is from -70 to -30dBm. Try putting it closer to -70dBm, as this will make VAD kick in for only a very low volume. I would suggest trying a value of -60 dBm for example and see if this has any affect.

hpetihpeti Mon, 11/12/2007 - 23:52


it seems a Cisco TAC found a problem on this issue. If i do a show ephone summary it shows this:

File system max access time 1205408 (us) (last 672934) with late-reads 8

It seems the access time to the flash is to high (regarding TAC it should not be higher then 80000). I will try to replace the flash card and see it this will solve the problem.

Greetings, Ingo

gthjohansson Thu, 01/24/2008 - 04:59

Hi were you ever able to resolve this issue ?

I am experiencing the same sound off on but my scenario is that I am using an external multicast source.



hpetihpeti Thu, 01/24/2008 - 05:06


no, i did not solve it till now. We tryed to replace the flash card - but the stupied router could not read it.

As i am in Europe and the router is in Singapore i need to wait for my next visit there for fixing this ...

But if the problem also happens with external multicast sources, does not seem to be the falsh card then.



gthjohansson Thu, 01/24/2008 - 06:28


I have tried sniffing the egress port towards my voice gateway and I see that the stream stops a few seconds after the sound stops.

I am still doing some debug on this issue in house but I will probably end up doing a tac case soon.



gthjohansson Mon, 01/28/2008 - 03:41


I have worked out a solution to my issue.

My voice gw has two interfaces and the MOH multicast was being received on both interfaces.

We made sure that we would only receive the multicast on one link and that solved the issue




This Discussion