CRTP on GigabitEthernet

Unanswered Question
Oct 28th, 2007

Dear,

I connected cisco 3800 routers with ericsson MD110 PBX over E1 Pri. Routers are connected via satellite link and satellite receivers are connected with routers over GigabitEthernet. Now problem is that CRTP can't be enabled on gigabitehternet. When I issue command “ip rtp header-compression”, I get error message “RTP Header compression not supported for this encapsulation”. My scenario is given below:

PBX---(PRI)---3845---(Ethernet)---Satellite BOX----(VSAT)------ Satellite BOX---(Ethernet)---3825----(PRI)----PBX

Please tell me solution how I can enable cRTP so that I couldn't use minimum bandwidth on satellite link for calls. Waiting for immediate positive response…….

Best regards,

Rameez

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
pranabgaya Sun, 10/28/2007 - 08:36

hello rameez,

what encapsulation showing on int Gigabitethernet .

sh int gi-

is "Encapsulation ARPA, loopback not set" showing

pls paste the o/p of that command

rgds

pranab

rameezsardar Sun, 10/28/2007 - 10:32

Dear Pranab,

Thanks for responding. Below you can find output of sh int gig

R1#show inter gig 0/1

GigabitEthernet0/1 is up, line protocol is up

Hardware is BCM1125 Internal MAC, address is 0019.3045.c811 (bia 0019.3045.c81

1)

Internet address is 192.168.101.2/28

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, link type is autonegotiation, media type is RJ45

output flow-control is XON, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:10, output 00:00:03, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

375 packets input, 38880 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 6 multicast, 0 pause input

0 input packets with dribble condition detected

Dear if you have any solution, please tell me as soon as posible. Waiting...

Regards

Rameez

pranabgaya Sun, 10/28/2007 - 13:34

i tried it in one of our router and getting the same message as u.

pdar073(config)#int fa0/0

pdar073(config-if)#ip rtp head

pdar073(config-if)#ip rtp header-compression

RTP Header compression not supported for this encapsulation

pdar073(config-if)#^Z

Paolo Bevilacqua Sun, 10/28/2007 - 09:33

You can't enable crtp on LAN. If any saving or compression is possible, the satellite box will do for you.

Else get a satellite modem with serial interface so you can enable cRTP on that:

http://cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801a893e.html

Note as a codec you may want to use iLBC codec on the GW, that is much better than other very low bitrate codecs.

Hope this helps, please rate post if it does!

rameezsardar Mon, 10/29/2007 - 01:27

Dear,

thanks for coordination. I tried to configure codec=iLBC but it is not working properly. When i use command "code ilbc" with default mode and call from one phone to other, recieving phone rings just one bell and call drop. If i issue command "code ilbc mode 30", phone rings bell and when i pick up the phone, call connects but no voice travel across phone. I also tried commands:

dial-peer voice 1 voip

rtp payload-type cisco-codec-ilbc 102

codec ilbc mode 30 bytes 200

but problem still there. Now tell me the solution. Waiting for immediate response.

Regards

Paolo Bevilacqua Mon, 10/29/2007 - 04:28

Hi,

please configure ilc also on the terminatig router. That is a DP configured with "incoming called-number X..." and codec ilbc.

rameezsardar Mon, 10/29/2007 - 21:18

Dear, same result, when i dial number phone rings bell but as i pick up handset, call drop......

rameezsardar Tue, 10/30/2007 - 05:54

R1#show run

!

hostname R1

!

boot-start-marker

boot-end-marker

!

card type e1 1 1

logging buffered 51200 warnings

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

!

ip cef

!

multilink bundle-name authenticated

!

isdn switch-type primary-qsig

voice-card 0

no dspfarm

!

voice-card 1

no dspfarm

!

voice service voip

qsig decode

!

username cisco privilege 15 secret xxx

!

controller E1 0/0/0

!

controller E1 0/0/1

!

controller E1 1/0

pri-group timeslots 1-31

!

controller E1 1/1

vlan internal allocation policy ascending

!

interface GigabitEthernet0/1

ip address 192.168.101.2 255.255.255.0

duplex auto

speed auto

media-type rj45

no keepalive

!

interface Serial0/0/1:0

no ip address

!

interface Serial1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn timer T203 30000

isdn timer T310 60000

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

ip route 192.168.102.0 255.255.255.0 192.168.101.1

!

control-plane

!

voice-port 1/0:15

!

dial-peer voice 3 pots

destination-pattern 3...$

port 1/0:15

forward-digits all

!

dial-peer voice 20 voip

destination-pattern 2...$

session target ipv4:192.168.102.2

codec g723ar53

!

end

R1#

++++++++++++++++

R2#sh run

version 12.4

!

hostname R2

!

boot-start-marker

boot-end-marker

!

card type e1 1 1

logging buffered 51200 warnings

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

!

!

ip cef

!

multilink bundle-name authenticated

!

isdn switch-type primary-qsig

voice-card 0

no dspfarm

!

voice-card 1

no dspfarm

!

voice service voip

qsig decode

!

username cisco privilege 15 secret xxx

!

!

controller E1 0/0/0

!

controller E1 0/0/1

!

controller E1 1/0

pri-group timeslots 1-31

!

controller E1 1/1

vlan internal allocation policy ascending

!

!

!

interface GigabitEthernet0/1

ip address 192.168.102.2 255.255.255.0

duplex auto

speed auto

media-type rj45

no keepalive

!

interface Serial1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn timer T203 30000

isdn timer T310 60000

isdn overlap-receiving

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

ip route 192.168.101.0 255.255.255.0 192.168.102.1

!

control-plane

!

voice-port 1/0:15

!

dial-peer voice 2 pots

destination-pattern 2...$

port 1/0:15

forward-digits all

!

dial-peer voice 30 voip

destination-pattern 3...$

session target ipv4:192.168.101.2

codec g723ar53

!

!

!

telephony-service

max-conferences 8 gain -6

transfer-system full-consult

!

!

end

R2#

Note: Due to Character limit, i removed unnecessary information.

No VPN no fW between routers. I configured ilbc, but response as i told in last posts. Waiting.

Rameez

pranabgaya Wed, 10/31/2007 - 02:44

can u add

"voice rtp send-recv" and "voice call send-alert" on both routers .

run" deb isdn q931 " on router to find out the possible call disconnect reason.And hows the bw usage for data when u place a call , check it on source and destination router.

Paolo Bevilacqua Wed, 10/31/2007 - 06:11

Hi, this is due to codec mismatch

as mentioned above, please configure a incoming DP matching the desired coded:

dial-peer voice 444 voip

incoming called-number 3...

codec ... (or use a voice-class with the accepted codes)

Actions

This Discussion