Static route

Unanswered Question
Oct 29th, 2007
User Badges:

Dear all,


As per attached diagrm from Router A I can reach to 10.10.10.2 but from any other router I can't when I do tracert from any other router it goes to router B then stops. for every router in sh ip route 10.10.10.0/30 it shows learn through A. We use BGP as Protocol


Waht can be issue


Regards





Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 10/29/2007 - 03:51
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


It could be a number of things but the most obvious thing to check first is does the CE router have routes back to the source IP addresses of the other routers ie.


when you ping from Router A, router A will use it's 10.10.10.1 interface so the CE router knows how to get back to this. But when you ping from another router it will not be using an address from the 10.10.10.x range so does the CE have routes for the relevant source IP addresses ?


Jon

mahesh-gohil Mon, 10/29/2007 - 03:56
User Badges:

you mean if i install default route

0.0.0.0 0.0.0.0 10.10.10.1 in CE Router then my problem will be solved


Pl. clarify


Regards

Mahesh

Jon Marshall Mon, 10/29/2007 - 03:59
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Mahesh


This would be one thing to try and if the problem is that the CE router doesn't know how to get back to the other routers then the default route would fix your problem.


However this is only one way to fix it. Without more details about routing protocols, redistribution etc. it's difficult to say.


Try adding default route and see if that solves the problem. If it does then you know it is a routing issue on CE router. You can then decide whether you just want to stick with default route or whether you want to investigate a bit more.


Jon

Actions

This Discussion