MOH from Router Flash.

Answered Question
Oct 29th, 2007

Hi,

I'm trying to get multicast MOH working from the router flash, but have been unsuccessful. At the present moment we just get silence when the phone is on hold.

Everything is set up on the Callmanager & the max hop count has been set to 1 on the MOH server.

Please can somebody help?

Thanks!

I have this problem too.
0 votes
Correct Answer by allan.thomas about 9 years 1 month ago

Each MoH audio source and codec combination will be multicasted to a different IP address.

For example if you have only two audio sources 1 and 2 the multicast addresses for each source and codec would be as follows:-

Source Codec IP Address Port

1 G711 u-law 239.10.1.1 16384

1 G711 a-law 239.10.1.2 16384

1 G729 239.10.1.3 16384

1 Wideband 239.10.1.4 16384

2 G711 u-law 239.10.1.5 16384

2 G711 a-law 239.10.1.6 16384

2 G729 239.10.1.7 16384

2 Wideband 239.10.1.8 16384

It is important to know exactly which audio stream and codec Cisco CallManager chooses when you place a device that receives Cisco IOS MoH. Only then can you specify the correct multicast IP address and port number in Cisco IOS.

You currently have two multicast audio sources enabled 1 and 16, therefore have configured the appropriate IP Phone endpoints with the same audio source for user and network hold?

If have not explicitly configured the Network and User source then these devices will use the audio-source file 1 by default.

If this is the case then I would still expect the IOS MoH to stream to the IP address 239.10.1.1 as you have configured, the audio-source number would be irrelevant.

The fact the you do not hear tone on hold when on-hold suggests that CCM is correctly providing the gateway with MoH.

Run the command 'show ccm-manager music-on-hold', this should indicate The IP address and port number of the MoH source that Cisco IOS has been directed to listen to by

Cisco CallManager. Can you post the output.

Make sure that these match those configured in the Cisco IOS MoH with the multicast moh

command.

Regards

Allan.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mciarfello Mon, 10/29/2007 - 10:20

Try this document I created. It has as sample config of the remote site across the WAN that I got working.

If I remember correctly, it took a little more understanding / reading between the linesof the Cisco document to get it to work.

So maybe my notes and config example will help. If not, we'll see what we can do for you.

standardbankcco Tue, 10/30/2007 - 05:31

Hi,

I seem to have done everything on the document, but unfortunately still get blank MOH.

When I do place a call from central to remote site I am using g729. When the central site puts the remote site on hold I see that the RXType on the remote phone changes to G711ulaw, which seems to be correct, but no music.

I have tried different file types i.e alaw/ulaw on the remote router, but no luck.

Just 1 question, do I need multicast routing enabled on the remote router?

Your help is much appreciated.

Thanks!

Zeek Ferraros Wed, 11/14/2007 - 13:55

Hi, I'm having the same problem. I'm trying to configure a 2811 to run MOH from flash and i get no sound or tone.

Here is part of the config:

interface Loopback0

ip address 10.10.10.1 255.255.255.0

---------------------------------------

interface FastEthernet0/0.10

description VLAN 10 for Data

encapsulation dot1Q 10

ip address 10.10.165.1 255.255.255.0

no snmp trap link-status

no cdp enable

!

interface FastEthernet0/0.15

description VLAN 15 for Voice

encapsulation dot1Q 15

ip address 192.168.165.1 255.255.255.0

no snmp trap link-status

----------------------------------------

ccm-manager redundant-host 172.16.1.12 172.16.1.11

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.16.1.11

ccm-manager config

---------------------------------------

mgcp

mgcp call-agent 172.16.1.14 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

----------------------------------------

call-manager-fallback

max-conferences 2 gain -6

ip source-address 192.168.165.1 port 2000

max-ephones 24

max-dn 24

system message primary CM Failed, NOW on SRST

default-destination 7007

moh TheRoadToLucia_ULAW.wav

multicast moh 239.1.1.9 port 16384 route 192.168.165.1 10.10.10.1

---------------------------------------------

This is the sh ephoen summary command output

ephone-1 Mac:0011.21CE.E12B TCP socket:[-1] activeLine:0 DECEASED

mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 debug:1

IP:172.16.1.59 Telecaster 7960 keepalive 0

Max 24, Registered 0, Unregistered 0, Deceased 1, Sockets 0

ephone_send_packet process switched 0

Max Conferences 8 with 0 active (2 allowed)

Skinny Music On Hold Status

Active MOH clients 0 (max 96), Media Clients 0

File TheRoadToLucia_ULAW.wav type WAVE Media_Payload_G711Ulaw64k 160 bytes

Moh multicast on 239.1.1.9 port 16384 via 192.168.165.1

via 10.10.10.1

File play position 345646 file type 2

Play offset 3520, Write offset 24000,File start 46 end 1572846 current type 2

Data at 467396A4, size 32000

RTP ssrc 37872A51 timestamp_offset 0 position 2B9E reposition 0

Max process service interval 224736 (last 217314)

Min interval 20000, missed 0 run 321 (us)

moh_process_service counter 4472422

Max Media process interval 290675 (last 208190) run 7 (us)

File system max access time 50248 (us) (last 42266) with late-reads 0

0 clients interrupt service, 0 process level

0 no-conversion, 0 a-to-mu, 0 mu-to-a

0 packets serviced at interrupt, 0 at process

----------------------------------------------

I hope you guys can help me, it is driving me crazy.

Also I call from my cell to the remote location told them to put me on hold and type the show ccm-manager music-on-hold i get this:

Current active multicast sessions : 0

We have all IP phones 7960

Also call manager is correcly configured.

The wav file is the number 3 and i assigned IP 239.1.1.9

THANK YOU IN ADVANCE

Zeek

allan.thomas Wed, 11/14/2007 - 16:29

As you are already aware, when configuring the base ip address, the base ip address will be incremented by CallManager.

However, you may have multiple audio-sources, are these in fact three multicast audio-sources?

Although the audio file may be number three, you need to ensure that within the MMoH Server in CCM you do have three sources listed.

The reason being, is that there maybe actuall only two multicast audio-sources listed for example, wav number 1 and wav number 3.

In this situation the audio-source will be number two, therefore the first base ip address for wav 3 would actually be 239.1.1.5 G711 u-law. Remember the base address in CCM is still 239.1.1.1 you only increment the address on the multicast moh command.

Also verify that the device pool which the MGCP endpoint is associated with has the appropriate MRGL with the MMoH. I assume that you have specified the MRG for Multicast, and enabled MoH on the server?

Regards

Allan.

allan.thomas Mon, 10/29/2007 - 11:09

Firstly is the audio file on the flash a valid source? To verify this execute the command 'show ephone summary'

If the output returns invalid-media then providing you are using correct audio-file for the MoH region (G711), and the same base address and port then I would remove the 'multicast moh port route , moh , ccm-manager music-on-hold commands and then re-apply.

Incidentally have you specified route interfaces for the MMoH? Certainly on older versions I discovered that it was necessary to create a dummy loopback interface even though it was not necessary, and specify this as a specific MMoh route interface, this was on 12.3(14). I found this is not the case in 12.4.

Please forward your configuration, I will take a look at if for you.

Regards

Allan.

standardbankcco Tue, 10/30/2007 - 05:18

Hi Allan,

Thanks for your reply.

When I entered the 'sh ephone summ' & found that no moh file was detected.

So I removed and re-applied the commands and now it can see the file.

I still have the same issue though, with blank MOH.

Please find the config attached.

Thanks!

allan.thomas Tue, 10/30/2007 - 06:06

Without understanding the topology of your VoIP network, one aspect which does require investigation from looking at your configuration is that voice class codec selection.

This voice class codec is applied to each of the VoIP dial-peers for the UK CallManager cluster, and the preference is to use G711 ulaw. However your audio file in the configuration is listed as ALAW.

It is assumed that the UK CallManager cluster is configured with MMoH and that the a specific device pool is assigned to this resource in order to ensure that G711 is used between all configured regions.

If this is the case, then ensure that your CCM audiosource is the same format. Note that you configure the CCM MoH server to either increment the multicast base address or port number for different codecs, So I suspect that there is mismatch.

Also verify whether Multicast MoH resource is actually being used by using perfmon or the RTMT depending whether your CCM is Windows or Linux based. This is determine also whether your media resource groups are configured correctly.

Regards

Allan.

standardbankcco Tue, 10/30/2007 - 09:50

Hi Alan,

I was just testing with the different audio files(ulaw/alaw). At the moment it is a ulaw file.

A UK cluster has a specific DP configured for MMoH & the region is configured for G711.

CCM audio server/ source details attached.

How can I tell if there is a mismatch?

I have used RTMT and it seems that we are definately using the MMoH Resource.

Thanks!

Attachment: 
allan.thomas Tue, 10/30/2007 - 17:43

As I have said previously the multicast base ip address or port is incremented for each audio source and codec.

In your case the MMoH has been configured to increment on the ip address, therefore the multicast address would increment by one for each source and codec.

For example the multicast address for stream 16 would actually start from 239.10.1.61 and would then increment by 1 for each codec. The next audio stream would then start at 239.10.1.65 and the whole process is repeated.

G711 U-Law - 239.10.1.61

G711 A-Law - 239.10.1.62

G729 - 239.10.1.63

Wideband - 239.10.1.64.

You have two options, initially reconfigure the moh multicast address in IOS to either .61 or .62 depending on your audio-file on the flash.

If that fails, it may be simpler to renumber your audio sources, and configure the audio source for SRST as number one. This would ensure that the very first ip address is used 239.10.1.1 (U-Law) or 239.10.1.2 (A-Law).

mike.lo Wed, 10/31/2007 - 00:45

another question: if there are 2 routers in the same remote site, can i put 2 different file sources so that 2 groups of user can receive different music?

standardbankcco Wed, 10/31/2007 - 02:36

How does source 16 correlate to 239.10.1.61?

Please not that the sources before are not all multicast enabled.

Correct Answer
allan.thomas Wed, 10/31/2007 - 03:52

Each MoH audio source and codec combination will be multicasted to a different IP address.

For example if you have only two audio sources 1 and 2 the multicast addresses for each source and codec would be as follows:-

Source Codec IP Address Port

1 G711 u-law 239.10.1.1 16384

1 G711 a-law 239.10.1.2 16384

1 G729 239.10.1.3 16384

1 Wideband 239.10.1.4 16384

2 G711 u-law 239.10.1.5 16384

2 G711 a-law 239.10.1.6 16384

2 G729 239.10.1.7 16384

2 Wideband 239.10.1.8 16384

It is important to know exactly which audio stream and codec Cisco CallManager chooses when you place a device that receives Cisco IOS MoH. Only then can you specify the correct multicast IP address and port number in Cisco IOS.

You currently have two multicast audio sources enabled 1 and 16, therefore have configured the appropriate IP Phone endpoints with the same audio source for user and network hold?

If have not explicitly configured the Network and User source then these devices will use the audio-source file 1 by default.

If this is the case then I would still expect the IOS MoH to stream to the IP address 239.10.1.1 as you have configured, the audio-source number would be irrelevant.

The fact the you do not hear tone on hold when on-hold suggests that CCM is correctly providing the gateway with MoH.

Run the command 'show ccm-manager music-on-hold', this should indicate The IP address and port number of the MoH source that Cisco IOS has been directed to listen to by

Cisco CallManager. Can you post the output.

Make sure that these match those configured in the Cisco IOS MoH with the multicast moh

command.

Regards

Allan.

standardbankcco Wed, 10/31/2007 - 04:13

Hi Alan,

I don't get any multicast sesseions.

MOS7RT_3745_WAN#sh ccm-manager music-on-hold

Current active multicast sessions : 0

Also when I have a look at the IP flows it looks like the phone is still trying to go to the CCM.

allan.thomas Wed, 10/31/2007 - 04:35

When you run the command, ensure that you have an active call on hold first. Sorry, I should have mentioned that.

standardbankcco Wed, 10/31/2007 - 05:11

I had a call on hold at the time.

Anyway I have it working now. Found that it was using 239.10.1.5.

The weird thing is that I still don't get anything when I do the 'sh ccm-m mu' command.

Any ideas?

Thanks for your help.

allan.thomas Wed, 10/31/2007 - 06:03

The show ccm-manager music-on-hold command shows only PSTN connections on hold. It does not show multicast streams going to IP phones on hold.

When an IP phone is placed on hold, and the MoH is sourced from a Cisco IOS gateway, the MoH signaling is directly between Cisco CallManager and the IP phone.

In this scenario, the Cisco IOS gateway plays no role other than to blindly stream multicast RTP packets to the IP phone.

Keep in mind that if you hear MoH, it does not necessarily mean that multicast Cisco IOS MoH is working as expected.

If the PSTN caller hears MoH, but the show ccm-manager music-on-hold command shows no

active multicast streams, then the MoH has come from a unicast.

This can be confirmed if you check the MoH perfmon mentioned earlier. I believe you mentioned that the multicast resource was being selected in a previous post, if that the case then you should see an active session.

The fact that you had only two multicast audio sources 1 and 16 select and not all 16 as shown in the audio source giff, then in the case this is the second audio source hence the first ip address for this audio source would be 239.10.1.5 for u-law.

Regards

Allan.

standardbankcco Wed, 10/31/2007 - 06:53

Hi Allan,

I have one problem it looks like when a call from the PSTN is put on hold it goes to 239.10.1.6 alaw, but internal calls go to 239.10.1.5 ulaw.

MOS7RT_2821_WAN03#sh ccm-manager music-on-hold

Current active multicast sessions : 1

Multicast RTP port Packets Call Codec Incoming

Address number in/out id Interface

===================================================================

239.10.1.6 16384 1169/1169 1983794 g711alaw Lo220

How do I change internal calls to go to alaw?

allan.thomas Wed, 10/31/2007 - 09:09

Have you tried configuring a different voice class codec which has g711 alaw as it first preference and applying this to your CCM voip dial-peers instead?

Regards

Allan.

standardbankcco Wed, 10/31/2007 - 09:47

No not yet.

I will be changing the MOH codecs in service parameters so that g.711 ulaw is not selected.

Actions

This Discussion