Removing Tacacs+ ????

Answered Question
Oct 29th, 2007

Hello,

I removed Tacacs from my router config by "no aaa new-model" but I am not anymore able to login by the username and password that I had already configured on my router.

How can I activate this username and password?

I have this problem too.
0 votes
Correct Answer by romeocz about 9 years 1 month ago

Persepolis77,

You need to re-enable aaa new-model.

You need this command to be able to use your local username and password command. You don't need to run TACACS on your routers. You can use LOCAL authentication. I think that is what you are trying to do anyway.

Right now your router is local for only the password on your vty lines and enable password.

Most likely you didn't set up a password for your "line vty" so you will have to console into the equipment.

Sorry

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
romeocz Mon, 10/29/2007 - 15:32

Persepolis77,

You need to re-enable aaa new-model.

You need this command to be able to use your local username and password command. You don't need to run TACACS on your routers. You can use LOCAL authentication. I think that is what you are trying to do anyway.

Right now your router is local for only the password on your vty lines and enable password.

Most likely you didn't set up a password for your "line vty" so you will have to console into the equipment.

Sorry

persepolis77 Tue, 10/30/2007 - 06:06

Thanks alot romeocz,

I re-enabled aaa new-model and diabled my Tacacs only by :

no aaa authentication login xxx group tacacs+ local

no aaa authentication enable default group tacacs+ enable

no aaa authorization exec default group tacacs+ none

no aaa accounting commands 15 default start-stop group tacacs+

then added :

aaa authentication login default local

and my local username and password work fine.

Thank you again.

Actions

This Discussion