Direct transfer to VM in Call Manager 5.1

Unanswered Question

Hi All,

Is there a way to directly call or transfer into a voicemail in call manager 5.1?

I used to be able to do it in 4.x but now it does not work in 5.1

For instance i could dial *5000 and it would put me directly into 5000 voicemail.

This is how i did it.

Created a CTI route point *XXXX and forward all to voicemail.

On voicemail profile make the mask XXXX

I do the same in 5.x and when i dial *5000 i get unity but it is asking for me to login where 4.x would play the greeting for the user and i can leave a message

anyway to do this in 5.x

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
allan.thomas Mon, 10/29/2007 - 15:13

I have certainly successfully configured this within CallManager5.0x, therefore I should see no reason for this to fail in subsequent releases.

Incidentally, have you allocated or assigned the transfer to voicemail profile that you created to the CTI route point DN?



Yep, on the CTI Route point i have it using the Unity profile.

It does get to unity but it is asking for a password instead of getting the users greeting.

This is with Unity Connections, but i've had Connections working with this before as well.

Does anyone know of a tool like regular unity has that you can watch the Digits coming over from call manager to unity?

Jon Nelson Tue, 10/30/2007 - 07:44

A few things to check just in case. Make sure the mask on the VM profile is set to XXXX and also make sure that the DN on the CTI route point has the proper VM profile. Last, make sure that both the mask on the VM profile and the DN are setup using capital X's ...

You can use Unity Call Viewer to see the digits being passed to Unity from CallManager. It is located under the Unity Tools Depot.

Thank you,


Jon Nelson Tue, 10/30/2007 - 07:49

Got it. Thanks for the info. I have used the Xfer to VM on CM4-6 and Unity and Unity Connection 1.2, but not 2.0. I have a copy running in the lab. I will try and get to something by the end of the day.

Thank you,


I found a port monitor tool on for Connections 2.x

It requires you open a port on the server using Cisco Utilities Data Link for Informix. But that utility says it only works on Non production systems.

Any versions of this that can run on production versions? or maybe a newer version of the port monitor that does not need you to open the ports with the data link tool?

mimalloy Fri, 11/16/2007 - 11:31

Anybody have a fix? I have the same problem. using the same config I used on CCM3. and 4. and it's not working on 5.1.2. Call Viewer shows called number as pilot number and nowhere do I see sunscribers extn. Thanks.....MM

mimalloy Tue, 11/20/2007 - 08:01

I got mine fixed.

We have an 8xxxx route pattern and our VM pilot is 83191.

I think we might have been sending the calls out to the PBX and then the PBX was sending the calls back to Unity as a DIRECT call instead of a FWD call. (Never got a chance to verify)

I deleted my VM ports, line group, hunt pilot, VM pilot number, VM profile etc.

Ran the VM Port Wizard and rebuilt everything from scratch and now it works fine.?!?!?!?

I still have the 8xxxx route pattern and my VM pilot is still 83191.

Nothing changed, but now it works.


Must be some weird black magic inside CM513.....Mike

nrichie Thu, 01/03/2008 - 07:00

I ran into the exact same problem today. We were trying to forward to VM by using *XXX. However, when the call went to Unity, you received the standard Unity greeting, not the users greeting. I resolved it by deleting both the VM profile and the CTI route point and recreating them. This time I used # instead of * (not sure if that made a difference or not). The only other difference was the order that I created them in. The first time, the CTI route point was already configured and I then created the VM profile and associated the 2. The second time, I created the VM profile first and then the CTI route point.

Not sure if this helps, but thought I would chip in. BTW - we are using CUCM 5.1(3) and Unity 4.2(1).



dennisbehrens Sun, 01/13/2008 - 08:43

If you have set the Alerting Name on the CTI Route Point DN, try removing it. I was just viewing the SvcHost trace files within Unity 5.0(1) with TSP 8.2(1) and saw that Unity was detecting the forwarded call as coming from a Voice Mail port. I believe it's either detecting the word "Voicemail", or matching it against the Alerting Name of the voicemail ports. I have a TAC case open and will update with the results.

r.volta Fri, 08/01/2008 - 07:45

I didn't buy it at first, but deleted the Alerting Name "Voicemail" and it works.

CUCM 6.1.1

Thanks guys,



This Discussion