CME Forwarding Number

Unanswered Question
Oct 29th, 2007


Currently, when someone forwards all of their calls to a new number, the q931 debug shows the calling number as the original number that called. I would like the forward to display the number that has been forwarded from.


6500 0313 (external) calls extension 95010260 who is forwarding to their mobile. I want the mobile to display 95010260 as the calling party.

Under my telephony service I have:


calling-number initiator

dialplan-pattern 1 650201.. extension-length 4

call-forward pattern .T



transfer-system full-consult

transfer-pattern 0.T


Any thoughts?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
alig.norbert Tue, 10/30/2007 - 13:50


I would try with translation-rules on the ISDN voice-port.

Furthermore it depends on the Telco setting (Special arrangement routing).

Only a few hints.



Paolo Bevilacqua Tue, 10/30/2007 - 13:56


yes cme will try to send original called number.

If it not enough for you to impose main calling number, what you want it can be done but is a bit complex configuration with ephone-dn loopback. wirte here if you want to try it.

mattiep00 Wed, 10/31/2007 - 02:18


If you had any examples, i would like to give it a try. We use CCM in our main site, and forwarding from individual numbers must be the default behaviour - so I need to make it the same or the users will freak out!


Paolo Bevilacqua Wed, 10/31/2007 - 04:04


try what is described in the following post:

you need to adapt for the numbers and length of numbers you are forwarding to, please ask if anything isn't clear.

mattiep00 Fri, 11/02/2007 - 22:40


This worked - however now when I dial numbers using the prefix, it doesn't let me put in the last number - so I dont think this will work. Here's the config:

dial-peer voice 2 pots

description ** PRI POTS Standard dial-peer **

destination-pattern 9[3,6,8,9].......

port 0/0/0:15


ephone-dn 78

number 3.......

loopback-dn 90 prefix 9

caller-id local

ephone-dn 90

number 707

loopback-dn 78

So any time someone dials 935010178, it trys to dial 93501017...So I think this may be a bit flawed...

Any suggestions?

Paolo Bevilacqua Sat, 11/03/2007 - 07:02

Hi Mattie,

In you case DP 2 is

destination-pattern 9[3,6,8,9].......

This means numbers beginning with 3, 6, 8 or 8 are followed by 7 more digits for a total of 8.

Now you say that when you try to dial 935010178 it doesn't let you put the last digit (this is unrelated to the forwarding config.

This is inconsistent with the configuration, can you verify how many digits do you have and the actual number length.

Hope this helps, please rate post if it does!

mattiep00 Sat, 11/03/2007 - 18:00


That dial peer has been working previously - also when I removed the forwarding ephone-dns it allowed me to enter the 8th number again.

I could however just dial 35010178 and that would work, but then users wouldnt be entering '9' to access an external line...

Paolo Bevilacqua Sat, 11/03/2007 - 18:08


I've just tried that and it's calling after the 8th digit after '9' as access.

I'm not sure how the ephone-dn interferes with the DP, it should not.

Perhaps if you post the full config we can understand why.

mattiep00 Sun, 11/04/2007 - 01:25

Config attached. Let me know if you see anything out of the ordinary.

Also, All IP communicator phones are behind by 1 hour - is that set on the CIPC, or on the router?

I have rated the post with the answer in it already, as this does resolve the problem (just creates another for me!)


Paolo Bevilacqua Mon, 11/05/2007 - 06:26


is not exactly clear to me why this is happening, however, can you try "preference 1" under the ephone-dn set in loopback ?

For the time problem, do you have the correct time, timezone and DST correction when doing "show clock" ?

mattiep00 Mon, 11/05/2007 - 17:36

I will try tonight and post the results.

Does the IP Communicator get its time from router clock, or timezone under telephony service?

Clock timezone GMT 8


time-zone 41

All the 7940 phone times are correct however - just IPC...

Paolo Bevilacqua Tue, 11/06/2007 - 03:11

They use a mix. Does DST apply in you location? If yes, you need to configure like:

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00

The example above is for Europe.

mattiep00 Wed, 11/07/2007 - 14:43

No - no daylights saving in Singapore. I get Error updating Locale in the CIPC status messages.

I've tried to create those DN's again. This is a debug for q931 which I get.

I also get no voice as well, just silence which I assume is related to this error:**ERROR**: call_progress: DEV_CONNECTED VOICE ERROR: Bearer capability not available(0x3A): b c

hannel 4 call id 0x131

Also - calling number comes from 708 which doesnt sound correct...

Paolo Bevilacqua Wed, 11/07/2007 - 15:06

Hi Mattie,

The error you see is purely cosmetic, you will see it in any and all ISDN calls until cisco will finally fix this spurious message.

On which type of calls do you have no voice path ?

The calling number you see is the extension one. You can have it replaced with your main number, main+DID, depending on what you want.

Going back in this forum I remember some discussion about ISDN in Singapore, but as far I can recall, there was nothing special about it.

mattiep00 Wed, 11/07/2007 - 15:10

This is for calls that are being forwarded. All other external voice calls are still working fine.

I thought that the config with that in it would use the calling number?

ephone-dn 79

number 6.......

loopback-dn 91 prefix 9

caller-id local

preference 1

ephone-dn 91

number 708

loopback-dn 79

Paolo Bevilacqua Wed, 11/07/2007 - 16:43

Hi Mattie,

First of all thank you for your patience in following on this.

I have tried again the configuration, and it works for me. But I have no "preference" under the ephone-dn that goes in loopback.

I made various tests, but under no circumstance it happened to send out the number in the 'second' ephone-dn (708 in your case) as calling number.

Now, which exact IOS are you using ? Here I have 12.4(11)XJ4 that actually I recommend because of the many bug fixes (even in the area of DST).

Let me know if you can possible upgrade to that IOS in order to align the scenarios.

Thanks again and good luck.

mattiep00 Wed, 11/07/2007 - 21:08


Thanks for trying to work me through this!

I've just tried on another router/isdn service and have the results i got at the start. Forwarding works ok now, but when I dial a number it strips the last digit. Here are the dial peers again:

dial-peer voice 2 pots

description ** PRI POTS Standard dial-peer **

destination-pattern 96.......

port 0/1/0:15

prefix 9


ephone-dn 81

number 9.......

loopback-dn 93 prefix 9

caller-id local



ephone-dn 93

number 710

loopback-dn 81


I've tried changing that dial-peer and it makes no difference, so it must be using the ephone-dn for some reason.

Is it the way I have the prefixes set up or something?

I am using 12.4(11)XJ4 as per your suggestion in another thread!

andrey.smirnov Wed, 11/14/2007 - 00:08


I had the same question some time ago and solution was very simple - I've just changed the value of "calling-number" command under telephony section from "initiator" to "local". Setting this option has one drawback - this feature is only useful when you transfer or forward calls to PSTN but not to the other IP phones. I guess that when you forward calls to another IP phone it's much better for the final recipient to see on his phone screen who is really calling him (probably as well as who is forwarding the call). Unfortunately in this situation calling number of initiator of the call is unavailable for the final recipient.

Best Regards,


Paolo Bevilacqua Mon, 11/19/2007 - 19:12

Andrey is right. I don't know why I concluded that "calling-number" wasn't working for this.

At least I had a chance to put "ephone-dn loopback' in use -- even if too succesfuly :0


This Discussion