local directory

Unanswered Question
Oct 30th, 2007

i have a problem with the local directory when i press the directory button i see missed/recieved/placed call only and there is no local directory and host not found message appear

so i need to understand from where the ip phone read the directories entries(if it read it from specific file i need to know this file)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lpezj Tue, 10/30/2007 - 04:57

Hi,

Have you set up DNS on the IPPhones. By default, in Callmanager, the Directory URL are configured with the Callmanager DNS address instead of the IP.

Check on CallManager CCMAdmin web pages on 'System'->'Enterprise Parameters'->'URL Directories' parameter. You can change the CallManager name by the IP Address or add DNS entries on the IP Phones configuration to resolve the CallManager name.

Hope this helps,

Juan Luis

rob.huffman Tue, 10/30/2007 - 06:46

Hi Mostafa,

Were you using the Local Directory or using the url method to point to an external Directory? Here is some info related to both;

Cisco Unified Communications Manager Express Configuring Directories

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_guide_chapter09186a00807e1325.html

Also have a look at this doc;

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_command_reference_chapter09186a0080611961.html#wp1056637

You only need to configure a url if you don't want to use the local directory. Have a look;

The Cisco CME system automatically creates a local phone directory according to the telephone numbers that are assigned during ephone-dn configuration. Additional entries to the local Cisco CME directory can be made using the directory entry command. The additional numbers can be nonlocal numbers, such as telephone numbers of other Cisco CME systems used by the same corporation.

By default, the router automatically uses the local directory service. Provisioning the directory URL to select an external directory resource disables the Cisco CME local directory service. You can also disable the local directory by entering the no service local-directory command.

telephony-service

Example:

Router(config)# telephony-service

Enters telephony-service configuration mode.

Step 2

service local-directory

Example:

Router(config-telephony)# service local-directory

enables local directory service on IP phones.

Step 3

exit

Example:

Router(config-telephony)# exit

Hope this helps!

Rob

k6lw Tue, 10/30/2007 - 10:33

We've found that simply rebooting the phone will make the directory reappear.

Press the settings button and then dial **#**.

Lee

Paolo Bevilacqua Tue, 10/30/2007 - 14:36

I've seen that happening on 7941's with latest 12.4(11)XJ code and latest 8.2 phone FW.

mostafamossad Mon, 11/05/2007 - 05:40

i need to know from where the ip phone get the directory page that displayed on it

Paolo Bevilacqua Mon, 11/05/2007 - 06:53

From the router. Please configure:

telephony-service

service local-directory

As a recognition to those providing answers, please rate useful posts using the scrollbox below!

mostafamossad Mon, 11/05/2007 - 23:17

really idid that but it still don't appear and the message host not found appear

Paolo Bevilacqua Tue, 11/06/2007 - 03:22

Hi,

which telephone type are you using, which firmware ? You can see that accessing 'settings' - device status.

Alos, how do you try to access the local directory, which button do you press ?

nalonsoamerex Sat, 05/22/2010 - 07:44

I'm having this same issue on CME 7.1 on a 7942 running SCCP 8.4.2. The Directory option does not show. Only missed, received and placed calls. I have gone through the documentation and nothing. Anyone figured this out yet?

Other than that and the Idle logo not coming up when idle time expires, everything else works fine.

Any help would be appreciated.

Adrian Saavedra Tue, 05/25/2010 - 09:31

Hi,

Does it affect all the IP phones?. I was wondering whether there is an access list applied to the IOS HTTP service (ip http access-class) that could be denying phones to access local directory. Perhaps you can check it after firmware upgrade.

Hope to help.

Regards,

-- Adrián.

nalonsoamerex Tue, 05/25/2010 - 11:01

Yes all phones. There is no access list on the http server. I'm going to have to open a case with

TAC on this. So frustrating!!  I do have DNS configured on the router and phones.

nalonsoamerex Wed, 05/26/2010 - 04:19

I figured it out. It was the IDLE screen URL I added for a company logo. For some strange reason, when the phone boots, the CME router is asking for a level 15 authorization to access the HTTP server location of the xml file. I manually entered a test user I created and it all worked fine, but the process repeats itself every time you reset the phone. I took the idle URL off and the local directory now shows ok. It is as if the authorization prompt haults the proper load of the phone. CME is ignoring the username and passwords already created under the ephone.

This was not visible on the standard hard sets, I had to load IP communicator to spot it.

fbriski10 Tue, 10/05/2010 - 06:41

Hello Mostafa and everyone else who have problem with local directory on CUCME system.There are some thinghs you must do before local directory  appear on your phone:

     1) you must enable http server using command "ip http server" in global configuration mode

     2) you must assign name to ephone-dn

     3) If local directory still won't work, you must configure "type" (example for 7942 is "type 7942) in ephone configuration. You need to do it for every

         phone.

     4) After you configure type, you must create cnf-files in telephony-service mode

     5) after you create cnf-files, reset your phones

After reseting (not restarting), local directory should appear on your phone

Actions

This Discussion