Call transfer (full-consult / local-consult) not working with CME 4.2 or4.1

Unanswered Question

CME 4.1(0) and IOS 12.4(15)T1 on 2851.

Also tried with CME 4.2 and 12.4(11)XW1, same problem.

Call Transfer with full-consult is not working with internal or external calls.


If I configured full-consult, I can consultate the second DN (now original caller is on hold, second dn is connected, but after pressing transfer or hangig up the phone, both lines are in status on hold and I will get hold-alert notifications and message transfer not possible on the phone with both lines on hold.


Original callers phones shows ring out, the phone (dn) which should be transfered to shows connected.

There is also no music on hold heard.


Phones are 7961G-GE and 7941G-GE. Firmware 8.2.2SR1S. We have also tried 7.03.


If we use local-consult as workaround, consultative transfer does fail sometimes.


Any suggestions?


Thanks

Peter

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rob Huffman Tue, 10/30/2007 - 05:58
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Peter,


Usually this fails if you are using Transfer System Full-Consult without the Dual Line config;


A dual-line ephone-dn has one virtual voice port and two channels to handle two independent calls. This capacity allows call waiting, call transfer, and conference functions within a single ephone-dn. Dual-line mode is supported on all phone types, but is not appropriate for voice-mail numbers, intercoms, or ephone-dns used for message-waiting indicators, paging, loopback, or hunt groups. Overlays of single-line hunt groups onto dual-line buttons are supported.


Ephone-dns are created in single-line mode if the dual-line keyword is not used. Changing an ephone-dn from dual-line mode to single-line mode (and vice versa) requires that you delete the ephone-dn and then recreate it.


Examples


The following example enters ephone-dn configuration mode to create the ephone-dn 5576:


Router(config)# ephone-dn 1

Router(config-ephone-dn)# number 5576

Router(config-ephone-dn)# exit

The following example creates an ephone-dn with the number 1001 in dual-line mode. The no huntstop command allows calls to continue to hunt to other ephone-dns if this one is busy or does not answer. The huntstop channel command disables call hunting to the second channel of this ephone-dn if the first channel is busy or does not answer.


Router(config)# ephone-dn 10 dual-line

Router(config-ephone-dn)# number 1001

Router(config-ephone-dn)# no huntstop

Router(config-ephone-dn)# huntstop channel

Router(config-ephone-dn)# exit


From this good CME doc;


http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_command_reference_chapter09186a0080611350.html



Hope this helps!

Rob



paolo bevilacqua Tue, 10/30/2007 - 06:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


can you try 12.4(11)XJ4 ? All my installations with that release Ok wrt transfers.

paolo bevilacqua Tue, 10/30/2007 - 07:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Can you send config ? That is strange, full consult not working at all.

paolo bevilacqua Tue, 10/30/2007 - 09:47
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I understand it's unlikely, to be the cause, but can you try SCCP41.8-2-2SR4S ?


I have solved the problem. I can now use transfer-system full-consult and can transfer internal and external calls.


I have done the following:


telephony-service

no multicast moh 239.10.16.4 port 2000


voice-port 0/2/0

shut


disabled E&M port for Moh live-feed


application

package callfeature

no param med-inact-det enable

no param med-inact-disc-cause 16

no param med-inact-action disc


After configuring the no param ... whole section with application has gone.


I will again configure moh live feed in a few days, if call transfer works well.


Many thanks to all.


Regards

Peter

paolo bevilacqua Tue, 10/30/2007 - 10:53
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ah! Thanks for letting us know. I must say, have not the slightest idea about what package callfeature does!

Actions

This Discussion