CiscoWorks question

Unanswered Question
Oct 30th, 2007


I want to run the enable secret $x6E8s# by Ciscoworks, but it gives me the following error message:


enable secret ********

can't read "x6E8s": no such variable

Any reason?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (5 ratings)
Joe Clarke Tue, 10/30/2007 - 10:09

LMS uses the '$' to indicate a variable for parameterized templates. How are you creating this job, and what version of RME are you using?

persepolis77 Tue, 10/30/2007 - 10:16

RME version 4.0.5

I do not understand what you mean by how I create the job, but I have a template which has the following command:

enable secret $x6E8s#

Should I add something before $ to show that $ is a part of my password?

Joe Clarke Tue, 10/30/2007 - 10:22

If you have a template, check its configuration to see if you've checked the "Parameterized" box. If so, uncheck that box, and save your user-defined task, and see if that helps.

persepolis77 Tue, 10/30/2007 - 10:31

"Parametrized" is not checked. I will check it and try again to see it that one helps or not.

I actually have another problem also. I have the following command in tclsh:

proc get_net { interface } {return [join [lrange [split [lindex [exec sh ip int brief $interface

| include $interface] 1] .] 0 2] .]}

and I get this error message:


proc get_net { interface } {return [join [lrange [split [lindex [exec sh ip int brief $interface

+>missing close-brace

In my template, the line is complete!!!

Joe Clarke Tue, 10/30/2007 - 10:37

Do not check it as it will certainly not do what you want. This may be a bug in RME 4.0.5. I tested 4.1, and your template is working.

As for the TCL problem, please start a new thread in the Network Management forum for that.

Joe Clarke Tue, 10/30/2007 - 10:44

I tried RME 4.0.5 with your template, and it works just fine if I don't check the Parameterized box.

What I did was create a new User-Defined Task in Netconfig. The Task was a Config Task for Switches and Hubs (I tested with a 3560). I did NOT check the Parameterized box, and I entered, the following in the CLI Commands box:

enable secret $x6E8s#

I then went to NetConfig Jobs, and created a new job to deploy this template to my test 3560. It deployed just fine. No errors.

persepolis77 Tue, 10/30/2007 - 12:01

I created a new template with only enable secret command and it worked for me also, but when I add it to all my config, it does not work!!!

Any idea why?

Joe Clarke Tue, 10/30/2007 - 12:03

What do you mean, it does not work when you add it to your config? Are you getting the same error as before?

persepolis77 Wed, 10/31/2007 - 06:36

yes, true, it was not working when I added it to my config!!!

but, I found the problem. When I was changing my enable secret, I was still in TCL mode. That is why whatever was after $ was considered as a variable.

I just put my enable secret after the exit of TCL mode and it worked.



This Discussion