NM-16ESW switching problem !!!

Answered Question
Oct 31st, 2007
User Badges:

Hi,


We have a problem using an NM-16ESW in a 2811 routeur. Actually this network module works perfectly in routing mode (no switchport on the interfaces) but we are not able to use it in switching mode; Our configuration is very simple: We have configured vlan 100 in vlan database, we have configured interface vlan 100 and set an ip address to this interface vlan 100, then we have put the interface Fa1/0 (first int of the NM-16ESW) in vlan 100 (switchport mode acces, switchport access vlan 100). But there is nothing to do and we are still unable to ping (of course we've checked that interfaces are up)!!! Thanks for your help because this problem is going to drive us crazy !


Regards,


Adrien

Pau, FRANCE

Correct Answer by b-ulrich about 9 years 9 months ago

Hello,

It looks like you have a 4port HWIC also in the router. You may want to remove it and retest. I remember trying to use a 9 port HWIC with a 36 port ESW in a 2851 and they could not communicate with each other. However now I just have the 36port ESW in several 2851's and they work fine with basically what you have configured.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (3 ratings)
Loading.
glen.grant Wed, 10/31/2007 - 05:03
User Badges:
  • Purple, 4500 points or more

Maybe you can post the config and elaborate a little more on how you are testing this and what is on the port that you are trying to ping , is a pc or a switch etc... Sounds like you have the config down.

You need at least 1 active interface in vlan 100 to be able to ping the SVI address . Use the "show vlan-switch" command to verify vlan was created and your port shows in the right vlan.



vlan database

vlan 100

exit


int vlan 100

ip addres xxx.xxx.xxx.xxx


int f1/0

switchport

switchport mode access

switchport access vlan 100

ogor Wed, 10/31/2007 - 07:13
User Badges:

Hi !


Thanks for your response. We entered the same commands as you to create vlan and to configure interface vlan.

As requested, here is output of "sh run" command related to the NM-16ESW configuration. As you can see configuration is very simple.



interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0/0

switchport access vlan 100

!

interface FastEthernet0/0/1

switchport access vlan 100

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

!

interface FastEthernet1/0

switchport access vlan 100

!

interface FastEthernet1/1

description *** Sectorielle 1 ***

switchport access vlan 100

!

interface FastEthernet1/2

description *** Sectorielle 2 ***

switchport access vlan 100

!

interface FastEthernet1/3

description *** Sectorielle 3 ***

switchport access vlan 100

!

interface FastEthernet1/4

description *** Sectorielle 4 ***

switchport access vlan 100

!

interface FastEthernet1/5

!

interface FastEthernet1/6

!

interface FastEthernet1/7

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

ip address 192.168.38.252 255.255.255.0

standby 100 ip 192.168.38.254

standby 100 priority 110

standby 100 preempt

!

....


Here is output of show command in the vlan database... as you can see we are able to see VLAN 100 which has been created with "vlan 100" command in vlan database mode.

Router(vlan)#sh

VLAN ISL Id: 1

Name: default

Media Type: Ethernet

VLAN 802.10 Id: 100001

State: Operational

MTU: 1500

Translational Bridged VLAN: 1002

Translational Bridged VLAN: 1003


VLAN ISL Id: 100

Name: VLAN0100

Media Type: Ethernet

VLAN 802.10 Id: 100100

State: Operational

MTU: 1500

.....


It seems to be very simple but unable to ping anything. We tried to connect a pc, a routeur on interfaces within vlan 100 (Fa1/0 - 4), configured of course with an ip address within the subnet 192.168.38.0/24, but it doesn't work-> impossible to ping. Worst; when we connect a router we are able to see it with sh cdp nei command (but ping doesn't work)!


Thanks for your help.


Correct Answer
b-ulrich Wed, 10/31/2007 - 09:01
User Badges:
  • Bronze, 100 points or more

Hello,

It looks like you have a 4port HWIC also in the router. You may want to remove it and retest. I remember trying to use a 9 port HWIC with a 36 port ESW in a 2851 and they could not communicate with each other. However now I just have the 36port ESW in several 2851's and they work fine with basically what you have configured.

glen.grant Wed, 10/31/2007 - 09:08
User Badges:
  • Purple, 4500 points or more

Ethernet Switch Network Modules


This chapter explains how to install the 16- and 36-port Ethernet switch network modules. The Ethernet switch network module is a modular, high-density voice network module that provides Layer 2 switching across Ethernet ports. The 16-port Ethernet switch network module has 16 10/100BASE-TX ports and an optional 10/100/1000BASE-T Gigabit Ethernet port. The 36-port Ethernet switch network module has 36 10/100BASE-TX ports and 2 optional 10/100/1000BASE-T Gigabit Ethernet ports. The 36-port Ethernet switch network module requires a double-wide slot. An optional power module can also be added to provide inline power for IP telephones.


The10/100BASE-TX ports and Gigabit Ethernet ports on the Ethernet switch network module are connected to the network using RJ-45 connectors on the front panel. The power module is connected to an external power supply using a power connection cable. The front of the 16-port card is shown in Figure 17-1. The front panel of the 36-port card is shown in Figure 17-2.


Figure 17-1 16-Port Ethernet Switch Network Module


Figure 17-2 36-Port Ethernet Switch Network Module


Requirements for Installing Two Ethernet Switch Network Modules in a Single Chassis


A maximum of two Ethernet switch network modules can be installed in a single chassis. If two Ethernet switch network modules of any type are installed in the same chassis, the following configuration requirements must be met:


•Both Ethernet switch network modules must have an optional Gigabit Ethernet expansion board installed.


•An Ethernet crossover cable is connected to the two Ethernet switch network modules using the optional Gigabit Ethernet expansion board ports.


•Intrachassis stacking for the the optional Gigabit Ethernet expansion board ports is configured. For information about intrachassis stacking configuration, see the 16- and 36-Port Ethernet Switch Module for Cisco 2600 Series, Cisco 3600 Series, and Cisco 3700 series feature document.


Without this configuration and connection, duplications will occur in the VLAN databases, and unexpected packet handling may occur.

adrienbomble Wed, 10/31/2007 - 13:14
User Badges:

Thanks for your reponse ! You're right ! As soon as we remove the 4port HWIC, the NM-16ESW works perfectly. It seems to be a kind of conflict between these two cards... Moreover some others stranges Layer3 behaviours can be observed when these two cards are installed within the 2811:

- OSPF adjacencies never reach FULL state.

- ODR routing doesn't work too...


Don't check if it's a well known bug but hope Cisco will correct it soon.


Thanks again for your help.


Regards,


Adrien

Actions

This Discussion