cisco 1801 router. ISP dns is not working

Unanswered Question
Oct 31st, 2007

Hi,

I have a new cisco 1801 router. I have configured the ATM interface to connect to the local ISP. The connection works but for some reason I cannot use the names of the web pages to go into the internet. However I can use their ip addresses to go to the webpages.I have for the time begin turned off the firewall and had a PAT from ATM to VLAN 1.Looks like my connection isnt picking up the ISP DNS. Any assistance would be greatly appreciated

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Wed, 10/31/2007 - 23:48

Verify the ip adresses for these DNS servers, they mostly specify two.

Also, there are other dns servers around that might serve your requests, try one of these and see if that helps.

Otherwise, post your config and let us have a look.

regards,

Leo

rodmunch999 Thu, 11/01/2007 - 01:40

As you can see, I have hard coded in the DNS servers in the router but this is not ideal. I am getting dynamic IP address but not the DNS. Below is my config.

!This is the running config of the router: 10.10.10.1

!----------------------------------------------------------------------------

!version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret xxx

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

aaa session-id common

!

resource policy

!

!

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool sdm-pool

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

dns-server 203.x.x.71 139.130.4.4

lease 0 2

!

!

ip domain name yourdomain.com

ip name-server 203.50.2.71

ip name-server 139.130.4.4

ip name-server 139.130.204.47

ip name-server 139.130.4.5

ip ddns update method sdm_ddns1

DDNS both

!

!

username admin privilege 15 secret xxx

username 357689 privilege 15 secret xxx

!

!

!

!

!

!

interface FastEthernet0

no ip address

duplex auto

speed auto

!

interface FastEthernet0.1

description $ETH-LAN$

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

no cdp enable

!

interface FastEthernet0.2

description $ETH-LAN$

encapsulation dot1Q 12

ip address 192.168.12.250 255.255.255.0

ip nat inside

ip virtual-reassembly

no snmp trap link-status

no cdp enable

!

interface BRI0

no ip address

encapsulation hdlc

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.2 point-to-point

no snmp trap link-status

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$

ip address 10.10.10.1 255.255.255.248

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname java.util.regex.Matcher[pattern=[a-zA-Z0-9_+-.]+@[a-zA-Z0-9][w.+-]+.[a-zA-Z]{2,} region=0,3230 lastmatch=[email protected]]

ppp chap password 0 xxxxxx

ppp pap sent-username java.util.regex.Matcher[pattern=[a-zA-Z0-9_+-.]+@[a-zA-Z0-9][w.+-]+.[a-zA-Z]{2,} region=0,3230 lastmatch=[email protected]] password 0 xxxxx

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 remark INSIDE_IF=FastEthernet0.1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.168.10.0 0.0.0.255

dialer-list 1 protocol ip permit

no cdp run

!

!

!

!

!

!

control-plane

!

banner login ^C

cheers

Ravi

lgijssel Thu, 11/01/2007 - 02:22

You are trunking on int fa0. PC hosts will not communicate over a dot1Q trunk. Try this:

interface FastEthernet0

ip address 10.10.10.1 255.255.255.248

ip nat inside

end

modify this acl: access-list 1 permit 192.168.10.0 0.0.0.255

to contain the ip range of your inside network: access-list 1 permit 10.10.10.0 0.0.0.7

With the config as shown, your are not allowing nat for inside hosts on subnet 10.10.10.0

regards,

Leo

andriyhar Thu, 11/01/2007 - 12:56

ip dhcp pool sdm-pool

import all

interface ATM0

no ip address WRONG

negotiated

interface Vlan1

ip nat inside

ip classless

ip nat inside source list 1 interface Dialer1 overload

Actions

This Discussion