QoS on Catalyst 6500

Unanswered Question
Nov 1st, 2007

We have the following QoS config running on Edge, Distributions and Cores and got the following error.

“priority command is not supported in output direction for this interface

Configuration failed on: Port-channel”

We had opened a TAC case and they said ” PFC QoS does not support these policy map class commands:





set qos-group



How can we prioritize voip traffic. On our monitoring application, it says queues empty. Even if the priority command is not working there should be traffic in the queue.Different version of supervisors in Distribution (sup720) and COREs (Sup2).

Any suggestions? Attached document gives Config details.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
steve.busby Thu, 11/01/2007 - 19:10

If you properly classify, mark and police your traffic in the access-layer, you could simply trust the dscp value in the distribution and core layers instead of attempting to reclassify and remark the traffic.

You would still need to properly setup your transmit queues based on the tx-queue capabilities of your modules. Of course if you are running L2 in your access layer, then you would need to classify and mark your traffic in the distribution layer. Instead of doing port-based, use VLAN based classification.

There are great explanations and examples in this book:


or here:


One final question/comment: What QoS "monitoring application" are you using? QoS on the 6500 series is done in hardware and there are no SNMP MIBs to query (i.e., cbQosCMCfgTable, cbQosServicePolicyTable

cbQosSetCfgTable, cbQosCMStatsTable)



sapnatripathi Fri, 11/02/2007 - 07:52

Thanks for replying. We are classifying traffic on our access-layer switches. We are running layer 2 in our access layer. We are turning on QoS and modifying default COS map on our access-layer switches as shown below:

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos

And we are configuring QoS on the uplink port of the switch to Distribution (Catalyst 6500) and trunking voice vlan. See below:

interface GigabitEthernet1/0/1

priority-queue out

mls qos trust dscp

switchport trunk allowed vlan 801-802

On our Distributions and Cores, we are trusting DSCP and applying the service policy outbound on the port-channels.See below:

int poXX

mls qos trust dscp

service-policy output voip-policy

On our Distributions, We are defining policy-maps:

mls qos

class-map match-any voip-class

match ip dscp ef

policy-map voip-policy

Class voip-class

priority 10000

class class-default



The monitoring application is NetMRI. It doesn't give lots of details but says "Queues empty"


steve.busby Fri, 11/02/2007 - 12:04

Are your Access Layer switches also 6500s? What Supervisor(s) are running in your 6500s & what CatOS or CatIOS are you running?

It sounds like you are redefining your trust boundary at every layer (Access, Distribution, Core). Did you get a chance to look over this SRND document?


Here's an example of our L2 6513 with a WS-X6724 which has 1p3q8t for QoS Scheduling:

interface GigabitEthernet1/2


switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

logging event link-status

logging event bundle-status

logging event trunk-status

wrr-queue bandwidth 5 25 70

wrr-queue queue-limit 5 25 40

wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 3 50 60 70 80 90 100 100 100

wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 3 60 70 80 90 100 100 100 100

wrr-queue cos-map 1 1 1

wrr-queue cos-map 2 1 0

wrr-queue cos-map 3 1 4

wrr-queue cos-map 3 2 2

wrr-queue cos-map 3 3 3

wrr-queue cos-map 3 4 6

wrr-queue cos-map 3 5 7

priority-queue cos-map 1 5

udld port

mls qos trust dscp

rmon collection stats 6001 owner monitor

channel-group 2 mode desirable non-silent

interface Port-channel2


switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

mls qos trust dscp

We also use NetMRI and you're correct, because the Cat 6500 PFC performs classification, marking, mapping, and policing functions, but the queuing and dropping policies are administered by the line cards, there are no MIBs for NetMRI to poll.



sapnatripathi Fri, 11/02/2007 - 13:48

Thanks Steve. We are using catalyst 3750 or 3550 on access-layer with SMI code. The DIstribution box has Sup 720 and Cores have Sup 2. The IOS on them is s72033-ipservicesk9-mz.122-18.SXF8.bin

I did not get a chance to read that document.We are mapping COS-to-DSCP on our access-layer switches and making sure Dist and Cores trust DSCP but we are not redefining the boundaries there.We are doing CBWFQ for voice and video.

steve.busby Sat, 11/03/2007 - 03:49

Please read over the SRND document I referenced earlier, it provides the best explanations and examples for exactly what you want to accomplish for each type of switch in Access, Distribution, Core layers.



This Discussion