Configuring a 2800 router for two ISP's

Unanswered Question
Nov 1st, 2007

How do I configure a 2800 series router for dual WAN connections. I just added another fast ethernet card to the router, and will be connecting two ISP's to the same router. Will need to load balance and set static routes. Anyone know of a knowledgebase article or website that will help me with that?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
JORGE RODRIGUEZ Thu, 11/01/2007 - 14:43

what is your topology? assuming you have switch-->2800-->ISP

This could be one way :

interface serial0/0

Description ISP1

ip address

ip nat outside

interface serial0/1

Description ISP2

ip address

ip nat outside

interface fE0/0

ip add

ip nat inside

interface fe0/1

ip add

ip nat inside

ip nat pool ISP1 netmask

ip nat pool ISP2 netmask

ip nat inside source route-map ISP1 pool ISP1 overload

ip nat inside source route-map ISP2 pool ISP2 overload

ip access-list 101 permit

ip access-list 102 permit

route-map ISP1

match ip address 101

match interface S0/0

route-map ISP2

match ip address 102

match interface S0/1

ip route

ip route

there are some other examples here

some threads here

You may also need these resources

NAT support page

if not firewalls between 2800 router and ISP I would recommend go over these acls



kltconsulting Thu, 11/01/2007 - 14:50

Excellent! This info is a big help. Currently, the 2800 router goes straight into a stack of 3 catalyst 2950's. The reason for this dual WAN is there are several users utilizing an imaging database out of Houston that requires a ton of dedicated badwidth. I'd like to static all traffic to that Houston database thru one ISP, and then push all the other traffic (basic internet, email, etc)thru the other ISP. The Cisco rep that sold me the card made mention that 2 VLAN's would have to be created to accomplish this. Wasn't sure what she meant and wanted to see some sample config's.

JORGE RODRIGUEZ Thu, 11/01/2007 - 15:09

You could also do it with one FE interface only by 802.1q trunking FE0 interface to switch and pass two subnets into switch. On switch trunk the port connecting to FE these way you can assign switch ports to be in vlan 2 or 3 for hosts that will go to ISP1

and ISP2 respectivately.


interface FastEthernet0/0

description MyOnlyOne FE INterface

no ip address

no ip proxy-arp

duplex full

speed 100

interface FastEthernet0/0.2

Description VLAN2

encapsulation dot1Q 2 ( for vlan 2 on switch )

ip address

ip nat inside

interface FastEthernet0/0.3

Description VLAN3

encapsulation dot1Q 3 ( for vlan 3 on switch )

ip address

ip nat inside




This Discussion