CVP Error

Unanswered Question
Nov 1st, 2007


I am running a comprehensive CVP mode with NAM and CICM.On the Gateway I am getting the following error

**** CVP HANDOFF.TCL: DB692265.87F811DC.82B2C624.8892778E abnormally disconnected with code 38. ****

I can see the switch leg completing.CVP is not playing any wave files.On the VB of cvp I am getting an message saying"there was an issue with egress gateway".

It is CVP version 4.0.1 and IOS version 12.4.15T

Does any one know what this is?

Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
wiwebb Fri, 11/02/2007 - 06:21

Can you give some details of the architecture and call flow? Is this SIP or H.323?

1. I assume you are calling in through a gateway (PSTN?) and hitting a voip dial-peer that is either sending the call to CUPS (SIP) or gatekeeper (H.323)?

2. That dial-peer is handing the call off to the CVP Call Server, which starts ICM processing.

3. ICM script runs a "Send to VRU" node, which should be returning the VRU transfer Label (configured on the Type 10 Network VRU in ICM for the Call Server Routing Client).

4. This Label should either be going back to CUPS or gatekeeper for resolution or directly back to the ingress gateway (if it is also the VXML gateway) if you have "return to originator" or the SetTransferLabel setting set.

5. Either way, the VXML gateway should then have a voip dial-peer to accept the VRU transfer label, and this is the one that should be calling bootstrap.tcl via a "sevice" command.

- Bill

habib.issa Sat, 11/22/2008 - 00:32


I am facing the same problem and same error as bellow :

**** CVP HANDOFF.TCL: DB692265.87F811DC.82B2C624.8892778E abnormally disconnected with code 38. ****

I am running CVP 4.2, ICM 7.1 and I am using SIP proxy, while we are troubleshooting on this error we found that when we put the Voice Gateway in the Same V Lan of the Servers ( CVP and ICM ) the systems works without error.

I do not know why this error happen when the VG in different V Lan I tried to ping between the 2 V Lan there is no delay and also there is no firewall between the V Lan's

If anyone can help ..?

Best regards

Habib Issa


This Discussion