UCCX 5.0 CRS Editor - Fail to launch with remote machine

Unanswered Question
Nov 1st, 2007

Hi,

I am having a problem using the editor on any machine other than the IPCC server. Installation is fine. I input my user name and password and crs IP. The program launches fine, and during the step near the end, it freezes with the message:

starting com.cisco.file.FileManager manager

It stays there for a long time, then it shuts down the application without any error messages thrown. I made sure I have connectivity and no firewalls. I also tried on different 2000 Server and XP Pro machines. The only time I am able to launch the editor is from the IPCC server itself. Has anyone else encountered this problem?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
adignan Sun, 11/04/2007 - 11:17

Yup, its a defect (I don't have bug id yet) but below is the response back from the tac development engineer:

---------------snip-------------

So what happens exactly is:

1) When there is no connection to CRS server, it throws java.net.NoRouteToHostException and deletes /ClusterData/profile.ini file.

2) Later on it tries to read the same file for configuration data and throws a java.io.FileNotFoundException.

Pls raise a defect for the same and we will fix it in the next release.

-----------------end snip------------

please rate helpful posts.

phillip.rowland Thu, 12/22/2011 - 13:40

I had that issue as well. This is what I've done as a workaround.

  • Launch Notepad as Administrator and open /ClusterData/profile.ini. (Thanks to Andrew for this file!)
  • Veriphy that the "ipAddress" in that file is the correct address of your UCCX server and save but leave it open. Mine wasn't correct even though I entered it correctly on the login form.
  • Launch the Editor and login. While it's starting up, continuously save the file. It will keep the file present and correct throughout startup so it won't run into any issues

It's irritating, but it works...

If that file doesn't exist, you can try grabbing a copy as the Editor launches but before it gets deleted.

Cheers!

leopastor Fri, 06/04/2010 - 03:57

Almost 3 years later, today I am having exactly the same problem with UCCX7.

Does someone solve this issue?

Thanks.

doshinimit Wed, 10/06/2010 - 05:49

Hi,

I also faced the same issue. I am not able to open CRS editor with same result.

Has any one fixed this issue ??

Regards,

Nimit

vincent.morton Mon, 04/11/2011 - 02:11

I've just found the same issue with a UCCX 7 installation.

The editor installs OK (or at least appears to) then when it is launched, it gets to 81%, displaying "com.cisco.file.FileManager", waits for about a minute then closes itself.

I've uninstalled, rebooted, installed and rebooted again but the same thing happens.

Is there a fix for this?

salman.adil Mon, 07/04/2011 - 04:17

I am Also facing the same issue in UCCX Editor 8. It got stuck in Starting com.cisco.file.FileManager and ends up saying Shutting down com.cisco.file.FileManager...

Any clue for the resolutions?

vincent.stng Thu, 10/24/2013 - 02:26

Sadly, 6 years later...... I also need to use UCCX Editor 7 to edit a customer's call flow and also facing the same issue: Run on Window 7, compatible with Window 2000, but get stuck at 81% when it is launching, then end up with "shutting down com.cisco.file.FileManager manager" and close itself.

Any fix for this? or is there any other editer version can open the old script?

Thanks.

Anthony Holloway Tue, 10/29/2013 - 21:05

Almost six years later... but anyway, I have this problem now too.  I had the 8.5(1) Editor already installed and working on my Win7 machine and then today it decided to just hang on the file manager step at 81% like everyone else.  I have uninstalled, rebooted, re-installed, rebooted, but to no avail.  Just adding my $.02.  I'll see what I can come up with.

EDIT: Turned out to be a server problem and a restart of Tomcat on the server fixed the issue.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.

Actions

This Discussion