dot1q VLANs on switch of 871

Answered Question
Nov 1st, 2007

I am trying to duplicate a VLAN setup that I have used successfully on 1700 routers on a 871 router. I purchased the Adv IP Services version of the 871 (no wireless) which is supposed to be able to do 4 dot1q VLANs. However I am realizing since the Fa0-3 interfaces on this little guy are not L3 interfaces I can't use my tried and true setup. I can't find much on how to do this other than the fact that it seems I am going to have to use bridging and BVI interfaces. What are BVI interfaces? Can they help me create something like I am showing below? If so, can anybody point me to some examples?

Thanks,

Diego

interface FastEthernet0

ip address 10.1.1.1 255.255.255.0

!

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 10.1.2.1 255.255.255.0

!

interface FastEthernet0.3

encapsulation dot1Q 3

ip address 10.1.3.1 255.255.255.0

!

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 9 years 1 month ago

By default, switchports are set for dynamic trunking.

If you connect a workstation, it will negotiate to access mode.

If you connect another switch with the same characteristics, the switchport will trunk.

As I stated before, if you connect a workstation to a switchport and the mode is to set to an access vlan #,

it will send a dhcp-request packet on that Vlan.

A DHCP server listening on that Vlan will reply with an IP address, if available.

If the DHCP server resides in another Vlan, you need to configure ip helper-address on the Layer3 gateway from that Vlan pointing to the remote DHCP server.

The DHCP server scope will need to have the default gateway information under the scope and this needs to match from the Layer3 gateway above.

As for the switchport mode query, this document provides some information:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_35_se/command/reference/cli3.html#wp1948171

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (7 ratings)
Loading.
dbellaze Thu, 11/01/2007 - 21:14

The VLAN support is configured using the Cisco IOS switching commands.

Layer 3 interfaces example

interface vlan 1

description LAN1

ip add 192.168.1.1 255.255.255.0

!

interface vlan 2

description LAN2

ip add 192.168.2.1 255.255.255.0

!

interface vlan 3

description LAN3

ip add 192.168.3.1 255.255.255.0

!

interface vlan 4

description LAN4

ip add 192.168.4.1 255.255.255.0

!

Than you have the switch interfaces that you can set up as a trunk or individually associated to a VLAN as an access port.

As a trunk

interface fa0

description switch1

switchport mode trunk

As an access port

interface fa0

description switch1

switchport mode access

switchport access vlan 2

Daniel

DIEGO ALONSO Fri, 11/02/2007 - 06:52

Well the router accepts those command without complaining but when I do a "show vlans" I get "No Vlans configured". Seems like I need to do a bit more. Any ideas?

Thanks,

Diego

Edison Ortiz Fri, 11/02/2007 - 07:32

That command only works on real switches, try sh vlan-switch on these hybrid devices :)

DIEGO ALONSO Fri, 11/02/2007 - 07:55

The sho vlan-switch also shows no VLANs. This is the output from that command:

Router#sho vlan-swit

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0, Fa1, Fa2, Fa3

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 1002 1003

1002 fddi 101002 1500 - - - - - 1 1003

1003 tr 101003 1500 1005 0 - - srb 1 1002

1004 fdnet 101004 1500 - - 1 ibm - 0 0

1005 trnet 101005 1500 - - 1 ibm - 0 0

Router#

Edison Ortiz Fri, 11/02/2007 - 07:59

It's not showing because you haven't create them. The previous poster guided you on configuring Layer3 SVIs but you also need to configure Layer2 Vlans on the VTP database.

The steps are:

router#vlan management

vlan 2

vlan 3

vlan 4

exit

a.cruea1980 Fri, 11/02/2007 - 08:07

I never could get my 871, nor can I get my 1811, to show VLANs with the "sh vlans" command. However, if you hook up a catalyst switch, set it up correct with a trunk, it'll broadcast the VLANs properly.

*shrug* If you go into the vlan database, though, they're there. *shrug*

edit: Whoooooooops. . .nevermind. Missed a few key posts in the thread.

dbellaze Fri, 11/02/2007 - 09:38

You don't need to create the vlans in the database.

They will function without doing that.

Daniel

DIEGO ALONSO Fri, 11/02/2007 - 11:06

That command is not available on my router. The only vlan command avail is "vlan accounting". It is interesting that one poster's advice is to simply ignore the fact that they don't show. I will try some tests even though I am not sure the VLANs are there yet.

Diego

a.cruea1980 Fri, 11/02/2007 - 11:21

If you created the interfaces for them (ie, int vlan x), then they've been created. You just have to make sure they're not shut down.

You can also look in the actual vlan database. In global config (provided it still exists), type vlan database.

Edison Ortiz Fri, 11/02/2007 - 11:55

Don't go into config mode.

Vlan Database is not a config command but an exec command.

_______________

Rack1SW1#vlan data

Rack1SW1(vlan)#vlan 2

VLAN 2 added:

Name: VLAN0002

Rack1SW1(vlan)#vlan 3

VLAN 3 added:

Name: VLAN0003

Rack1SW1(vlan)#vlan 4

VLAN 4 added:

Name: VLAN0004

Rack1SW1(vlan)#exit

APPLY completed.

Rack1SW1#sh vlan-switch

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa1/0, Fa1/1, Fa1/2, Fa1/3

Fa1/4, Fa1/5, Fa1/6, Fa1/7

Fa1/8, Fa1/9, Fa1/10, Fa1/11

Fa1/12, Fa1/13, Fa1/14, Fa1/15

2 VLAN0002 active

3 VLAN0003 active

4 VLAN0004 active

________________________________

Can you post the show ip interface bri | ex una output before and after the commands above ?

DIEGO ALONSO Fri, 11/02/2007 - 12:29

Looks like we are making progress now. I have attached a file with the output you requested. What if I now need to add two devices to each port. One PC and one IP phone. The PCs do not support dot1q and the phones can be configured for VLAN ID2. I believe that I need to make all switchports trunk ports no? Also, if I have two DHCP pools how do I assign one pool to VLAN1 and the second pool to VLAN2?

Thanks,

Diego

Edison Ortiz Fri, 11/02/2007 - 14:13

I don't see any attached file.

So the PCs will connect via the phone ?

If so, configure the phones for one Vlan and the workstation for another vlan.

_______________

interface FastEthernet x/x

switchport access vlan 3

switchport voice vlan 2

___________________

DIEGO ALONSO Sat, 11/03/2007 - 16:43

I have two questions for the above:

1) Will PCs work on VLAN 3 if they don't support or have any type of VLAN capability? I thought it would be easiest to simply have them use the native VLAN 1

2) I have setup two DHCP pools. How do I assign the pools to the correct VLANs?

Thanks,

Diego

Edison Ortiz Sat, 11/03/2007 - 19:34

1) PCs won't know what Vlan they belong to. It's up to the switch to place those devices in the correct Vlan. If you assign Vlan 3 as the access vlan, that's what the PCs will use.

2) What type of DHCP server are you using ? Under the pool, you will want a default router -or- gateway. This value will determine the correct scope when assigning dynamic addresses.

DIEGO ALONSO Mon, 11/05/2007 - 07:49

I am using the 871 as the DHCP server. However, it seems like there should be other factors at play here. What affect would the port mode (access, trunk) have on the DHCP? What about if the device is VLAN aware or not? Can you recomend a good document that explains the different switchport modes in detail?

Thanks,

Diego

Correct Answer
Edison Ortiz Mon, 11/05/2007 - 15:05

By default, switchports are set for dynamic trunking.

If you connect a workstation, it will negotiate to access mode.

If you connect another switch with the same characteristics, the switchport will trunk.

As I stated before, if you connect a workstation to a switchport and the mode is to set to an access vlan #,

it will send a dhcp-request packet on that Vlan.

A DHCP server listening on that Vlan will reply with an IP address, if available.

If the DHCP server resides in another Vlan, you need to configure ip helper-address on the Layer3 gateway from that Vlan pointing to the remote DHCP server.

The DHCP server scope will need to have the default gateway information under the scope and this needs to match from the Layer3 gateway above.

As for the switchport mode query, this document provides some information:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_35_se/command/reference/cli3.html#wp1948171

DIEGO ALONSO Fri, 11/09/2007 - 10:54

Thank you sir, seems like I am well on my way to getting this all straightend out.

Rgds,

Diego

Actions

This Discussion