ASA webvpn with MS Remote Desktop Web Connection

Unanswered Question
Nov 2nd, 2007

I am configuring an ASA with a web page linking to and internal IIS server page delivering Microsoft's Remote Desktop Web Connection page. I have configured Application Access (port forwarding) and successfully tested the localhost:port# connection with mstsc.exe on the remote PC.

I can surf to the page via the ASA web links page and can see the content. The RDP activex loads and the connect button is active. But I cannot get a connection.

The same page works internally (when I change the TS server's listening port to match the port mapping via the ASA Applcation Access).

If I attempt using mstsc.exe again after the activex fails, mstsc.exe works fine. (same vpn session)

Application Access packet counters increment with mstsc.exe use but not with the activex attempts.

Is there something I am not understanding about ASA web access and VBscript or activex functionality?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
blumley Mon, 11/05/2007 - 07:54

Is there no one running MS webRDP via Cisco ASA WebVPN??!

... or at least have some idea why the MS website code won't function correctly when delivered by the ASA WebVPN "proxy"?

cranium92838 Thu, 11/15/2007 - 14:41

Have you enabled the 'Smart Tunnel' option on the bookmark URL (Advanced Options)?

blumley Fri, 11/16/2007 - 05:47

I don't see an Advanced Options on the WebVPN,Servers and URLs section.

Smart Tunnels does not appear to be an option under ASA v7.22. Is it new in v8.x?

I am testing on an ASA 5505, I have a ASA 5540 but it is not online yet.

cranium92838 Fri, 11/16/2007 - 09:41

The 'Smart Tunnel' option appears in 8.0(2) under Configuration->Remote Access VPN->Clientless SSL VPN Access->Portal->Bookmarks when you edit a bookmark entry.

I got MS Remote Desktop Web Connection running on my ASA 5505 with the clientless SSL VPN connection using that option. Without the smart tunnel enabled the connection would not go through.


This Discussion