Etherchannel on 3750

Unanswered Question
Nov 2nd, 2007

Hi,

I am trying to configure etherchannel between two linux servers and 3750 switch. Linux interfaces are bonded and can ping each other. Both are on same subnet. When I try to send traffic from one server to another I am getting throughput equal to 1 Gig and its never crossing it. Below is my switch config. Please advise if something need to be changed on switch.

interface Port-channel5

switchport access vlan 10

switchport mode access

!

interface Port-channel6

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/1

switchport access vlan 10

switchport mode access

speed 1000

duplex full

channel-group 5 mode active

spanning-tree portfast

!

i

!

interface GigabitEthernet1/0/6

switchport access vlan 10

switchport mode access

speed 1000

duplex full

channel-group 5 mode active

spanning-tree portfast

!

!

i

!

interface GigabitEthernet1/0/17

switchport access vlan 10

switchport mode access

speed 1000

duplex full

channel-group 6 mode active

spanning-tree portfast

!

!

interface GigabitEthernet1/0/23

switchport access vlan 10

switchport mode access

speed 1000

duplex full

channel-group 6 mode active

spanning-tree portfast

!

Thanks in advance.

Meerz

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Fri, 11/02/2007 - 16:08

You have to remember etherchannel is a load balancer not specifically an aggregator . If you have a specific conversation between 2 devices it is always going to go down the same link , it does not go down both ports . this is a way it works with the etherchannel hashing algorithom cisco uses. So a specific conversation in a etherchannel has a 1 gig pipe and thats it . A different conversation may go down the other side but that will also only have a gig to play with .

Actions

This Discussion