ASK THE EXPERT - CISCO SMART BUSINESS COMMUNICATIONS SYSTEM

Unanswered Question
Nov 2nd, 2007
User Badges:
  • Gold, 750 points or more

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to learn about Cisco SBCS, which is a new integrated system that provides a simple and secure Voice, Video, Data and Mobility solution, with Cisco experts Maulik Shah and Saurabh Verma. Maulik has been with Cisco Systems for the past seven years. He has worked with Unified Communications & Voice over IP systems for the last five years as part of the Cisco Technical Assistance Center and Technical Marketing Team. He has helped design, deploy & troubleshoot multiple customer VoIP networks. In his current role as Technical Marketing Engineer, he is focused on Cisco Unified Communications 500 for Smart Business Communications Solutions (SBCS) & SIP trunking deployments. He is a CCIE (# 8422) in Routing & Switching and Voice. Saurabh has been with Cisco Systems for the past seven years. He has worked with Unified Communications & Voice over IP systems for the last six years as part of the Cisco Technical Assistance Center and Technical Marketing Team. He has helped design, deploy & troubleshoot multiple customer VoIP networks. In his current role as Technical Marketing Engineer, he is focused on Cisco Unified Communications - UC500 for Smart Business Communications Solutions - SBCS deployments. He is a CCIE in Voice.


Remember to use the rating system to let Maulik and Saurabh know if you have received an adequate response.


Maulik and Saurabh might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through November 16, 2007. Visit this forum often to view responses to your questions and the questions of other.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
sudheendra1000 Mon, 11/05/2007 - 05:50
User Badges:

In IP commm when to use IPPBX and SIP server in a voice communications network?

Maulik Shah Mon, 11/05/2007 - 09:23
User Badges:
  • Silver, 250 points or more

This question does not appear to be related to this forum. Not sure of the exact question - is this IP PBX versus SIP proxy server? Typically an IP PBX allows call control of the end points locally on itself - thus a lot of the features are handled on the IP PBX (such as UC500, CUCME, CUCM). SIP proxy server would typically be used in large environments when you want to interconnect multiple IP PBXes.

devang_etcom Mon, 11/05/2007 - 13:13
User Badges:
  • Gold, 750 points or more

Maulik,


I know call manager is more intelligent then the UC500 but will you please tell me the exact difference. actually i am going to have one small project on voice deployment but i dont have knowledge of voice network so what is the best way to start learning and deployment the voice network in small and medium business...


regards

Devang

Maulik Shah Mon, 11/05/2007 - 15:13
User Badges:
  • Silver, 250 points or more

I assume you mean the windows or linux server based Call Manager (now called Communications Manager). There are lots of differences - the main one being the UC500 is more for the SMB and hence the features are targetted for that. The Communications Manager is for Enterprises.


To get started for deploying Unified Communications (voice, video etc) in the SMB - would suggest you take up the SMB specialization courses at the Partner Central site:

http://www.cisco.com/web/partners/index.html


Also, a lot of collateral is at:

http://www.cisco.com/web/partners/support/steps-to-success/index.html

If a prospective client wishes to have a proposal for a UC500 system with the ability to have four employees work from home or from a remote site, how do I configure the licensing for four soft phones on their remote PC's? Do I add in four licenses for the Cisco IP Communicator (SW-IPCOMM-E1-CH1)? Or is it SW-IPCOMM-E1= ?

Maulik Shah Mon, 11/05/2007 - 16:57
User Badges:
  • Silver, 250 points or more

You need the SW-IPCOMM-E1=. Also, please make sure the 4 softphones are within the max limit of the UC520 SKU in question.

Saurabh Verma Tue, 11/06/2007 - 06:27
User Badges:
  • Silver, 250 points or more

The recommendation is for 2 softphones. The system can support 8+2 phones. These phones could be any combination of hardphones, softphones, or wireless phones.


The UC500 comes with "CME Phone Licenses" built-in. For the 8-user UC500 system, there are 8+2 licenses, whereas, for 16-user UC500 system, there are 16+2 licenses.


Consider this example:

If you already have 8 hardphones and 2 softphones registered to the system, then you have run out of available license. However, if you have registered 4 hardphones and 2 softphones, then you can register upto 4 more softphones/hardphones/wireless phones.


HTH,

Saurabh

Saurabh Verma Tue, 11/06/2007 - 10:35
User Badges:
  • Silver, 250 points or more

Yes, that's correct. You won't need any additional licenses.


-Saurabh

gaattila Thu, 11/08/2007 - 07:21
User Badges:

I'm not sure if I can add a new question after the session has already been ended.


The UC520W-8U bundle theoretically contains 10 phone licenses, but I can configure "max-ephone 14" under telephony-service, and 14 phones can register to the CME service.

Could you please clarify this contradiction?


Thank you,

Attila

Maulik Shah Thu, 11/08/2007 - 12:39
User Badges:
  • Silver, 250 points or more

The UC520W-8U has 14 licenses - 4 for the built in FXS ports (for fax, modem, analog phones etc) & 10 for IP phones. Also, please note deleting the FXS ports is not a Cisco supported configuration.

rss_shabb Mon, 11/05/2007 - 21:51
User Badges:

hello sir i m astudent of CCNA, i want to know that which type of job i can get in call centre

JOHN NIKOLATOS Tue, 11/06/2007 - 18:49
User Badges:
  • Bronze, 100 points or more

I have a client interested in the UC500 Phone System. He wants to have paging done to an external paging system (Bose audio receiver with 3 speakers and analog input). I was told this is supported through the FXS port. Is there any info you can point me to for configuration of this?

JOHN NIKOLATOS Wed, 11/07/2007 - 17:14
User Badges:
  • Bronze, 100 points or more

Extension mobility is an option on the UC500. I have a question about what the commands would look like to allow this on the phones that support it. It does not look like the Configuration assistant has the ability to configure this through the GUI.

JOHN NIKOLATOS Thu, 11/08/2007 - 08:17
User Badges:
  • Bronze, 100 points or more

Maushah, is their documentation on how to upgrade this IOS to the latest?

Maulik Shah Thu, 11/08/2007 - 16:08
User Badges:
  • Silver, 250 points or more

You can use Cisco Config Assistant to do this. Once you download the IOS image from cisco.com to your laptop, launch CCA & connect to your UC520.


Then you can go to Maintainence -> Software Upgrade, Click on the UC520 and hit Upgrade settings and follow the steps.


Obviously when you upgrade IOS, the UC520 will need to be reloaded so make sure you do this during a down time.


Alternatively, you could use CLI:

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a00801fc986.shtml

jdelrosario Fri, 11/09/2007 - 14:02
User Badges:

Maushah,


What about the CME and CUE files that need to be uploaded? What procedure can be followed from the CLI for these files? Is it the same as the IOS upgrade procedure from the CLI?

Maulik Shah Fri, 11/09/2007 - 14:59
User Badges:
  • Silver, 250 points or more

For CME files - the process is the same - you can use CCA to drag / drop files or use CLI to TFTP.


For CUE files, not sure I understand - the CUE version shipped is the only CUE supported release on the UC500 so you cannot upgrade to anything at this time. In the future when a release is available, CCA should be able to guide you through this.

brianbrohm Fri, 11/09/2007 - 10:31
User Badges:

How does one change the Data ip from 192.168.10.1? Does it have to be done via the CLI?

Maulik Shah Fri, 11/09/2007 - 15:01
User Badges:
  • Silver, 250 points or more

If you want to change the IP address or subnet the Vlan 1 (or BVI1) interface then yes that would be via CLI.


If this is about adding a new subnet or vlan then that can be done via CCA


brianbrohm Fri, 11/09/2007 - 19:56
User Badges:

Thanks! I got the IP changed and the basics up and running. Could you point me in the right direction for fixing my IMAP access to my UC520? I have properly (i think) configured Outlook to talk to my UC520 at it's new IP of 192.168.10.15 (the data side of the UC520) however Outlook says it can't connect to the IMAP server at 192.168.10.15. I am also having trouble figuring out how to make sure I have the latest software on my UC520 and how to go about getting the newest version from cisco.com


Thanks again!

Maulik Shah Sat, 11/10/2007 - 14:17
User Badges:
  • Silver, 250 points or more

What does register your UC520 mean? Not sure if you are talking about a contract or something else.


For the IMAP access to CUE issue, make sure you can ping the UC520 IP address from the PC. Also, you may want to add the below on the CLI for CUE (we are fixing this in CCA):


UC520# service integrate 0/0 session

Trying 10.1.10.2, 2002 ... Open

User Access Verification

Username: cisco

Password:

UC500-CUE>enable

password: (hit enter - there is no password)

UC500-CUE#groupname ImapGroup create

UC500-CUE# conf t

UC500-CUE(config)# groupname ImapGroup privilege vm-imap

UC500-CUE(config)# groupname ImapGroup member



For Software updates - you can sign up online for the notification tool:

http://www.cisco.com/kobayashi/sw-center/sw-voice.shtml


All UC500 software is at the below - 4.2.4 is the latest:

http://www.cisco.com/cgi-bin/tablebuild.pl/UC520

brianbrohm Sun, 11/11/2007 - 18:21
User Badges:

Thanks for the reply! I can't ping any address from a PC other than the data side IP of 192.168.10.15 (changed via CLI from 192.168.10.1 to .15 as .1 was used on my LAN already).

Maulik Shah Mon, 11/12/2007 - 09:49
User Badges:
  • Silver, 250 points or more

What other IP address are you trying to ping - please send the current config of the UC500 so that we can understand what was changed. Also, what is the IP address on your PC (Start -> Run -> cmd, then ipconfig).

brianbrohm Sun, 11/11/2007 - 18:24
User Badges:

I have tried to access IOS download pages and the page you referred me to above for 4.2.4 but cisco.com says I'm not authorized to download. That's why I was wondering if I needed to register or tie my UC520 to my user account at cisco.com so the site would know I'm an owner of a UC500 device.


Thanks again,

brianbrohm Mon, 11/12/2007 - 10:32
User Badges:

Is there a way in the CLI to change the outbound CID number that is presented? For instance, I have 4 PSTN lines connected and I'd like for them all to show up as 678-384-5100 when we make outbound calls. Is that possible?

Maulik Shah Mon, 11/12/2007 - 10:56
User Badges:
  • Silver, 250 points or more

Yes - you can create a translation rule and apply that to all the outbound dial peers:


voice translation-rule 1

rule 1 /^.*/ /6783845100/

!

voice translation-profile OUT

translate calling 1

!

dial-peer voice xx pots << xx is the dial-peer tag >>

translation-profile outgoing OUT

brianbrohm Mon, 11/12/2007 - 06:51
User Badges:

I have tried the syntax posted above but I get....




User Access Verification


Username: cisco

Password:


UC520#enable

UC520#groupname ImapGroup create

^

% Invalid input detected at '^' marker.


UC520#


Maulik Shah Mon, 11/12/2007 - 10:11
User Badges:
  • Silver, 250 points or more

You need to session into the CUE first


UC520# service integrate 0/0 session

Trying 10.1.10.2, 2002 ... Open

User Access Verification

Username: cisco

Password:

UC500-CUE>enable

password: (hit enter - there is no password)

UC500-CUE#groupname ImapGroup create

UC500-CUE# conf t

UC500-CUE(config)# groupname ImapGroup privilege vm-imap

UC500-CUE(config)# groupname ImapGroup member


You are entering the CLI on the UC500 itself and hence the CLI is not going through.

brianbrohm Mon, 11/12/2007 - 07:03
User Badges:

I know this may seem like a silly question, but how can I tell what version of the UC500 software I'm running? I see IOS version, but not UC500.


Thanks,

Maulik Shah Mon, 11/12/2007 - 10:06
User Badges:
  • Silver, 250 points or more

For IOS version:

show version OR on CCA go to Maintenance -> Software Upgrade


For UC500 version:

show telephony-service

brianbrohm Sat, 11/10/2007 - 06:28
User Badges:

Atlanta 10 Digit Local Dialing.


We are in Atlanta GA and we have a local calling area comprising of 678, 404, and 770 area codes. We have to dial all ten digits of a number for a local calls. If I set my UC500 to 10 digits for my local calling Dial Plan in the GUI then I can't dial long distance or 800 numbers. If I set the GUI Dial Plan to 7 digits for local then I can dial long distance and 800 numbers but not 10 digit locals. Sounds like I need some CLI code right? Can you provide assitance with this?


Thanks!

Maulik Shah Mon, 11/12/2007 - 10:40
User Badges:
  • Silver, 250 points or more

I see you opened a TAC case for it (if not would recommend you open one). We are investigating the CCA side on this via the TAC case.

jdelrosario Tue, 11/13/2007 - 08:50
User Badges:

Brian,


I had the same problem. I had to go in the CLI and create voice dial-peers and have each one look for a destination pattern.. none of this is in CCA.. you will have to go through the CLI.. A good reference is the Cisco Press Book titled "Call Manager Express with Unity Express".. the UC520 has a majority of the CME and UE features and this book goes into detail how to configure features of each application. Hope this helps!!

m_wade_hartley Fri, 11/09/2007 - 14:07
User Badges:

Hey guys....we are experiecing a strange issue with the UC500...wanted to know if this is something others have seen or if this is a known issue:


The strange issue that we are seeing with the UC500 is that its auto configuring itself! We clean up the configuration...get it where we want it....save the config to startup...and then out of no where we see configuration lines back in the config.


Here are a few lines of the config where we are seeing auto configuration taking place....notice the line "call-forward all 55" on ephone-dn 10....origianlly we removed ALL call-forward lines from the ephone-dns....then we noticed that call-forward lines were back on just a couple of the ephone-dns....we removed them again...saved the config to startup...and then the line is back again. I know its not the same ephone-dns because when we first saw the call-forward line back...it was on ephone-dn 5...now we see it on ephone-dn 10....see below:


ephone-dn 5 dual-line

number 101 no-reg primary

label 101

description Clerk 1

name 101

corlist incoming user-domestic

translation-profile incoming CallBlocking

!

!

ephone-dn 6 dual-line

number 102 no-reg primary

label 102

name 102

corlist incoming user-domestic

translation-profile incoming CallBlocking

!

!

ephone-dn 7 dual-line

number 103 no-reg primary

label 103

name 103

corlist incoming user-domestic

translation-profile incoming CallBlocking

!

!

ephone-dn 8 dual-line

number 104 no-reg primary

label 104

name 104

corlist incoming user-domestic

translation-profile incoming CallBlocking

!

!

ephone-dn 9

number BCD no-reg primary

description MoH

moh ip 239.10.16.8 port 2139 out-call ABC

!

!

ephone-dn 10 dual-line

number 105 no-reg primary

label 105

name 105

call-forward all 55

corlist incoming user-domestic

translation-profile incoming CallBlocking

!

!

ephone-dn 11 dual-line

number 106 no-reg primary

label 106

name 106

corlist incoming user-domestic

translation-profile incoming CallBlocking

!


We have also seen other strange auto configuration behavior...again with ephone-dns....we had set up paging...added the ephone-dn for paging...saved the config to startup....and now the ephone-dn for paging is gone from the config....


The most we have done to the config in the last week is "sho run"....this is how we saw these changes. I want to believe this is human error....but we have been very careful making changes as well as making sure we save the config to startup..



let me know your thoughts...

Maulik Shah Fri, 11/09/2007 - 16:11
User Badges:
  • Silver, 250 points or more

The "call-forward all" gets added if a user on a phone presses CFwdAll softkey - it will show up on the config while that phone is in a Fwded state. Are you sure none of the users of the phones are doing this?


Also, you can use the below feature to log all the commands entered on the UC500:


http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080454f73.html


m_wade_hartley Mon, 11/12/2007 - 06:24
User Badges:

Actually, now that you mention it...I am pretty sure they ARE doing that. These are new users not familar with the Cisco 7961 IP Phone. Can we disable this?


Also, do you know of any other scenarios where auto configuration can happen? Any ideas why our paging-dn was removed auto-magically?


thanks for the help too...that was great input : )

Maulik Shah Mon, 11/12/2007 - 10:39
User Badges:
  • Silver, 250 points or more

You can try setting the max-length of the call-forward to 0:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_c1ht.html#wp1063421


This will disable CFwdAll completely. May need to restart all phones after this change.


Paging-dn - am not sure that is removed in any way unless someone removes the ephone-dn setup for paging by accident. This would be harder to troubleshoot unless you had the archive CLI for config logging.

m_wade_hartley Fri, 11/09/2007 - 14:12
User Badges:

Hey guys...another thing...we have a TCL application deployed on the UC500..and we are getting a disconnect with a status:


di_102


I have read the TCL IVR programmers guide and I know what it says...but I'm trying to understand what circumstances on CME/UC500 would potentially cause the disconnect with this status of di_102: Recovery on timer expiration


Any ideas of why this status gets thrown would help and be a great start for us to debug this disconnect.


thanks,


Matt

Maulik Shah Fri, 11/09/2007 - 16:17
User Badges:
  • Silver, 250 points or more

Typically for custom TCL applications - support is via the Cisco Developer Support program:


http://www.cisco.com/en/US/products/svcs/ps3034/ps5408/ps5418/serv_home.html


Without knowing details on the call flow its hard to say what you should debug. Since this is a TCL script, debugging requires a fair amount of CLI knowledge. There is a IOS debug lookup tool for various voice issues:


http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080207ec6.shtml


That you can start looking at to turn on debugs.

jdelrosario Mon, 11/12/2007 - 09:36
User Badges:

Maulik/Saurabh,


I have downloaded the newest version of Cisco Monitor Director 1.1.2 and tried to install it. The install seems to work, but we have issues with the MYSQL process. Does CMD have an option to use MSDE instead of MYSQL or is your only option to use an external database (such as Oracle)? We've tried to restart the CMD processes we have found, but when I try to add a customer to the administrative view, I can't do anything on the management interface. Thanks in advance!

jdelrosario Mon, 11/12/2007 - 14:32
User Badges:

I've got 2 issues.


#1 -- I want to change the configuration of my UC520 from a PBX to a keysystem. According to the SBCS Implementation Guide, if you disconnect all IP phones, you should be able to make the change from CCA. I have done that and the option is still greyed out. Is there a series of commands I would need to use from the CLI to do this?


#2 I am trying to change the IP telephony zone on the same UC520 but it is grayed out. It is currently on "GMT -12:00 Eniwetok, Kwajalein" and it is grayed out. I need to go to "U.S. - 6:00 Chicago" but I can't use the drop down menu because it is grayed out. How can this be fixed? I have a valid NTP server and my system time on the UC520 is correct. The system time on the UE-500 Integrated Service Engine is also correct. Is there a way to fix this problem through the CLI of either application?


For both issues, I am using CCA 1.1(1) and have upgraded my UC520 to 4.2.4 (IOS 12.4(11)XW4)


Any help is greatly appreciated!


Thanks in advance!


Actions

This Discussion