cdp on sc0 interface

Answered Question
Nov 2nd, 2007
User Badges:

How can you enable cdp on just the sc0 interface? Our private(management) connection is plugged into the mgmt port on the supervisor. So how do you specify that port, if you can? Thanks.

Correct Answer by Joe Clarke about 9 years 5 months ago

Correct. If you disable CDP on the other ports, then they will not see any advertisements.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Fri, 11/02/2007 - 11:38
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

It makes no sense to have CDP running on sc0 since sc0 is a virtual interface. Instead, you want to have CDP enabled on all ports that connect to other managed Cisco devices. This way, you will be able to find all of your directly connected neighbors.


So it sounds like you just want to enable CDP on your supervisor ethernet port (port 1/1, for example). In that case:


set cdp enable 1/1

MZydorczyk2 Fri, 11/02/2007 - 12:08
User Badges:

Thanks for the response. However, I dont think I can do that because as I mentioned, we have a public and private network. So if I enabled cdp on 1/1 (the uplink), it would be visible on the public net, which my director does not want.


It doesnt sound like there is any way for me to do this then unless the private was plugged into a port other than the mgmt on the supervisor.


EDIT: Unless...if the other ports have cdp disabled, then they shouldnt get any of the advertisements correct?

Correct Answer
Joe Clarke Fri, 11/02/2007 - 12:12
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Correct. If you disable CDP on the other ports, then they will not see any advertisements.

Actions

This Discussion