logging buffered not working

Unanswered Question
Nov 2nd, 2007
User Badges:

Hi,


i don't see any events logged to buffer. Can you advise why?


logging buffered 16384 informational

! also tried

! logging buffered 20000 debug


logging [server_ip]

!

...

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps config

snmp-server enable traps syslog

snmp-server host [server_ip] network

snmp-server host [server_ip_1] public


















6509_sup_750#conf t

Enter configuration commands, one per line. End with CNTL/Z.

6509_sup_750(config)#int g3/33

6509_sup_750(config-if)#shut

6509_sup_750(config-if)#^Z

6509_sup_750#sh log

Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes, 0 overruns)

Console logging: level debugging, 125 messages logged

Monitor logging: level debugging, 0 messages logged

Buffer logging: level debugging, 5 messages logged

Exception Logging: size (4096 bytes)

Count and timestamp logging messages: disabled

Trap logging: level informational, 141 message lines logged

Logging to [server_ip], 141 message lines logged


Log Buffer (20000 bytes):


Nov 2 17:19:34.770: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])

Nov 2 17:20:19.954: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ( [laptop_ip])

Nov 2 17:24:08.302: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])

Nov 2 17:24:24.142: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ( [laptop_ip])

Nov 2 17:24:38.394: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])

6509_sup_750#conf t

Enter configuration commands, one per line. End with CNTL/Z.

6509_sup_750(config)#int g3/33

6509_sup_750(config-if)#no shut

6509_sup_750(config-if)#^Z

6509_sup_750#sh log

Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes, 0 overruns)

Console logging: level debugging, 126 messages logged

Monitor logging: level debugging, 0 messages logged

Buffer logging: level debugging, 6 messages logged

Exception Logging: size (4096 bytes)

Count and timestamp logging messages: disabled

Trap logging: level informational, 142 message lines logged

Logging to [server_ip], 142 message lines logged


Log Buffer (20000 bytes):


Nov 2 17:19:34.770: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ( [laptop_ip])

Nov 2 17:20:19.954: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])

Nov 2 17:24:08.302: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ( [laptop_ip])

Nov 2 17:24:24.142: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])

Nov 2 17:24:38.394: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ( [laptop_ip])

Nov 2 17:24:50.630: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 11/02/2007 - 14:17
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I don't see the problem. You have five messages logged to the buffer:


Nov 2 17:19:34.770: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ( [laptop_ip])

Nov 2 17:20:19.954: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])

Nov 2 17:24:08.302: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ( [laptop_ip])

Nov 2 17:24:24.142: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])

Nov 2 17:24:38.394: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ( [laptop_ip])

Nov 2 17:24:50.630: %SYS-5-CONFIG_I: Configured from console by [username] onvty2 ([laptop_ip])


What are you expecting to see?

danger_mousie Fri, 11/02/2007 - 14:24
User Badges:

In the example you can see me admin down an interface, this doesn't appear in the logs. Cabling was done today so interfaces and port channels were going up and down but none of that appears in the logs.


Thanks.

danger_mousie Fri, 11/02/2007 - 14:26
User Badges:

141 messages were sent to the server_ip but only 5 appear in the logging buffer

Joe Clarke Fri, 11/02/2007 - 17:17
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I missed where you downed an interface in your testing. It would be helpful to see the full show run as well as a show ver from this switch.

danger_mousie Sat, 11/03/2007 - 04:11
User Badges:

Solution:


6509(config)#int range g2/1 - 48

6509(config-if-range)#logging event link

6509(config-if-range)#logging event bundle

6509(config-if-range)#logging event trunk

6509(config-if-range)#logging event spanning-tree status




Nov 3 13:04:09.986: %LINK-5-CHANGED: Interface GigabitEthernet3/33, changed state to administratively down

Nov 3 13:04:09.990: %LINK-SP-5-CHANGED: Interface GigabitEthernet3/33, changed state to administratively down

Nov 3 13:04:12.374: %LINK-3-UPDOWN: Interface GigabitEthernet3/33, changed state to down

Nov 3 13:04:13.006: %SYS-5-CONFIG_I: Configured from console by [username] onvty0 ([laptop_ip])

Nov 3 13:04:12.378: %LINK-SP-3-UPDOWN: Interface GigabitEthernet3/33, changed state to down


Actions

This Discussion