Unity Connection Call Handler Caller Input settings

Unanswered Question
Nov 2nd, 2007


Quick question. On unity connections caller input, is there a way to disable the dialing of extensions like there is in full blown Unity caller input settings?

The problem we had was we had a new call handler we working on and had set the caller input to be locked, but when you entered like 521 it would transfer to extension 521 and not do what option 5 went to and 5 was a locked key.

We had saved the caller input, but when we went under caller input and chose 'save caller input settings' , after this was done it started working as expected. Does save caller input settings do something different then a normal save?

If the dialing of extensions can't be disabled in unity connections, is the way to prevent that by lowering the time for additional digits down really low?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rob.huffman Fri, 11/02/2007 - 17:28

Hi Erick,

So this process does not work?

Step 3 On the Edit Call Handler page, on the Edit menu, click Caller Input.

Step 4 In the Single Key Settings table, click the applicable touchtone key.

Step 5 On the Edit Caller Input page for the key you have selected, check the Ignore Additional Input (Locked) check box.

Step 6 Click an Action, and change settings as applicable.

Step 7 Click Save.


Let us know,


Erick Bergquist Fri, 11/02/2007 - 21:06

Something funky was going on, as all the caller input settings showed all the options right. The keys were locked (ignore additional input). But when you called and hit that call handler (yes, I made sure it was the one being used) and entered 555 instead of just 5 it would transfer to extension 555 and not go to what 5 was mapped to. The client was testing that no one could dial extensions since they didn't want this to be a backdoor to get to someones extension.

I had updated and resaved a caller input setting even with above settings, and same thing.

After I went back to the edit -> caller input screen I chose Call Handler -> Save Caller Input settings under the main Caller Input Keys screen and after that, it seems to be working with the locked keys fine.

The main reason I had posted this was to see if there was a way to set the call handler to not accept extensions to be dialed, like in full blown unity call handler caller input screen. That option isn't in connections unless it is someplace else I haven't found yet. It wouldn't be a big deal but we had this odd behavior with locked keys. So we had also bumped the time to wait for additional keys down to 200ms to hopefully prevent extension dialing on these call handlers.


This Discussion