CCM 6 MGCP ISDN Backhaul

Unanswered Question
Nov 2nd, 2007
User Badges:

I have a 2801 that has a 12 channel frac ISDN PRI on it programmed for channels 12-24. When i don't bind it to MGCP it comes up fine and the ISDN layer 2 status shows established. Whenever I have CCM takeover it switches between TEI_Assigned and Awaiting Establishment. The settings on the T1 controller on the router are

switch-type primary-ni

linecode: b8zs

framing: esf


CCM underneath the T1 controller VWIC-1MFT-T1 is configured with the same 0 in the input and output gain. Clock: External framing and linecode the same and disabled echo cancellation. I have attached a picture of the other settings.



any help is appreciated.


Rob




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
allan.thomas Fri, 11/02/2007 - 18:41
User Badges:
  • Blue, 1500 points or more

Due to the ISDN PRI being fractional I would recommend that you configure the CallManager services parameters to busy out the respective channels and enable status poll under the MGCP configuration in CallManager.


This enables the Cisco Unified CallManager advanced service parameter to Change B-Channel Maintenance Status. This service parameter allows you to take individual B-channels out of service for an MGCP T1/E1 PRI gateway in real time.


I have also noticed that the channel selection has changed to TopDown, this is generally first to last, and BottomUp is last to first and is the default.


Regardless of the above the backhaul should register if the controller is up and L3 is established.


Could you please forward your MGCP gateway configuration.


Regards

Allan.

rraver Fri, 11/02/2007 - 18:47
User Badges:

here is hte router config, some stuff stripped but nothing related to the voice.


I will add that config in as well ...



Attachment: 
rraver Fri, 11/02/2007 - 19:02
User Badges:

I noticed that the pri-group timeslots 1-24 was there so I stripped the binding off of the ser 0/2/0:23 interface shutdown the voice ports removed it and then added the pri-group timeslots 12-24 command in there, when I re-enabled the ports and bound the isdn l3 ccm command to the ser 0/2/0:23 it put it back to 1-24, any ideas? It's showing established underneath the isdn status now also though.,

allan.thomas Sat, 11/03/2007 - 03:53
User Badges:
  • Blue, 1500 points or more

This is problem with MGCP and fractional PRI in comparision to H323.


In order to ensure that CCM does not configure the Controller remove the ccm-manager config command and then remove and reconfigure your pri-group as before.


This only becomes absolutely necessary if you are unable to busy the b-channels/time-slots within service parameters as you limited to only 5 gateways. Also, the other caveat is that you have only provided enough DSPs for the number channels on the PRI and for hardware transcoding/conferecing resources. CCM will configure all timeslots which will therefore use DSPs which you would ordinarily allocate to these resources.


Regards

Allan.


HTH.

Hi, Allan,


is there a way to busyout the B-Channels only for a specific PRI if i have e.g. 4 MGCP Gateways and only 1 fractional with 10 B-Channels ?


Kind regards



STOP:


Here is the answer... RTFM ;-)


Input Format:

Device Name = B-channel Maintenance Status

Example:

[email protected] = 0000 1111 0000 0000 0000 0001 (24 bits for T1. Channel number begins with 1 to 24 from left to right. In the case of PRI, the last bit specifies the D-Channel, which does not get affected. In this example, the 5th through 8th B-Channels are out of service.)

or,


Steffen

allan.thomas Fri, 11/09/2007 - 01:54
User Badges:
  • Blue, 1500 points or more

Glad you found the answer, it always help to RTFM, but sometimes things are not always that obvious.


Any questions drop me a line.


Regards

Allan.

Actions

This Discussion