l2tp/ipsec Remote Access Vpn

Unanswered Question
Nov 3rd, 2007
User Badges:

hi ,

i wanna configure l2tp/ipsec vpn between winXP Client And Pix515e Firewall .


this is my configuration :



PIX Version 7.2(2)

!

hostname Pix

enable password xxx

names

!

interface Ethernet0

nameif outside

security-level 0

ip address 172.16.1.254 255.255.255.0

!

interface Ethernet1

nameif inside

security-level 100

ip address 192.168.0.1 255.255.255.0

!

interface Ethernet2

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet3

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet4

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet5

shutdown

no nameif

no security-level

no ip address

!

passwd xxx

ftp mode passive

access-list nonat extended permit ip 192.168.0.0 255.255.255.0 10.20.30.0 255.255.255.0

access-list l2tp extended permit ip host 172.16.1.254 any

pager lines 24

mtu outside 1500

mtu inside 1500

ip local pool mypool 10.20.30.1-10.20.30.100 mask 255.255.255.0

no failover

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout uauth 0:05:00 absolute

aaa-server radius protocol radius

aaa-server radius host 192.168.0.2

key nasser

group-policy l2tpipsec internal

group-policy l2tpipsec attributes

dns-server value 4.2.2.4 192.9.9.3

vpn-tunnel-protocol l2tp-ipsec

default-domain value NCG

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set l2tp esp-des esp-sha-hmac

crypto ipsec transform-set l2tp mode transport

crypto ipsec security-association lifetime seconds 3600

crypto dynamic-map dyna 20 set transform-set l2tp

crypto map mymap 10 ipsec-isakmp dynamic dyna

crypto map mymap interface outside

crypto isakmp enable outside

crypto isakmp policy 20

authentication pre-share

encryption des

hash md5

group 1

lifetime 86400

tunnel-group l2tpipsec type ipsec-ra

tunnel-group l2tpipsec general-attributes

address-pool mypool

authentication-server-group radius

default-group-policy l2tpipsec

tunnel-group l2tpipsec ipsec-attributes

pre-shared-key nasser

tunnel-group l2tpipsec ppp-attributes

authentication pap

authentication ms-chap-v2

telnet timeout 5

ssh 192.168.0.0 255.255.255.0 inside

ssh timeout 60

console timeout 0

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum 512

policy-map global_policy

class inspection_default

inspect dns preset_dns_map

inspect ftp

inspect h323 h225

inspect h323 ras

inspect netbios

inspect rsh

inspect rtsp

inspect skinny

inspect esmtp

inspect sqlnet

inspect sunrpc

inspect tftp

inspect sip

inspect xdmcp

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:xxx

: end



now when i debug crypto isakmp i get this messages :


Pix(config)# Nov 03 11:40:50 [IKEv1]: Group = 172.16.1.22, IP = 172.16.1.22, Can't find a valid tunnel group, aborting...!

Nov 03 11:40:50 [IKEv1]: Group = 172.16.1.22, IP = 172.16.1.22, Removing peer from peer table failed, no match!

Nov 03 11:40:50 [IKEv1]: Group = 172.16.1.22, IP = 172.16.1.22, Error: Unable to remove PeerTblEntry

Nov 03 11:40:51 [IKEv1]: IP = 172.16.1.22, Header invalid, missing SA payload! (next payload = 4)

Nov 03 11:40:53 [IKEv1]: IP = 172.16.1.22, Header invalid, missing SA payload! (next payload = 4)



and in client side i get error 800 .

please help me .

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ivillegas Wed, 11/07/2007 - 14:26
User Badges:
  • Silver, 250 points or more

This error message on the PIX means that the tunnel group for the connection is not configured correctly. Make sure that the tunnel-group name to the ip address of the remote peer.


Actions

This Discussion