Issue with Gig port of 12006 GSR

Unanswered Question
Nov 5th, 2007

IOS c12kprp-k3p-mz.120-32.SY4.bin and c12k-fpd-pkg.120-32.SY4.pkg

We have 2 Gigabit port SPA (SPA-2X1GE-V2=). It has both options SFP and RJ45. But when we change media-type rj45, the port doesn't come up until we insert Fiber module in the optical slot.

I issued shut command after providing media-type rj45. And when I did no shut, amber LED next to RJ45 connector starts glowing. Then I connected a cross (tried straight as well) cable between two GSRs, the amber LED turns green but port remains down. I issued IP address, no negotiation, several combination of speed and duplex as well but no help.

Can any one please help, if it is an IOS problem or something else??

When I insert Gig module in it's slot, port came up and start pinging on RJ45 copper cable.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
owillins Mon, 11/12/2007 - 07:11

Could you paste the following output.

show interfaces interface-name interface-number

show tech

show log.

balajitvk Sun, 11/18/2007 - 07:00

Hi Bharat,

You can try the same in the below mentioned order.....


media-type rj45

speed { 10 | 100 | 1000 | auto }

duplex { full | half | auto }

no shut

After changing the media type, configure the speed and duplex to appropriately match the new interface characteristics. i.e rj45 and then give no shut to the port.....

It seems to be independent of availablity of Fiber SFP.

Rate if it does,



This Discussion