Need Advice on how to setup moh on local router.

Unanswered Question
Nov 6th, 2007

Ive already got a tac case logged regarding this, but whilst i'm waiting for a reply I thought I would ask for other peoples advice.

A customer has asked us to configure music on hold to be played locally at one of there remote sites and I believe this can be done by storing the sample on the remote router. Thus when any phone at the remote office is placed on hold this will be streamed from the router and not from head office. By the way ive already read through moh from site router document but need some clarification on how to do this.

Here is some info about the customer's setup of the call manager.

Currently they have three call managers all located at there cental office. All three call managers are currently configured as MOH servers and currently music on hold is only being played at central office via unicast streaming.

They would like to still play the head office music on hold streaming via unicast and have the remote site streaming music via multicast. I plan to remove the third server from the central office moh group and to create a new moh group and place the third server for multicast streaming.

This is what I plan do to set this up on the call manager first, I will ask about the router config later but please let me know if this is correct:-

1. Create new region configuration called MOH_Remote

2. Apply G.711 on all codecs for all sites for MOH_Remote.

3. Remote third MOH server from current moh group (mrg-co-moh)

4. Edit 3rd server moh

6. Tick enable multicast audio sources on this MOH server

7. Enter Multicast ip address port 16384. (Second audio source)

8. Create new music on media resource group called mrg-remote-moh and add 3rd server MOH

9. Edit MRGL-6428 (mrgl-list for remote site)

10. Add MRG-remote-moh to this list.

12. Create a new device pool called MoH_DP

13. Apply MoH_remote region and MRG-remote-moh to this dp.

14. Add music on hold audio source, with this source allow multicast and play continuously.

15. Add the MoH_DP to the moh server.

Do I also need to add the moh_dp to the central office media resouce list as well?

Thanks all.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
allan.thomas Tue, 11/06/2007 - 04:43

The MoH device pool is only associated with the MMOH audio source on your third server, so it will only be necessary to add the MRG-remote-moh to the central media resource list if you intend endpoints which are associated with this MRGL to receive multicast. Which if I understand you correctly you do no want to do.

Ensure that the audio file or the codec of the audio source that you copy on the IOS Flash matches what within CCM u-law in this case.

Incidentally if you configure the base address to be, CCM will increment the IP address for each codec, if that is what you have selected.

You will only need to configure the IOS multicast moh command with the address Configuring the base address to be within CCM will mean that the second MMOH audio source will actually be

Remember to specify your incoming moh interface when you configure the multicast moh command. Also make sure that the audio file is already on the flash before configuring the moh file, multicast moh commands. If you don't you may find that when you run 'show ephone summary' the audio source may appear as invalid. Simply remove the commands and reconfigure once the file is on the flash.




Pls rate helpful posts.

networkdefence Tue, 11/06/2007 - 05:14

Thanks Allan

So what you say is even though I want to play the audio source 2, I still keep the multicast address as for u-law and have the ios multicast address as for the correct codec.

Also if I assign the mrg-remote-moh to the mrgl of the remote site this should enough configuration work on the ccm.

If so then I may have a few questions regarding the router config now shortly.



allan.thomas Tue, 11/06/2007 - 06:34

That's correct, configure the base address on MMoH server to be and simply increment the address when you specify the IOS multicast moh for the correct source and codec.

Providing you have configured the MoH region, enabled the appropriate MRG for MMoH and associated this with DP for the MoH Server, then this should sufficient. One other thing, ensure that the hop count on the MMoH audio-source is configured to 1.

Drop a line if you have any question regarding the IOS config.



networkdefence Tue, 11/06/2007 - 08:11


Right ive setup the moh file on the router and have placed this within the srst config as per the MoH from remote site router docs.

This router is currently running ios ver 12.4(3a) do I need to setup a local loop back address? Otherwise will doing multicast moh port 16384 work?



networkdefence Tue, 11/06/2007 - 09:27

It's ok ive placed a random local loop back address and used this.

Now i haven't reset the mrgl for the remote site yet as this resets all phones. But should I be getting this running a debug ephone moh:-

*Nov 6 17:23:39.152: skinny_get_moh_from_codec MOH_TYPE_INVALID

*Nov 6 17:23:39.156: Can not open file flash:audio-ulaw.wav

skinny_get_moh_from_codec MOH_TYPE_INVALID



allan.thomas Tue, 11/06/2007 - 09:37

You need to specify the multicast interface for which MoH will be forced out of, ordinarily this will be your FE or the voice-vlan sub-if on the FE if you have one.

A loopback interface must be configured and included in the list of IP addresses on the multicast moh command.

Without this, no MoH is heard on the POTS ports on the gateway if configured. In previous IOS versions I found that regardless of whether I had POTs configured or not it would only work with a loopback as well.




networkdefence Tue, 11/06/2007 - 09:47

Thanks strange as ive already configured the loopback address as follows:-

loopback 0

ip address

ccm-manager music-on-hold

moh audio-ulaw.wav

multicast moh port 16384 route (ip address of gigabit ethernet interface)



allan.thomas Tue, 11/06/2007 - 09:51

Could you post a 'show ephone summary' and also a 'show ccm-manager music' when a call is on-hold.

These should provide helpful information is ascertaining the status of the MoH and whether Cisco CallManager is failing to provide the gateway with MoH.

If the ephone summary show as invalid, if the audio file is in the correct format, then try removing the moh commands and reapplying.



networkdefence Wed, 11/07/2007 - 09:14

Right after restarting the moh server and reseting the mrgl for the remote site the music on hold still isn't playing.

Please see below the 'show ephone summary':

Max Conferences 12 with 0 active (8 allowed)

Skinny Music On Hold Status

Active MOH clients 0 (max 720), Media Clients 0

File audio-ulaw.wav type INVALID Media_Payload_G711Ulaw64k 160 bytes

Moh multicast on port 16384 via

Also when a user is on hold running show ccm-manager music it doesn't display any music information?

Any ideas?


allan.thomas Wed, 11/07/2007 - 09:36

The show ephone summary indicates that audio-source is invalid, have you tried removing the ccm-manager music, and the multicast moh commands and then re-applying? Does it still show as invalid after?



networkdefence Thu, 11/08/2007 - 09:24

well i'm now trying with a different sample and it's no longer displaying any error messages, however the music on hold still isn't working.

Thanks for the document, ive followed everything and should work, but its not.


allan.thomas Thu, 11/08/2007 - 09:38

Firstly remove SRST 'call-manager-fallback' completely and reconfigure the commands.

I have come across problem with changing the audio-source before and by removing SRST and reconfiguring resolved the problem.

Verify whether MMOH resources are being allocated by CCM through RTMT or Perfmon.

If you hear silence then CCM is allocating the resource as expect, if you receive ToH however then there is a problem within the CCM configuration.




This Discussion