low transfer rate with NAT/Duplex/Speed settings

Answered Question
Nov 6th, 2007

Hi all, I'm having this problem and I cannot find any bug or TAC case in the collection. I'm using PAT between two ethernet interfaces on a c3745 or c3845(I tried both in a lab).

If I keep the duplex and speed negociation to auto, everything works fine and it autonegotiates to full/100, but as soon as I force the duplex to full and speed to 100, the transfer rate of my FTP drops considerably. When I change the speed back to auto everything goes back to normal. I've tried the latest IOS but the problem persist.

Anyone experienced the same problem? Any ideas?

Thanks in advance,

Mariano

I have this problem too.
0 votes
Correct Answer by lgijssel about 9 years 2 months ago

Fixing speed and duplex must be done on both sides. If one end remains in auto-mode the connection will default to half duplex.

This will result in a duplex mismatch between the devices.

http://www.cisco.com/univercd/cc/td/doc/cisintwk/itg_v1/tr1904.htm

regards,

Leo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
marianodt Tue, 11/06/2007 - 07:16

Thank you for your answer. I was confused because both sides reported a full/100 negotiation, but forcing caused the problem.

I guess I'll stay in the safe side by forcing everything. Anyway, thanks again.

Actions

This Discussion