Multiple ISP connecting to one router

Unanswered Question
Nov 7th, 2007

Hai, need ur profesional advised,

i have 1 core router that connected to 3 ISP and 5 customer with differ capacity

cust1-ISP1-2M

cust2-ISP1-4M

cust3-ISP2-stm1

cust4-ISP3-45M

cust5-ISP3-8M

1. do i need edge router that will interconnect to my customer. can i directly connect to my core router?

2. all routing to ISP is static route. ist possible

3.how can i manage the bandwith as different customer and different isp. is there a way i can have this via policy.

4. do i need to dedicate one customer to one router port, is there a way i can shared everything and save my port expecially E1 port which is expensive?

I really need your answer and help.. iam alone..i already try searching but nothing close.

please my frenz. TQ in advanced!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
bvsnarayana03 Wed, 11/07/2007 - 02:27

1. Either u get a separate edge router or WIC ports for each customer.

2. Use separate VRF instances for each customer. This way u can manage with static routes.

3. U can police the bandwidth on each interface to restrict it to the required value.

chenoi2007 Wed, 11/07/2007 - 02:38

1. Either u get a separate edge router or WIC ports for each customer. --> can i have multiple customer with different bandwith req and prefered isp into one edge router.

2. Use separate VRF instances for each customer. This way u can manage with static routes. --> even if my network is not MPLS i can run VRF?

3. U can police the bandwidth on each interface to restrict it to the required value.--> this interface referring to edge router interface? or core router interface?

TQ

chenoi2007 Wed, 11/07/2007 - 05:37

advised please,

if i only have one core router is it possible to have MPLS running? and do i must have PE router?

one more thing.. is this design possible?

Phillip Hichens Thu, 11/08/2007 - 01:56

Hi

Looking at your original requirement one core router will do, you can directly connect your customers, no mpls or vrf lite required.

Just use PBR and policing.

Please note I thumb sucked most of the values and you should LAB test this first.

Keep in mind NAT might also be a requirement, depending on your addressing scheme.

Depending on your router hardware the config should look something like this:

#CUST1 ip range

access-list 1 permit 192.168.1.0 0.0.0.255

#CUST2 ip range

access-list 2 permit 192.168.2.0 0.0.0.255

#CUST3 ip range

access-list 3 permit 192.168.3.0 0.0.0.255

#CUST4 ip range

access-list 4 permit 192.168.4.0 0.0.0.255

#CUST5 ip range

access-list 5 permit 192.168.5.0 0.0.0.255

!

class map CUST1

match access-group 1

class map CUST2

match access-group 2

class map CUST2

match access-group 3

class map CUST3

match access-group 3

class map CUST4

match access-group 4

class map CUST5

match access-group 5

!

route-map ISP1 permit 10

match ip address 1

set interface ATM1/0

!

route-map ISP1 permit 20

match ip address 2

set interface ATM1/0

!

route-map ISP2 permit 10

match ip address 3

set interface POS2/0

!

route-map ISP3 permit 10

match ip address 4

set interface ATM1/1

!

route-map ISP3 permit 20

match ip address 5

set interface ATM1/1

!

policy-map ISP1

class CUST1

bandwidth 2048

police 2048000 20000 40000 conform-action transmit exceed-action drop

class CUST2

bandwidth 4096

police 4096000 40000 80000 conform-action transmit exceed-action drop

!

policy-map ISP3

class CUST4

bandwidth 45056

police 45056000 450000 900000 conform-action transmit exceed-action drop

class CUST5

bandwidth 8192

police 8192000 80000 160000 conform-action transmit exceed-action drop

!

interface ethernet 0/1

description CUST1

ip policy route-map ISP1

!

interface ethernet 0/2

description CUST2

ip policy route-map ISP1

!

interface ethernet 0/3

description CUST3

ip policy route-map ISP2

!

interface ethernet 0/4

description CUST4

ip policy route-map ISP3

!

interface ethernet 0/5

description CUST5

ip policy route-map ISP3

!

interface ATM1/0

description ISP1

service-policy output ISP1

!

interface ATM1/1

description ISP3

service-policy output ISP3

!

interface POS2/0

description ISP2

Regards

Phillip

chenoi2007 Thu, 11/08/2007 - 08:59

Hai..thanks phillip,

my network design ok? and i can connect directly to my core. no need mpls and vrf.

fyi..i didnt have control on the ip address , it will given by upstream provider to our customer. we only handle the routing from our customer to their respective isp. so..is this configuration suitable also with my scenario?... TQ

Phillip Hichens Wed, 11/21/2007 - 03:58

Hi

Sorry, been out of the office.

Yes the configuration is suitable with your scenario, you just need to mark cust IP addresses provided by the ISP with the ACL.

As for bringing it in to your core, it will work but not best practise, this all depends on the requirements and feasibility of adding a dedicated edge box. Either way no mpls or vrf required.

Regards

Phillip

Actions

This Discussion