ICM HDS replication stops working

Unanswered Question
Nov 8th, 2007

Hi, all.

Recently we have encountered an issue for the ICM HDS data replication. When we tried to view some historical reports such as skill group half hour, trunki group half hour (for current date) on the webview, nothing was shown, there was only 1 line of record showing some "0" values.. However, some other reports such as Call Type Half Hour, Agent Task Summary Half Hour are working fine and they are able to show the stats for the current date..

When I looked at the rpl process window on the HDS, the log space used was 25% and it didn't seem to decrease.

I also noticed that, under Space Used Summary for the HDS database by using icmdba, the "Max DateTime" under those tables which store the historical data for the mentioned report, showed the date of 3 days ago, which is not up-to-date. however, the "Max DateTime" for the rest of the tables has got the current date..

Appreciate it if any expert can enlighten me with some clue or solution.. it this caused by the over utilization of the transaction logs for the HDS, as shown in the rpl process window? We tried to do a dump tran with no_log query and rebooted the HDS server, but it didn't help at all. the log space used still stays at 25%..

I have also checked and confirmed there is up-to-date historical data in the Logger database. We are using ICM 6.0 SR2..

Thanks & Regards,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jeff.marshall Thu, 11/08/2007 - 05:52

Is there any data in those tables that you reference in the hds_db?

Upon start-up, does the rpl log show any additional warning messages? invalid date/time? duplicate record?

You're running v6.0 so that indicates that you've been deployed for some time. Is this an issue that has always been there or is this something new?


eric.neoh Sun, 11/11/2007 - 18:24

Hi, Jeff.

Those tables only contain historical data up till 5th Nov 1pm, which is not up to date..

I didn't notice any message in the rpl process, which indicated any invalid date time or duplicate record. Btw, will any of these exception event possibly cause the issue to happen?

Yup, it has been running for about 3 years and this issue happened since last week only..

Any other clue that we can find?

Thanks & Regards,


rbua Thu, 11/08/2007 - 06:01

Hi Eric,

check the overall space used in the DB on the HDS if it is higher then the threshold set for the DB to grow then the data is going to be trimmed, no matter the retention period being set.



eric.neoh Sun, 11/11/2007 - 18:30

Hi, Riccardo.

The overall space used is about 60% and it should be still below the threshold set for the DB to grow.. However, As mentioned in my first post, I noticed that the space used for the log is constantly at about 24% to 35%, will this cause any replication problem?

Under what kind of circumstances, the rpl process only replicates partial of the historical tables?

Appreciate your advice and help.

Thanks & Regards,



This Discussion