why not all MAC appearing on table?

Unanswered Question
Nov 8th, 2007
User Badges:

Hi guys,


Please see below outputs,


1st Question:

why no all mac address appearing on mac table?

This is for cisco C6513 model

Should be ARP table should be listing all the available arp matches?

This interface is connected to a server.



sw9#sh mac-add int f5/38

Legend: * - primary entry

age - seconds since last seen

n/a - not available


vlan mac address type learn age ports

------+----------------+--------+-----+----------+--------------------------

* 107 0015.6053.c61d dynamic Yes 0 Fa5/38 >>>>>>>>>>>>>>>>>>>




sw9#sh run int f5/38

Building configuration...


Current configuration : 191 bytes

!

interface FastEthernet5/38

description SERVER002_SEC >>>>server

switchport

switchport access vlan 107

switchport mode access

no ip address

speed 100

duplex full

spanning-tree portfast

end




sw9#sh ip arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 204.x.52.12 0 0015.c67f.5f2d ARPA Vlan2

Internet 204.x.52.13 0 0015.63a4.8dc2 ARPA Vlan2

Internet 204.x.52.11 - 0013.5fd3.8dc0 ARPA Vlan2

Internet 204.x.52.8 4 000e.d68d.0400 ARPA Vlan2

Internet 204.x.52.9 12 000e.d68c.cc00 ARPA Vlan2

Internet 204.x.52.1 34 0000.0c07.ac00 ARPA Vlan2

sw9#


only few mac-addresses are shown in the output.


====================================================



2nd Question:


Why when i tried to find information about Vlan 107, i got below error:

but from Sh vlan output, i can see the vlan name and ports associated to it.



sw9#sh run int vlan 107

^

% Invalid input detected at '^' marker.


sw9#



sw9#sh vlan


VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa4/35, Gi9/42, Gi9/43, Gi9/44

Gi9/45, Gi9/46, Gi9/47, Gi9/48

Gi12/9, Gi12/29, Gi13/12

Gi13/13, Gi13/14

2 Management_Vlan_2 active Gi10/14, Gi12/1, Gi12/48


........................


107 Server_Prod active Fa2/20, Fa5/17, Fa5/18, Fa5/19

Fa5/20, Fa5/21, Fa5/25, Fa5/37

Fa5/38, Fa5/39, Fa5/42, Fa5/43

Fa5/44, Fa5/45, Fa5/46, Fa5/47

Fa5/48, Gi12/2, Gi12/4, Gi12/5

Gi12/8, Gi12/25, Gi12/38




This is for model C6509 which i can see more vlan information.


sw8#sh run int vlan413

Building configuration...


Current configuration : 284 bytes

!

interface Vlan413

description HYPERION_FW_MGMT

ip address 192.x.35.75 255.255.255.248

no ip redirects

no ip proxy-arp

ip route-cache flow

arp timeout 1800

standby ip 192.x.35.74

standby priority 110

standby preempt delay minimum 5

standby authentication opsmgtpl

end


sw8#

======================================


Thanks in advance


SiraJ

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Thu, 11/08/2007 - 04:48
User Badges:
  • Red, 2250 points or more

Both symptoms can be explained by the assumption that the switch is configured as a layer2 switch. It does not do any ip routing and hence it only needs arp for things like management PC's etc. All the "real work" is done via the cam-table at layer2.

When the switch is configured as layer 2, you will not see an int vlan 107 because it doesn't exist in the configuration.


regards,

Leo

Actions

This Discussion