cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1612
Views
0
Helpful
3
Replies

LMR troubleshooting

stephan.steiner
Spotlight
Spotlight

We have a working LMR setup in a customer's lab (2811 ISR, VIC2 2e/m module connected to Polycom radio system) - we're trying to replicate it in our own lab, with somewhat different hardware: 2651XM and a VIC 2e/m)

The integration we have is based on multicast... any multicast voice sent to 239.224.0.1 port 21086 should be send to the e/m port, and likewise, any voice signal coming to the interface should be send via multicast.

Here's my current config:

Building configuration...

Current configuration : 1794 bytes

!

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 32000 debugging

enable secret xxx

enable password nextiraone

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

no ip domain lookup

ip multicast-routing

!

!

!

!

!

!

!

!

voice class permanent 11

signal timing oos timeout disabled

signal keepalive disabled

signal sequence oos no-action

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Vif1

ip address 172.16.10.1 255.255.255.252

ip pim sparse-dense-mode

!

interface FastEthernet0/0

ip address 10.145.5.111 255.255.252.0

ip pim sparse-dense-mode

speed auto

full-duplex

no cdp enable

no mop enabled

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.145.4.1

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 1/1/0

auto-cut-through

operation 4-wire

signal lmr

lmr e-lead voice

no comfort-noise

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-in 0

connection trunk 8611

description Funk

!

voice-port 1/1/1

auto-cut-through

operation 4-wire

signal lmr

lmr e-lead voice

no comfort-noise

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-in 0

connection trunk 8611

description Funk

!

!

!

!

!

dial-peer voice 111 voip

destination-pattern 8611

session protocol multicast

session target ipv4:239.224.0.1:21086

codec g711ulaw

ip qos dscp cs5 media

vad aggressive

!

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password mypass

login

!

!

end

The thing is.. this works at the customer's, but does nothing whatsoever in the lab with the different hardware.

If I start sending audio to the multicast address, nothing happens on the router. Using "show ip mroute" I see that the router gets the multicast stream from the source, but that's it.

I get no output whatsoever when I activate debugging on the dialpeer (debug voip dialpeer all)..

since I do see the multicast (I also see the packets if I activate debugging on the interface), I'd figure that upon receiving some multicast traffic, I should see something on the dialpeer debugging, shouldn't I? Unfortunately I don't have access to the customer's system right now to see if something happens there, but this has my very confused. Plus there also doesn't seem to be anything in terms of debugging commands.

Has anybody any idea on how to track this down?

A "debug voip dialpeer all"

3 Replies 3

Not applicable

debug dial-peer

debug voip ccapi inout

Show vtsp call fsm

Show voice trace

These debug commands should help you out in dertmining the cause:

tgibson
Level 1
Level 1

couple of things...

you need to run a routing protocol like EIGRP and have your vif and your network advertised in them.

Also why do you have both ports with the same connection trunk and the same dial peer for both.

pcameron
Cisco Employee
Cisco Employee

You need to apply the voice class you have defined to the actual voice port being used for the LMR operation. Add the voice port command 'voice-class permanent 11'

Also try E&M type 5 operation as this more like a conventional Push to talk interface.

Here is a voice port config for a working LMR system -

!

voice-port 0/0/0

voice-class permanent 1

auto-cut-through

operation 4-wire

type 5

signal lmr

lmr e-lead voice

lmr duplex half

lmr led-on

no echo-cancel enable

no comfort-noise

timeouts call-disconnect 3

timing hangover 40

connection trunk 101

!

Change the connection trunk number to what you are using and see if it helps.