871 connected to a 3550 Catalyst

Answered Question
Nov 8th, 2007
User Badges:

I am looking to create 2 VLAN's. VLAN 1 will be tunneling through a VPN to our corporate office. VLAN10 will be used for contractors to access the internet. I need help configuring the VLAN trunking, DHCP to supply to both VLAN's. I supplied my running configs minus some information. Thanks for your help.



Correct Answer by Edison Ortiz about 9 years 6 months ago

on the router, enter this command:


sh int f0 switchport


You will see something like this


Administrative Trunking Encapsulation: dot1q


It won't show in the config because there is only one encapsulation option. If you had ISL as another option, it would be shown in the config.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Edison Ortiz Thu, 11/08/2007 - 15:05
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

On the 3550 switchport connected to the router:


interface FastEthernetx/x

switchport trunk encap dot1q

switchport mode trunk


On the router port connected to the 3550:


interface FastEthernetx

switchport

switchport trunk encap dot1q

switchport mode trunk


On the router DHCP pool


ip dhcp excluded-address 10.10.24.254

ip dhcp pool sdm-pool2

network 10.10.24.0 255.255.255.0

domain-name [domain name for contractors]

default-router 10.10.24.254

dns-server [dns server for contractors]

netbios-name-server [ditto]


NAT for that segment


interface Vlan10

ip address 10.10.24.254 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow


access-list 130 permit ip 10.10.24.0 0.0.0.255 any

obmis Fri, 11/09/2007 - 08:57
User Badges:

All entries went in with out a problem. Except the command on the router port connected to the 3550. In this case I am using interface fastethernet0. Switchport mode trunk works but am unable to do the switchport trunk encap dot1q. I can put it in but it does not seem to go into the running config. I saved the config and rebooted. Do I need a different IOS to support VLAN trunking? My reseller said no. Let me know. Thanks.

Current IOS c870-advsecurityk9-mz.124-11.XJ4.bin

Correct Answer
Edison Ortiz Fri, 11/09/2007 - 09:12
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

on the router, enter this command:


sh int f0 switchport


You will see something like this


Administrative Trunking Encapsulation: dot1q


It won't show in the config because there is only one encapsulation option. If you had ISL as another option, it would be shown in the config.

Actions

This Discussion