Cisco 1841 ADSL drops for a minute, can I debug?

Unanswered Question
Nov 9th, 2007

Hi, I have a Cisco 1841 ADSL in VPN mode, every now and then it will drop for a minute and come back. This can happen only once a day. The ADSL line provider can't see that the line is the problem, however is there some sort of debug I can run for a day or too to see what is happening?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Fri, 11/09/2007 - 01:46

You likely need to upgrade DSL firmware.

You can access the latest at

The one you want is 3.0.X, and there is a doc file that explain the installation procedure in detail.

Please remember to rate useful posts with the scrollbox below!

whiteford Fri, 11/09/2007 - 02:28

So it is:

Sh Dsl int:

SW Version: 3.8131

FW Version: 0x1A04

Worth an upgrade? If so I would have to try this over the internet and not console, high risk I guess.

Are there not debug commands to try as well?

whiteford Fri, 11/09/2007 - 04:23

I don't understand what you mean, It just came with an ADSL card from our supplier. Can I run a command for you?

Paolo Bevilacqua Fri, 11/09/2007 - 05:23


You have the older model WIC-1ADSL instead of the current HWIC-1ADSL that would accept firmware upgrade and is the recommended model for 1800 routers.

For WIC-1ADSL, I'm not aware of any possibility of upgrading firmware, per document:

You can enable the "dsl training logs", but I doubt it would bring to any improvement.

whiteford Fri, 11/09/2007 - 06:21

Thanks, it's only 3 months old too :(

Any newer ones I'll make sure I get HWIC. As I said it only drops for a minute and not too often.


This Discussion