Unable to establish ISDN BRI.

Answered Question
Nov 9th, 2007
User Badges:

Guys,


I have a 2651 with VIC 2B-S/T TE with 1 X BRI ISDN populated.


I am unable to estable layer 2.


Following message.


Layer 2 Status:

TEI = 255, Ces = 1, SAPI = 0, State = ESTABLISH_AWAITING_TEI


Please see the router config:


SHOW RUN

Building configuration...


Current configuration : 1708 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname AUC_GATEWAY

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

no aaa new-model

voice-card 0

dspfarm

no local-bypass

!

ip cef

!

!

--More-- !

!

no ip domain lookup

multilink bundle-name authenticated

isdn switch-type basic-net3

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

--More-- !

!

!

!

!

!

interface FastEthernet0/0

ip address x.x.x.x 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI1/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn layer1-emulate network

isdn incoming-voice voice

--More-- isdn bind-l3 ccm-manager service mgcp

!

interface BRI1/1

no ip address

shutdown

isdn switch-type basic-net3

isdn point-to-point-setup

!

!

ip http server

no ip http secure-server

!

!

!

control-plane

!

!

!

voice-port 1/0/0

compand-type a-law

cptone GB

!

voice-port 1/0/1

--More-- !

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server x.x.x.x

ccm-manager config

!

mgcp

mgcp call-agent x.x.x.x 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

--More-- !

!

!

line con 0

line aux 0

line vty 0 4

password Wellesb0urne

login

!

!

end


Please see the ISDN STATUS:


AUC_GATEWAY#


*Mar 2 02:12:55.357: ISDN BR1/0 Q921: User TX -> IDREQ ri=11550 ai=127[OK]

*Mar 2 02:12:57.356: ISDN BR1/0 Q921: User TX -> IDREQ ri=65279 ai=127

*Mar 2 02:12:59.359: ISDN BR1/0 Q921: User TX -> IDREQ ri=61168 ai=127

*Mar 2 02:13:01.948: ISDN BR1/0 Q921: User TX -> IDREQ ri=56817 ai=127

*Mar 2 02:13:03.947: ISDN BR1/0 Q921: User TX -> IDREQ ri=48386 ai=127

*Mar 2 02:13:05.950: ISDN BR1/0 Q921: User TX -> IDREQ ri=36131 ai=127

*Mar 2 02:13:11.964: ISDN BR1/0 Q921: User TX -> IDREQ ri=24404 ai=127




SDN BRI1/0 interface

dsl 0, interface ISDN Switchtype = basic-net3

L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 255, Ces = 1, SAPI = 0, State = ESTABLISH_AWAITING_TEI

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0













Correct Answer by AJAZ NAWAZ about 9 years 6 months ago

here, try out this config;


interface BRI0/3/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn static-tei 0

!

interface BRI0/3/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn static-tei 0


Please also 'compand-type a-law' under voice port. Of course replace the interface numbers with your own.


hth,

Ajaz


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
paolo bevilacqua Fri, 11/09/2007 - 01:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


Any chance you need "isdn static-tei 0" in that location? Common for DID and multi-BRI provisioning.


In any case, enable "debug isdn q921" and "term mon" to see what's going on in there.


Hope this helps, please rate post if it does!

Correct Answer
AJAZ NAWAZ Fri, 11/09/2007 - 02:56
User Badges:
  • Silver, 250 points or more

here, try out this config;


interface BRI0/3/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn static-tei 0

!

interface BRI0/3/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn static-tei 0


Please also 'compand-type a-law' under voice port. Of course replace the interface numbers with your own.


hth,

Ajaz


Actions

This Discussion