Traffics drop due to etherchannel

Unanswered Question
Nov 9th, 2007

Hi guys,

My client network is running on OSPF routing protocol.I was required to integrate one Multi-layer switch into the current network. Our client wanted a port-channel trunk to be configured for integration with the current live network.The first step taken by me was to ensure that the port-channel is up as it is just a directly connected network from the MLS to customer LAN switch. There are multiple trunk port on the LAN switch that carry the same Vlans as the port-channel trunk. Once the port-channel was configured, our customer complained that the network traffics dropped at one network element (Border Router). The Border Router is also connected to the same LAN switch. When i check the border router configuration, default information originate command parameter is configured and the static default route is pointing to one firewall which is also connected to the same LAN switch. When i check the newly-configured port-channel, there were a lot of output traffics but no input traffics. All the traffics come to the new MLS instead of going to the firewall. I wondered why this happened because ospf is not yet enable on the MLS interface. When i removed the port-channel and let it run on a single physical link, there is no service interruption. I have cleared the mac of that particular Vlans, changed switchport and changed cable but the problem still persist. Please help me on this as our customer is asking for the root cause. Please find the port-channel configuration as attached. The configuration of port-channel 5 on the LAN switch is similar to the port-channel 5 configured on the MLS.

interface Port-channel5

description EtherChannel for Gi Primary

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 150,152,154,164,182,188,190,192

switchport mode trunk

switchport nonegotiate

no ip address

!

interface FastEthernet0/42

description Connection-to-GGSH2-0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 150,152,154,164,182,188,190,192

switchport mode trunk

no ip address

switchport nonegotiate

duplex full

speed 100

channel-group 5 mode on

!

interface FastEthernet0/43

description Connection-to-GGSH2-0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 150,152,154,164,182,188,190,192

switchport mode trunk

no ip address

switchport nonegotiate

duplex full

speed 100

channel-group 5 mode on

SHTMSGSW1#sh int port-channel 5

Port-channel5 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 000d.65a4.5daa (bia 000d.65a4.5daa)

Description: EtherChannel for Gi Primary

MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,

reliability 255/255, txload 2/255, rxload 1/255

Encapsulation ARPA, loopback not set

Full-duplex, 100Mb/s

input flow-control is off, output flow-control is off

Members in this channel: Fa0/42 Fa0/43

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:01:41, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 2072000 bits/sec, 1441 packets/sec

1997329 packets input, 572096904 bytes, 0 no buffer

Received 489947 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 483945 multicast, 0 pause input

0 input packets with dribble condition detected

417112222 packets output, 1883053558 bytes, 0 underruns

0 output errors, 0 collisions, 12 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Thanks,

Sam

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ebreniz Thu, 11/15/2007 - 07:18

Are these drops incrementing regularly? If so you may need to add a third link to that etherchannel to accomodate the level of traffic. If not then this may be due to some previous (and abnormal) burst (could be due to a temporary spanning tree loop for example).

xcz504d1114 Thu, 11/15/2007 - 12:43

Theres not really a lot of information you provided, there is nothing wrong with your etherchannel configuration. I agree with ebreniz when he said it might be STP related.

From what i understood, you are concerned why the traffic is going to the MLS and not to the router anymore when you have both of your ports in the etherchannel connected. I would definately look at spanning tree. Link saturation should be logged as well, so if you have a syslog server setup or ciscoworks review the logs for any intermittent link saturation.

Actions

This Discussion