Unanswered Question
Nov 9th, 2007

i want to configure some mitel handsets to use LLDP Med, i have a cisco 3750 configured with LLDP default and CDP turned off. I can plug a mitel phone into the port and the phone boots in the voice vlan, i presume this is because i have the (switchport voice vlan 20) command on the port.

Question how do i modify the network policy in LLDP so it instructs the phone that i want to use a diffserv value of EF. The default voice policy show 802.1p 0 and diffserv 0 on the show lldp entry command.

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
msrohman Thu, 12/06/2007 - 19:41

I'm trying to do the same thing. I'll post when I get more information on it. Thus far, I haven't found a definitive TLV setting for marking the DSCP value.


littledavewhite Fri, 12/07/2007 - 13:01

Hi Mike

so i'm not alone on this one, i gave up in the end and configured the mitel kit via cdp and disabled LLDP on the cisco end. maybe cisco will have more functionality on this in later release.

I'll let you know if i find anything.

Dave white

CCIE #13955

richardmackie Wed, 08/25/2010 - 08:09

I realize that this is an old thread but I was wondering if you got any further with it?

I am using LLDP with NEC handsets and found you can use the Network-Policy command to assign DSCP/CoS values in LLDP.

The problem I have is that the Network Policy can not be assigned to a trunk port, I believe I need it to be a trunk port due to different VLAN tags for the phone and PC port.

And help would be appreciated.

Bryan Middleton Tue, 11/30/2010 - 07:40

Hi Richard

Did you manage to succeed with this? I know that you had said you could not use when configuring on a trunk but if you use the 'switchport voice vlan' command to assign the VLAN ID of the Voice VLAN this creates a 'special' dot1q trunk so you would then still be able to use the Network-Policy commands.

I have a customer who has some Mitel phones that they will be adding to their network and I have not used LLDP as of yet so wanted to check with you if it had done the job?



richardmackie Thu, 12/02/2010 - 02:33

Hi Bryan

Yes I managed to get it working :-)

As you say I used the 'voice vlan' command instead of setting as an actual trunk port.

I then set the required CoS/DSCP values in the Network Policy.

This was only lab testing rather than an actual customer but hopefully it helps you.




This Discussion