No ringback when calling a cellphone from CME

Unanswered Question
Nov 9th, 2007

I have CME running on a 3845 router with the latest CME code and correct IOS.

When a user dials out to a cell phone they do not hear any ringback but are able to connect to the cell phone and voice call proceeds fine. The VoIP user just never hears any ringback.

Is there a bug or something that Telco has to fix?

Seth

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Fri, 11/09/2007 - 15:06

Are you using PRI? If so please send output of "debug isdn q931" with "term mon". There are workaround commands, but I would like to see the call progress first.

srosenthal Mon, 11/12/2007 - 05:27

No, this site is using all BRI.

Here is the output from debug isdn q931. The first is for a call to cell phone and the second is a call to a land line.

2d16h: ISDN BR2/0/1 Q931: Applying typeplan for sw-type 0xC is 0x0 0x0, Calling

num 3025

2d16h: ISDN BR2/0/1 Q931: TX -> SETUP pd = 8 callref = 0x04

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x81

Preferred, B1

Keypad Facility i = '18045551212'

Calling Party Number i = 0x0080, '3025'

Plan:Unknown, Type:Unknown

2d16h: ISDN BR2/0/1 Q931: RX <- CALL_PROC pd = 8 callref = 0x84

Channel ID i = 0x89

Exclusive, B1

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x80880B, '18045551212', 0x8001098001148001148001

14

2d16h: ISDN BR2/0/1 Q931: RX <- INFORMATION pd = 8 callref = 0x84

Called Party Number i = 0x80, '18043477539'

Plan:Unknown, Type:Unknown

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x808300800114800114800114800114

2d16h: ISDN BR2/0/1 Q931: RX <- CONNECT pd = 8 callref = 0x84

Progress Ind i = 0x8482 - Destination address is non-ISDN

Nov 12 08:24:52 EST: %ISDN-6-CONNECT: Interface BRI2/0/1:1 is now connected to 1

8043477539 N/A

2d16h: ISDN BR2/0/1 Q931: TX -> CONNECT_ACK pd = 8 callref = 0x04

new_lexington_res#

Nov 12 08:24:58 EST: %ISDN-6-CONNECT: Interface BRI2/0/1:1 is now connected to 1

8043477539 N/A

Nov 12 08:25:07 EST: %ISDN-6-DISCONNECT: Interface BRI2/0/1:1 disconnected from

18045551212 , call lasted 14 seconds

2d16h: ISDN BR2/0/1 Q931: TX -> DISCONNECT pd = 8 callref = 0x04

Cause i = 0x8090 - Normal call clearing

2d16h: ISDN BR2/0/1 Q931: RX <- RELEASE pd = 8 callref = 0x84

2d16h: ISDN BR2/0/1 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x04

new_lexington_res#

2d16h: ISDN BR2/0/1 Q931: Applying typeplan for sw-type 0xC is 0x0 0x0, Calling

num 3025

2d16h: ISDN BR2/0/1 Q931: TX -> SETUP pd = 8 callref = 0x03

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x81

Preferred, B1

Keypad Facility i = '18045551211'

Calling Party Number i = 0x0080, '3025'

Plan:Unknown, Type:Unknown

2d16h: ISDN BR2/0/1 Q931: RX <- CALL_PROC pd = 8 callref = 0x83

Channel ID i = 0x89

Exclusive, B1

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x80880B, '18045551211', 0x8001098001148001148001

14

2d16h: ISDN BR2/0/1 Q931: RX <- ALERTING pd = 8 callref = 0x83

Progress Ind i = 0x8288 - In-band info or appropriate now available

Signal i = 0x01 - Ring back tone on

2d16h: ISDN BR2/0/1 Q931: RX <- CONNECT pd = 8 callref = 0x83

Signal i = 0x3F - Tones off

Nov 12 08:23:38 EST: %ISDN-6-CONNECT: Interface BRI2/0/1:1 is now connected to 1

8045551211 N/A

2d16h: ISDN BR2/0/1 Q931: TX -> CONNECT_ACK pd = 8 callref = 0x03

Nov 12 08:23:44 EST: %ISDN-6-CONNECT: Interface BRI2/0/1:1 is now connected to 1

8045551211 N/A

Nov 12 08:23:51 EST: %ISDN-6-DISCONNECT: Interface BRI2/0/1:1 disconnected from

18043597070 , call lasted 12 seconds

2d16h: ISDN BR2/0/1 Q931: TX -> DISCONNECT pd = 8 callref = 0x03

Cause i = 0x8090 - Normal call clearing

2d16h: ISDN BR2/0/1 Q931: RX <- RELEASE pd = 8 callref = 0x83

2d16h: ISDN BR2/0/1 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x03

srosenthal Mon, 11/12/2007 - 10:35

I was already given that document by a co-worker and tried those steps with no success.

Seth

srosenthal Mon, 11/12/2007 - 11:00

dial-peer voice 145 pots

corlist outgoing call-domestic

description dial peer for PSTN LongDistance

preference 1

destination-pattern 91[2-9]..[2-9]......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 2/0/1

forward-digits 11

Paolo Bevilacqua Mon, 11/12/2007 - 11:39

Hi,

per document you should be sending PI 3 in setup, this is not happening. Which exact IOS is this

Do you have "voice rtp send-recv" in global config ?

Can you try "tone ringback alert-no-pi" please ?

srosenthal Mon, 11/12/2007 - 12:00

The IOS is c3845-advipservicesk9-mz.124-11.XW1.bin

I did not have the "voice rtp send-recv" in global config but I added it with no luck.

Here is the dial-peer now.

dial-peer voice 145 pots

corlist outgoing call-domestic

tone ringback alert-no-PI

description dial peer for PSTN LongDistance

preference 1

destination-pattern 91[2-9]..[2-9]......

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 2/0/1

forward-digits 11

Paolo Bevilacqua Mon, 11/12/2007 - 12:54

Hi,

XW1 has been deferred, can you try latest XW4 or XJ4. I'm not positive that it would solve, but it's worth a try.

xiayunduan Sun, 11/18/2007 - 21:31

i have a 3845,running ios 12.4.12b

with fxo connecting to pbx

and no ringback tone too!

Actions

This Discussion