Problem with MTP Registration

Unanswered Question
Nov 9th, 2007
User Badges:

I am trying to register an IOS S/W MTP from a 2811 to the CallManager, but it won't register. In CM, I have:


Media Termination Point: mtp001794608e30

Media Termination Point Type Cisco IOS Enhanced Software Media Termination Point


In the gateway, I have:

voice-card 0

no dspfarm

dsp services dspfarm

!

sccp local Vlan210

sccp ccm X.X.X.X identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register mtp001794608e30


!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 500

associate application SCCP


RTR#sh sccp

*Nov 9 23:44:49.475: %SYS-5-CONFIG_I: Configured from console by console

SCCP Admin State: UP

Gateway IP Address: X.X.X.X, Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: X.X.X.X, Port Number: 2000

Priority: N/A, Version: 3.1, Identifier: 1


Software MTP Oper State: ACTIVE_IN_PROGRESS - Cause Code: NOT_REGIS_WITH_CCM

Active Call Manager: X.X.X.X, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 1

Reported Max Streams: 1000, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30


----------------------------

//Show Diag:

PVDM Slot 0:

32-channel (G.711) Voice/Fax PVDMII DSP SIMM PVDM daughter card

Hardware Revision : 3.1

Part Number : 73-8539-03

Board Revision : A0

Deviation Number : 0

Fab Version : 03

PCB Serial Number : FOC08321BU1

RMA Test History : 00

RMA Number : 0-0-0-0

RMA History : 00

Processor type : 00

Product (FRU) Number : PVDM2-32

Version Identifier : NA

EEPROM format version 4

EEPROM contents (hex):

0x00: 04 FF 40 03 EE 41 03 01 82 49 21 5B 03 42 41 30

0x10: 88 00 00 00 00 02 03 C1 8B 46 4F 43 30 38 33 32

0x20: 31 42 55 31 03 00 81 00 00 00 00 04 00 09 00 CB

0x30: 88 50 56 44 4D 32 2D 33 32 89 4E 41 20 20 D9 02

0x40: 40 C1 FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF


WIC Slot 0:

T1 (1 port) Multi-Flex Trunk WAN daughter card

Hardware revision 1.0 Board revision F0

Serial number 33087017 Part number 800-03568-03

FRU Part Number VWIC-1MFT-T1=

Test history 0x0 RMA number 00-00-00

Connector type PCI

EEPROM format version 1

EEPROM contents (hex):

0x20: 01 20 01 00 01 F8 DE 29 50 0D F0 03 00 00 00 00

0x30: 78 00 00 00 04 12 20 00 FF FF FF FF FF FF FF FF


WIC Slot 1:

Serial 1T WAN daughter card

Hardware revision 1.0 Board revision J0

Serial number 19618527 Part number 800-01514-01

FRU Part Number WIC-1T=

Test history 0x0 RMA number 00-00-00

Connector type Wan Module

EEPROM format version 1

EEPROM contents (hex):

0x20: 01 02 01 00 01 2B 5A DF 50 05 EA 01 00 00 00 00

0x30: 98 00 00 00 00 05 15 01 FF FF FF FF FF FF FF FF


//sh ver:

Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9_IVS-M), Version 12.4(8c), RELEASE SOFTWARE (fc3)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
allan.thomas Fri, 11/09/2007 - 17:16
User Badges:
  • Blue, 1500 points or more

The main caveat with IOS resources is ensuring that the MTP name within CallManager is the same name assigned to the MTP profile, which I believe from your post it is.


I would also try specifying the CCM version after the following command:-


sccp ccm X.X.X.X identifier 1


Regards

Allan.


HTH.

dual_line Wed, 11/05/2008 - 03:14
User Badges:

Thanks Allan, you fixed my issue! The lack of a version number prevented my S/W MTP from registering with CCM.

allan.thomas Wed, 11/05/2008 - 03:21
User Badges:
  • Blue, 1500 points or more

Good to see that previous posts are still providing the necessary help. Glad to see that it resolved your problem. Best of luck.


Allan.

Aaron Dhiman Tue, 11/13/2007 - 06:54
User Badges:

I believe I've done everything except for


gateway

timer receive-rtp seconds


And I don't think those are required in this situation. Also, I have no problems registering the hardware DSPs, just the software IOS MTP. I am trying to use it for SIP RFC2833.

allan.thomas Tue, 11/13/2007 - 07:24
User Badges:
  • Blue, 1500 points or more

I have notice from the configuration you provided in an earlier post that under the voice-card configuration you have 'no dspfarm'.


To add a specified voice card to those participating in a digital signal processor (DSP) resource pool, use the dspfarm command in voice-card configuration mode.


voice-card 0

dspfarm

dsp services dspfarm


I have had similar issue with profiles registering in the past with 12.4(9)T1, and after configuring the voice-card as above they register successfully.


Take a look at the following link, it provides examples for troubleshooting DSP Farm registration.


http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080108fe6.shtml


Regards

Allan.

Actions

This Discussion