"ip routing" not available on CAT 6500?

Unanswered Question
Nov 10th, 2007

I was trying to issue a global command "ip routing" to enable inter-VLAN routing on a Cisco 6504 running IOS. But "ip routing" does not seem to be a valid command. Please advise the reason and alternatives.

#show ver

Cisco Internetwork Operating System Software

IOS (tm) s3223_rp Software (s3223_rp-ADVIPSERVICESK9_WAN-M), Version 12.2(18)SXF8, RELEASE SOFTWARE (fc2)


6504#show mod

Mod Ports Card Type Model Serial No.

--- ----- -------------------------------------- ------------------ -----------

1 9 Supervisor Engine 32 8GE (Active) WS-SUP32-GE-3B SAL1035ZRWM

3 48 48-port 10/100/1000 RJ45 EtherModule WS-X6148A-GE-TX SAL1052CDV6

Mod MAC addresses Hw Fw Sw Status

--- ---------------------------------- ------ ------------ ------------ -------

1 0017.94c1.58f0 to 0017.94c1.58fb 4.5 12.2(18r)SX2 12.2(18)SXF8 Ok

3 001a.a2b2.c930 to 001a.a2b2.c95f 1.5 8.4(1) 8.5(0.46)RFW Ok

Mod Sub-Module Model Serial Hw Status

---- --------------------------- ------------------ ----------- ------- -------

1 Policy Feature Card 3 WS-F6K-PFC3B SAL1034ZHWU 2.3 Ok

1 Cat6k MSFC 2A daughterboard WS-F6K-MSFC2A SAL1035ZM8B 3.1 Ok

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
jackawang Sat, 11/10/2007 - 10:54

It says the command "ip routing" does not exist. I am in EXEC mode.

6504#config t

Enter configuration commands, one per line. End with CNTL/Z.

6504(config)#ip routing


% Invalid input detected at '^' marker.

andrew.butterworth Sat, 11/10/2007 - 11:14

I noticed this the other day when I was setting up a Sup720 in the lab. The issue (if you can call it an issue) is you can't disable IP routing on the 6500 running Native IOS so it is always enabled and can't be disabled. Type 'show ip route' and there will be a routing table (assuming you have at least one interface with an IP address).



ddemirchi Sat, 11/10/2007 - 10:57

turn on Cisco's Express Forwarding (CEF)

- ip cef

then try ip routing?

glen.grant Sat, 11/10/2007 - 11:09

It may be you can't turn it off so there is no command to turn it on . never really tied to turn it off on the new 720's though we do it all the time on our 4500's.

glen.grant Sat, 11/10/2007 - 11:12

It may be you can't turn it off so there is no command to turn it on . never really tied to turn it off on the new 720's though we do it all the time on our 4500's.

jackawang Sat, 11/10/2007 - 11:25

1. Unless I missed something, I am sure it is running IOS not CatOS.

6504#show ver

Cisco Internetwork Operating System Software

IOS (tm) s3223_rp Software (s3223_rp-ADVIPSERVICESK9_WAN-M), Version 12.2(18)SXF8, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by cisco Systems, Inc.

Compiled Fri 02-Mar-07 21:02 by tinhuang

Image text-base: 0x40101040, data-base: 0x42D30000

2. "ip cef" is enabled. It did not solve the issue.

3. Assuming you cannot turn off "ip routing" on, it makes sense because it does show routing tables.

6504#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 63.xx.xx.209 to network is subnetted, 1 subnets

S [1/0] via is subnetted, 5 subnets

C is directly connected, Vlan10

C is directly connected, Vlan4

C is directly connected, Vlan5

C is directly connected, Vlan2

C is directly connected, Vlan999 is subnetted, 1 subnets

C 63.xx.xx.208 is directly connected, Vlan3

S* [1/0] via

Now the question is how I can enable inter-VLAN routing? I am not able to ping a host on different VLAN. Please advise.

6504#show ip interface bri

Interface IP-Address OK? Method Status Protocol

Vlan1 unassigned YES NVRAM administratively down down

Vlan2 YES NVRAM up up

Vlan3 63.xx.xx.219 YES NVRAM up up

Vlan4 YES NVRAM up up

Vlan5 YES NVRAM up up

Vlan10 YES NVRAM up up

Vlan999 YES NVRAM up up

GigabitEthernet1/1 unassigned YES unset up up

GigabitEthernet1/2 unassigned YES unset up up


Harold Ritter Sat, 11/10/2007 - 11:28

If you want to ping from one vlan to the other, make sure that the default gateway on the hosts on these vlans is set to the IP address of their respective vlan interface.

Hope this helps,

jackawang Sat, 11/10/2007 - 11:32

All host's default gateways are set to the IP address of their respective VLAN interface already. In my case, 172.16.xx.1.

andrew.butterworth Sat, 11/10/2007 - 11:36

Sounds a bit bizarre.... Check the ARP cache on your PC for the gateway, make sure it is the 6500's MAC address for that VLAN. Try some traceroutes from your PC. It's not just XP's firewall is it?


ddemirchi Sat, 11/10/2007 - 11:56

Where are the hosts?

- different building or they are directly connection to 6504?

- check trunking

- check vlan pruning

- check vtp domain on the other switches.

check access switch;

- switch mode access

- switch acc vlan x

DHCP Scope configured?

- are you able to get IP address on host? or u r assigning static? check subnet mask, de.gateway...

ddemirchi Sat, 11/10/2007 - 11:32

If you are running hybrid; L2; sup1,2,320,720

When you telnet;

Cisco Systems Console

Username: username


c6504-sw> (enable)

c6504-sw> (enable)session 15 or 16...etc.

User Access Verification

Username: username





ddemirchi Sat, 11/10/2007 - 11:41

are you running any type of routing protocol?

an example;

router eigrp 1

network 10.x.x.x

network x.x.x.x

no auto-summary

!ip classless

no ip forward-protocol nd

no ip forward-protocol udp tftp

no ip forward-protocol udp nameserver

no ip forward-protocol udp domain

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

ip route x.x.x.x ; if you have pix or depand on your network topology

ip route x.x.x.x x.x.x.x ; if you have pix or depand on your network topology

no ip http server ; to run off your http svr

or you can route it STATIC;

by ip route IP; x.x.x. Sub.Mask; x.x.x.x to destination...

Can you send us "show run" on supx and MSFC?

and if it is possible your network topology?

Harold Ritter Sat, 11/10/2007 - 11:43

The two vlans are directly connected to the 6500. There is no need for a routing protocol in this scenario.


jackawang Sat, 11/10/2007 - 12:00

To summarize my test, I have a host on VLAN99 and I try to ping the GW(6500) and other hosts on diffrent VLAN.

From host

Ping -- OK (implies it can reach the gateway 6500)

Ping -- OK (impies it can reach the other host on same VLAN)

ping -- OK (implies it can reach the gateway 6500)

ping -- timeout (implies it cannot reach the other host on different VLAN)

From the 6500, I can ping every hosts on every VLANs. My understanding from the test results is that the inter-VLAN routing is not working. Please kindly advise.

Harold Ritter Sat, 11/10/2007 - 12:08

There is nothing additional you need to do to enable inter-vlan routing. I would double-check the default gateway setting on the second workstation and as mentioned by another poster, I would check if XP FWs are enabled and preventing icmp from other subnets.


Jon Marshall Sat, 11/10/2007 - 12:09


Can you post

1) Output of ipconfig from both PC's

2) The interface vlan configuration of vlan99 and the other vlan.

3) Ouput of "sh ip route" on 6500

4) Can you also confirm that both ports that connect to the 6500 for the PC's are in their respective vlans.


glen.grant Sat, 11/10/2007 - 12:32

Ip routing is working if you can ping the router interface 10.1 from .99 subnet . Check the default gateway on the device that won't ping and also that the subnet mask matches the router for that subnet .

jackawang Sat, 11/10/2007 - 12:42

Okay, here comes the tricky part.

My laptop(Host A) has an single NIC on VLAN99:




HostB has multiple NICs on different VLANs:




HostB's default gateway is set to

HostA and HostB can both reach it's default gateway. But HostA and B cannot ping each other. Please advise.

Jon Marshall Sat, 11/10/2007 - 12:44

Can you post the output of the following command from a cmd prompt on Host B

netstat -nr


ddemirchi Sat, 11/10/2007 - 12:57

I seen this problem before....

Your current issue is with Windows NIC Bindings.

- control panel

- open network connection

- click on Advanced from tool-bar

- Select Advaned settings

- Move UP/Down NIC for the first or use for your network.

jackawang Sat, 11/10/2007 - 14:01

I had no default gateway set on HostB! Once the gw is set, everything worked like charm! Thanks to everyone and apologies for my careless.

This leads me to think of an interesting issue -- if "ip routing" is enabled by default and is unable to disable, what if I want to turn it off?

ohassairi Sat, 11/10/2007 - 20:37

if you want to remove inter-vlan routing remove interfaces vlan X

(config)# no interface vlan 10

in your switch or use access lists.


This Discussion