cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
418
Views
10
Helpful
6
Replies

Using WAN DHCP, 4/5 pings ARP

pnielsen
Level 1
Level 1

I am using a cable modem connected to fa0/1 using DHCP on a 2621. I read that first ping is lost due to an ARP lookup. It seems to do a lookup on every address, including public IPs. It is causing every web page request to be delayed.

Config:

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router2621

!

boot-start-marker

boot-end-marker

!

enable password 7

!

no aaa new-model

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.99

!

ip dhcp pool 1

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

ip audit po max-events 100

!

!

username Pat password 7

!

!

interface FastEthernet0/0

description Local Network

bandwidth 1200

ip address 192.168.1.1 255.255.255.0

ip nat inside

duplex auto

speed 100

!

interface FastEthernet0/1

description connected to Internet

ip address dhcp

ip nat outside

duplex auto

speed auto

!

ip nat log translations syslog

ip nat inside source list 7 interface FastEthernet0/1 overload

ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

!

access-list 7 permit 192.168.1.0 0.0.0.255

access-list 100 permit udp any any eq bootpc

!

snmp-server community private RW

snmp-server enable traps tty

!

!

!

!

!

line con 0

exec-timeout 0 0

password 7

login

line aux 0

line vty 0 4

password 7

login

!

end

2 Accepted Solutions

Accepted Solutions

Jon Marshall
Hall of Fame
Hall of Fame

Hi

It's your default-route that is doing it

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

If your default-route was changed to be

ip route 0.0.0.0 0.0.0.0 "next-hop IP"

then your router would not need to arp for all destinations just the next-hop IP address. But because you have told it the default-route is out of the fa0/1 interface your router will arp out for all destinations.

Do you know what the next hop should be ?. If so change your default-route entry as in example above.

HTH

Jon

View solution in original post

Hi,

you should replace "FastEthernet0/1" or gateway address in 0.0.0.0 default route with "dhcp". If "command error", then need to upgrade IOS.

In recent code, you don't need to configure the default route at all.

In any case, you also don't need "default-router" that is only for when routing is disabled.

Moreover you don't even need:

ip dhcp excluded-address 192.168.1.1 192.168.1.99

as the roueter will never assign his own address via dhcp.

Hope this helps, please rate post if it does!

View solution in original post

6 Replies 6

Jon Marshall
Hall of Fame
Hall of Fame

Hi

It's your default-route that is doing it

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

If your default-route was changed to be

ip route 0.0.0.0 0.0.0.0 "next-hop IP"

then your router would not need to arp for all destinations just the next-hop IP address. But because you have told it the default-route is out of the fa0/1 interface your router will arp out for all destinations.

Do you know what the next hop should be ?. If so change your default-route entry as in example above.

HTH

Jon

I did the command, show dhcp lease

I used the temp default gateway that was in the lease. Works great thanks. Is there a way to have it dynamic? I'm not sure how offen ISP would change that but just curious.

Glad it helped.

Default-gateway should not change as long as ISP is leasing out of the same subnet range but it is worth talking to them to find out.

Jon

Hi,

you should replace "FastEthernet0/1" or gateway address in 0.0.0.0 default route with "dhcp". If "command error", then need to upgrade IOS.

In recent code, you don't need to configure the default route at all.

In any case, you also don't need "default-router" that is only for when routing is disabled.

Moreover you don't even need:

ip dhcp excluded-address 192.168.1.1 192.168.1.99

as the roueter will never assign his own address via dhcp.

Hope this helps, please rate post if it does!

1-99 are static set devices and computers. default router was left over trying routing to fix this. I thought I had 12.2 and it didn't have dhcp as an option. It worked in 12.3 which i tried previously tried before. Thank you ip route 0.0.0.0 0.0.0.0 DHCP is working like a champ.

woops I didn't looked the excluded address correctly. that included router address and is all good as well.

Glad to know it helped, please remember to rate posts using the scrollbox below!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: