SRST does not kick in

Unanswered Question
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Markus Schneider Mon, 11/12/2007 - 08:42

Do you mean that phones don't register to the SRST router, or the PRI doesn't come up or something? For phones, you need to make sure you have a supported phone and phone load. The phone's config file from the CCM server must tell the phone to use an SRST reference or default gateway as the SRST server. Then SRST has to be configured (minimum call-mananger-fallback; ip source...; max ephone; and max dn's defined).

AJAZ NAWAZ Mon, 11/12/2007 - 09:24

Here see this example for the gateway:


ip source-address port 2000

max-ephones 50

max-dn 100

Next, the link for MGCP gateway set-up on CCM:


And finally verify SRST on Callmanager:




AJAZ NAWAZ Mon, 11/12/2007 - 10:09

I just wanted to add one other thing for the sake of completeness, and that was important but commonly made mistake too.

When you configure the SRST reference point in callmanager, the IP address should be default GW address for the IP phones on the branch office LAN

Secondly, the command:

ip source-address port 2000 <-- this is the same address as mentioned above and as you know the command is applied to the MGCP gateway.

keep us updated hey - i'm sure this can be sorted.


dconstantino Mon, 11/12/2007 - 12:19

Also if you have the default gateway statement in SRST you can just set the SRST ref in CCM to gefault gateway and you do not have to set the IP address.


max-conferences 6 gain -6

transfer-system full-consult

limit-dn 7940 2

limit-dn 7960 2

timeouts interdigit 5

ip source-address 10.X.X.1 port 2000 -----> This is the default Gatewat of my CCM Subnet not the router LAN segment. That way if you have a lot of sites this config iis static.

Then in CCM Pub set the SRST Ref to Default Gateway in the drop down box.

mohammednw Tue, 11/13/2007 - 04:45

how abt the call application alternate default command....

is it configured?

allan.thomas Tue, 11/13/2007 - 08:55

One other possibility is whether you have ISDN backup or another secondary link configured in the event that your serial fails?

The reason is that the gateway will be still be able to register with CallManager as will your IP phones.

If this is the case then you will need to create an ACL to block inbound mgcp and sccp from your CallMangers.



a.gooding Tue, 11/13/2007 - 12:56

what CCM version are you running?

what is the SRST version on the router ?

had a similiar issue (i didnt read the compatibility matrix). we installed CCM 5.X but had our routers on SRST version 3.3 phones would not register until i upgraded to SRST 4.0. after that all phones worked.

You issue probably isnt as basic as this but then again you never know.

The SRST version is 3.3 and CCM is 4.1(3)sr2. Here is SRST config.

ip source-address port 2000

max-ephones 240

max-dn 500

max-conferences 8 gain -6

dspfarm units 0

dspfarm transcode sessions 0


voicemail 900xxxxxxxxxxxx

time-format 24

date-format dd-mm-yy

timezone 0 Greenwich Standard Time

call-forward busy 900xxxxxxxxxxxx

call-forward noan 900xxxxxxxxxxxx timeout 20

transfer-pattern 2....

keepalive 30

timeout interdigit 5

timeout busy 10

timeout ringing 180

caller-id name-only: enable

Limit number of DNs per phone:

7910: 36

7935: 1

7936: 36

7940: 36

7960: 34

7970: 36

Log (table parameters):

max-size: 150

retain-timer: 15

local directory service: enabled.

We have two router linked to two provider. It worked on one router with similiar config. If i unplug the serial cable , SRST kicks in on the primary router and works fine. But, on the second router, it does kick in and show ccm-manager host command shows connected to CCM also no failover enabled on show ccm-manager fallback.

Wonder it is IOS issue or need to upgrade to new SRST version.


allan.thomas Wed, 11/14/2007 - 01:49

As previous mentioned is there a possibility of alternate path to CallManager? When you iniate a 'show ccm-manager' that Primary, Secondary and teriary if set should be state DOWN. If this is not the case when you remove the serial, then I would conclude that there is an alternate route.

Please could you verify via traceroute whether you are able to reach either CCM when the serial is down. If this not the case then the underlying issue within IOS? Incidentally the other gateway which you stated that it worked is this the same IOS?



AJAZ NAWAZ Wed, 11/14/2007 - 02:40

Make sure that you issue the trace from the Voice vlan interface, and not from the WAN interface, or the interface closest to CCM.

You with me?


allan.thomas Wed, 11/14/2007 - 03:31

Absolutely, issue an extended trace and specifiy the source address as the data/voice vlan interface for your FE or GIG int connecting to the LAN.

Incidentally, please can you confirm that you have configured 'ccm-manager fallback-mgcp' command.

Can you post the 'show ccm-manager' output, this would indicate the state of MGCP Fallback mode,whether it is enabled or disabled.



allan.thomas Wed, 11/14/2007 - 16:49

What is perculiar is the fact that the both gateways are running the same IOS and almost identical configurations, yet the gateway fails to fallback.

Could you also trying reloading the MGCP application, run 'no mgcp' and then 'mgcp', what is the status of the primary and secondary CallManager under 'show ccm-manager' afterwards?

Incidentally, I have certainly looked into known caveats pertaining to 12.4(3g) and SRST and unfortunately there were no specific matches.

I have also verfied compatibility and support for SRST v3.3 on the platform and feature set, and as I suspected there issues.



allan.thomas Thu, 11/15/2007 - 01:42

I apologies the last sentence should have read that there were no issues, v3.3 is clearly supported on 12.4.3g IPAdvSvs and the 3845.

Sorry, my fingers cannot seem to keep up with my brain.




This Discussion